Bug Report OBS Crashes on iSight camera open macOS 10.15 Catalina

Interestingly the crash log specifies Thread #1 as the source of the crash, specifically:

Code:
3   com.apple.TCC                     0x00007fff650bb219 __CRASHING_DUE_TO_PRIVACY_VIOLATION__ + 163

This is a long shot, with Catalina still in Beta and such, but maybe add OBS to the list of apps that are allowed to access the webcam (if such a thing exists in Catalina).

As neither OBS nor QT is ready for Catalina, I wouldn't be surprised if OBS just connects to the webcam without checking for permissions first.
 

prado

New Member
Latest OBS fully works on latest Catalina 10.15 Beta (19A546d) [video capture on integrated camera, audio output capture, integrated mic capture, etc..] if you start it from the command line:

On terminal, just run:
/Applications/OBS.app/Contents/MacOS/OBS

You will be asked to give Camera and Mic permissions after starting (the first time only), no crashes while configuring camera, and no crashes at all. Fully working.
 

ricostarr

New Member
After following your instructions, I am able to run OBS but only through terminal. now when I boot it normally through the app icon, it instantly crashes. doesn't even launch all the way.
 

Attachments

  • obs_2019-10-18-165250.txt
    96.9 KB · Views: 107

Leon_Noel

New Member
I can run through OBS through Terminal, however: Terminal OBS can capture the built-in FaceTime Cam and can capture the Built-In Microphone and Desktop Audio using the iShowU method that's posted on here. However, it can't broadcast the visuals of your Desktop or Windows.
When I run OBS normally, the opposite true, I get visuals with no audio or FaceCam. I'm a bit bummed that I wasted my Friday afternoon trying to figure this all out. At least the idea of streaming got me to excited.

EDIT: I got this to work! Underneath all my windows, there was the message asking permission to use the camera I think so that it could show the screen. :)
 
Last edited:

Fish80

New Member
I had similar problems but now works through Terminal. BUT when I try to add the "Window capture" I don't find for example my Safari or Power Point windows from the Window list. Only OBS and Windows desktop are on the list. Any solution? Thanks

EDIT: Found solution. On the "Security and Privacy" settings add the "Terminal" to the "Full disk access"
 
Last edited:

kurtau22

New Member
I was able to get OBS to ask for permission to use the camera when I started from Terminal, but now it won't start by just trying to open the app. I have tried everything listed above and reinstalled OBS. Any ideas?
 

2020k

New Member
Is there a reason, in Catalina, that OBS only opens correctly through the Terminal? Is there a fix?

I bookmarked this page so I know the command to open it, but it seems like such an inconvenient method to opening a normal software program.

Just like other users, I can open it through the app button, but it crashes when I choose to use my webcam and doesn't pick up audio.
 
Top