OBS branch with AMD VCE support.

BioGenx2b

Member
Right, missed that option. x264 sets it to 4.1 too.

2015-01-07 [32bit] [64bit]: AMF profile level to 4.1

Thanks! I'll test this right now! http://twitch.tv/BioGenx2b

Edit: Just tested on my phone, it's listed again under Search > People as broadcasting! Thanks so much, Jackun!

The other problem now is that audio doesn't always play. I had the same issue before, only occurs when watching with the app. Maybe something about how VCE is encoding the audio? Audio profile might not match what x264 uses?

edit2: Changed audio encoding from MP3 to AAC and that seems to have fixed audio playback. No biggie there, though maybe that should be mentioned somewhere, unless it's a code issue.
 
Last edited:

dping

Active Member
Screenshots: http://imgur.com/a/SXK5Y

The Level=4.1 was a recommendation by Xangold before he realized I was using a different encoder. He was telling me that VCE was sending Video 4.2, which Twitch app by default doesn't list because it's not compatible with some older, supported devices.
Sounds right so I think we're all in the right ballpark. Other thoughts is that your GOP is a bit large; typical is 30 or 60 for 60fps video. I prefer 30 since that is the youtube recommendation to be half the fps just for all out compatibility reasons.

it should be noted that my phone is a windows 8.1 using a third party twitch app which doesn't seem to have the same mobile restrictions of the official twitch mobile apps.
 

BioGenx2b

Member
Sounds right so I think we're all in the right ballpark. Other thoughts is that your GOP is a bit large; typical is 30 or 60 for 60fps video. I prefer 30 since that is the youtube recommendation to be half the fps just for all out compatibility reasons.

it should be noted that my phone is a windows 8.1 using a third party twitch app which doesn't seem to have the same mobile restrictions of the official twitch mobile apps.

I hit the Quality button, that's it. What benefit would I have for reducing it?
 

HA6

New Member
So, you are using CQP for streaming? CQP bitrate can and will go way over 3000-4000kbit/s. You're better off using CBR for streaming (but then of course it will be blockier).
E: Lel, I can't read. Anyway, plain file looks fine to me (my laptop hates flash).
edit edit: Flash 11 seems to stutter and flash 15 throws some green in at IDRs (keyframes), hmm.
Try this build.

If I'll remember, I'll go through the thread and link some settings etc posts links to OP, maybe.

@HA6 what's your scene setup? Only using game capture? Upload log file where you recorded with Speed preset and "Disable D3D11 Opencl interop." unchecked, just in case.
Thanks fot replay~

AMF
http://youtu.be/Fii0vGF_yIw

My settings
http://i.imgur.com/uc3HMdp.png
http://i.imgur.com/t6SZ47r.png
http://i.imgur.com/WPCUIBq.png
http://i.imgur.com/hgG0GYi.png
http://i.imgur.com/bSXwGrO.png

And my CPU is E3-1230V3 (4C8T)
 

Attachments

  • 2015-01-07-2205-03.log
    19.8 KB · Views: 16

jackun

Developer
@HA6 Something weird happens with high bitrate and with cbr padding enabled. It starts out fine but suddenly buffer submission gets really slow. Probably set "Engine Type" back to DX11 and either uncheck CBR padding or select CQP / use Quality Balance.
 

Lucil

Member
So, you are using CQP for streaming? CQP bitrate can and will go way over 3000-4000kbit/s. You're better off using CBR for streaming (but then of course it will be blockier).
E: Lel, I can't read. Anyway, plain file looks fine to me (my laptop hates flash).
edit edit: Flash 11 seems to stutter and flash 15 throws some green in at IDRs (keyframes), hmm.
Try this build.

If I'll remember, I'll go through the thread and link some settings etc posts links to OP, maybe.

@HA6 what's your scene setup? Only using game capture? Upload log file where you recorded with Speed preset and "Disable D3D11 Opencl interop." unchecked, just in case.

seems to have fixed it
is it included in the 2015-01-07 build as well?
 

HA6

New Member
@HA6 Something weird happens with high bitrate and with cbr padding enabled. It starts out fine but suddenly buffer submission gets really slow. Probably set "Engine Type" back to DX11 and either uncheck CBR padding or select CQP / use Quality Balance.

I set it like you say and useing CQP (I aslo change my buffer to 50000 same like my bitrate)
Fist time OPS crash second try my System crash ...

==================================================
Dump File: 010815-51573-01.dmp
When the machine time: 2015/1/8 01:59:26 PM
Program error checking string:
Program error checking code: 0x00000116
Parameter 1: fffffa80`0cba44e0
Parameter 2: fffff880`090fa848
Parameter 3: 00000000`00000000
Parameter 4: 00000000`00000002
Driver caused: dxgkrnl.sys
Address the cause: dxgkrnl.sys + 5d134
File Description: DirectX Graphics Kernel
Product name: Microsoft® Windows® Operating System
Company: Microsoft Corporation
File Version: 6.1.7601.18510 (win7sp1_gdr.140615-1511)
Processor: x64
When the machine address: ntoskrnl.exe + 75bc0
Stacking address 1:
Stacking address 2:
Stacking address 3:
Computer Name:
Full path: C: \ Windows \ Minidump \ 010815-51573-01.dmp
Processor: 8
Major versions: 15
Minor version: 7601
Dump File Size: 375,152
Dump File time: 2015/1/8 02:03:10 PM
==================================================

(All of my drive is newest)
 

Attachments

  • 2015-01-08-1358-55.log
    3.7 KB · Views: 16
  • OBSCrashDump2015-01-08_1.dmp
    571.6 KB · Views: 14
  • OBSCrashLog2015-01-08_1.txt
    4.9 KB · Views: 16
Last edited:

HA6

New Member
@HA6 Something weird happens with high bitrate and with cbr padding enabled. It starts out fine but suddenly buffer submission gets really slow. Probably set "Engine Type" back to DX11 and either uncheck CBR padding or select CQP / use Quality Balance.

This is CBR other setting set like you say
http://youtu.be/tVCkVEn7E90

It is still stuck
 

Attachments

  • 2015-01-08-1449-02.log
    47.5 KB · Views: 16

jackun

Developer
@Lucil yes.

@HA6 Something strange going on with colorspace conversion:
15:51:48: video thread frame - [100%] [avg time: 295.03 ms] [children: 99.9%] [unaccounted: 0.0658%]
15:51:48: | scene->Preprocess - [0.000339%] [avg time: 0.001 ms]
15:51:48: | GPU download and conversion - [99.9%] [avg time: 294.835 ms] [children: 213%] [unaccounted: -113%]
15:51:48: | | flush - [0.123%] [avg time: 0.362 ms]
15:51:48: | | Conversion - [213%] [avg time: 629.087 ms]

Does x264 even work normally?

E: Maybe check CCC what is the current PCI-Ex speed or try to reinstall video drivers.
 
Last edited:

dping

Active Member
@Lucil yes.

@HA6 Something strange going on with colorspace conversion:


Does x264 even work normally?
15:15:46: MaxQP = 51
15:15:46: MinQP = 18
15:15:46: PeakBitrate = 50000000
15:15:46: Profile = 100
15:15:46: ProfileLevel = 41

Profile 4.1 does not support 1080p@60fps
http://en.wikipedia.org/wiki/H.264/MPEG-4_AVC#Levels
Might have him try the prior version that that sets to 4.2 since he is doing local or have a dropdown menu built in to select the profile up to 5.1 for those who record local L)

EDIT: or have it change based on the resolution. i.e. above 1080@30 set to 4.2 below set to 4.1. I would actually like to try out 5.1 just for shits n giigols :)
 
Last edited:
Wow huge difference, and AMD is supposed to be one of the best HW Encoders;P

Are you streaming or simply Youtubing?

I would try VBR, as CBR is always worse as it's "wasting bits".
Also if you have a new AMD GPU you can use B frames, not sure which but i think it's 290/270 and 285 (at least it's not 280).

GOP can perhaps be bigger, you usually want it to be the same as your FPS (at least in x264).
But higher GOP = less space needed. But generally the difference is small so just make GOP == FPS.

EDIT:

Ok was wrong about 270, here is the list- http://developer.amd.com/community/blog/2014/02/19/introducing-video-coding-engine-vce/ (look at VCE 2.0)
 

Corinarh

New Member
Wow huge difference, and AMD is supposed to be one of the best HW Encoders;P

Are you streaming or simply Youtubing?

I would try VBR, as CBR is always worse as it's "wasting bits".
Also if you have a new AMD GPU you can use B frames, not sure which but i think it's 290/270 and 285 (at least it's not 280).

GOP can perhaps be bigger, you usually want it to be the same as your FPS (at least in x264).
But higher GOP = less space needed. But generally the difference is small so just make GOP == FPS.

EDIT:

Ok was wrong about 270, here is the list- http://developer.amd.com/community/blog/2014/02/19/introducing-video-coding-engine-vce/ (look at VCE 2.0)


i have 7850 so i guess there are no fix for me
 

jackun

Developer
quality preset drops about 10fps more than balanced and recording/streaming is same bad pixelated quality
Drops game's fps? Wut... Also having D3D11 interop enabled would be preferable in theory unless D3D11/OpenCL workload scheduling/gpu sharing eats into perf too much.
 

dping

Active Member
quality preset drops about 10fps more than balanced and recording/streaming is same bad pixelated quality
I typically do 720@48fps 3400bitrate with much success. and I've tested with 54fps as well and that is smoother and works well at quality preset. just double for the IDR; 96 and 108 respectively. I've heard some different things lately on GOP which to each their own, but the more I read, youtube is the only place you really want to have a 1/2 GOP length so same as FPS should be fine.

I would try VBR, as CBR is always worse as it's "wasting bits".

for network traffic, having a static flowing stream it better for network shaping. CBR doesn't waiste bits, it merely reduces the peak restricted to the QP. CBR padding only repeats the last frames if the stream is idle, which is also better for ensuring twitch doesn't think your stream has disconnected unnecessarily.

@Corinarh you could also play with Min/max QP. I would lower the max QP to 41 and leave the minimum alone.
 
Last edited:

AndersE

New Member
Found a bug/missing feature in this version of OBS. The Anti-cheat compability hooking is not working. While the option can be ticked, me and my friend could just not record Arma 2 in game capture mode without a black screen. I tested everything I can think of to get around it, but without success. Today I installed the normal version of OBS and did a x264 test. It immediately began to work when ticking the anti-cheat hook. I also tested the x264 encoder in this branch without luck. Is this something that can be fixed, jackun?
 
Top