OBS 28.0.0 & 28.0.1 AMD AMF problem (AMD Ryzen 7 5700G iGPU)


New Member
Hi all,

With old obs, I was using the iGPU in my AMD 5700G to handle recording in h265 while playing on my geforce rtx 3060 ti.

I updated to 28.0.1 and found my AMD AMF encoder completely missing. I have updated to 28.0.1. And the AMD AMF encoder is still missing.

Here is an extract from my log file...

17:17:10.015: [AMF] Version 2.7.0 loaded (Compiled:, Runtime:, Library: 1;4;26;0;;202208191240;AMD-Radeon-Driver/drivers:a5556e3784c53412272d5998633b45b9af60ea2c).
17:17:10.044: [AMF] <Id: 1> Unable to set converter transfer characteristic, error AMF_NOT_FOUND (code 11)
17:17:10.070: [AMF] <Id: 2> Unable to set converter transfer characteristic, error AMF_NOT_FOUND (code 11)
17:17:10.075: [AMF] [Capability Manager] Testing Direct3D 11 Adapter 'AMD Radeon(TM) Graphics (VEN_1002/DEV_1638/SUB_88091043/REV_00c8)':
17:17:10.075: H264/AVC: Supported
17:17:10.075: H265/HEVC: Supported

As you see, OBS is detecting the encoder. Any ideas on how to get the AMD AMF encoder to appear again in the recording advanced settings?


New Member
I guess its a work around, but I have the latest obs installed and then I had another directory with the FULL zip files from the github here for version 28.0beta1 https://github.com/obsproject/obs-studio/releases/tag/28.0.0-beta1 that version seems to work for me, it allowed the AMD AMF option again from the drop down list, I havent done a lot of tests yet but it seems to be working ymmv

EDIT: Funny enough when I saved that profile and opened the updated version 28.03 AMD AMF is now there again, although it missing the other HEVC version, which might show up if I also save another profile with the encoder on from the old build and then saving the profile and loading up the new version, what a weird thing, definitely must be some kind of bug or something idk
Last edited:


New Member
@ SmachChopG
Thanks for the info. I updated to 28.0.3. Still not AMD encoder. So I tried downloading the 28.0.3 FULL, extracted and tried just running that.
Still no AMD encoder listed.
I downloaded the excact version you listed, extracted that and run that. That does list the AMD Encoder.
so thanks for that tip.
Im now going to go through the files to see which ones are different sizes in regards to the AMF encoder, to see if I can identify which files would get AMD to be listed on my 'installed' OBS.
I will post how it goes.


New Member
Update... I have located the files that cause the problem.
Inside the obs-studio\obs-plugins\64bit there are two files.

enc-amf.dll and enc-amf.pdb.

Using the link that SmashChopG provided, I started going through all the files and compairing the file size differences between 28.00 beta 3 and 28.0.3. Once identiftied I started to copy and replace files from the 28.00 Beta over the top of what I have in my 'installed' obs version. Then launch OBS. see if encoders are there. If they are not, I then copy the orginal files back from a 28.0.3 FULL that I had downloaded.

Once I got to the folder listed above. In Version 28.00 Beta 3. The enc-amf.dll and enc-amf.pdb file sizes was 315KB and 5668KB.
While in 23.0.3 Official the enc-amf.dll and enc-amf.pdb file sizes were 315KB and 612KB.

So as you see, there is a 5MB difference in size of the file enc-amd.pdb between the beta and current version.

I copied the two files from the Beta to the 'installed' version 28.0.3, and boom! I not have both h264 and h265 encoders listed for my AGPU.

My guess is, that this 5MB file, is a list of valid hardware for the AMD Encoder to use. But that is pure speculiation.

I couldnt have worked this out, without your help SmashChopG.

If anyone from the offical OBS support get to see this thread. Please take note of this. As whatever the problem is, it is related to these two files in this specific location. That narrows down your needle in a haystack problem to a needle in a paper clip tub problem.