Question / Help OBS 23.0.0 Encoder Overloaded

Ch0ke_tv

New Member
My System:
i7 8700k @ 4.9ghz
32gb DDR4-3000mhz RAM
MSI DUKE RTX 2080 (419.17 driver)
1Tb SSD.


I am trying to stream at 1080p60fps using the new OBS 23.0.0 for the enhanced NVENC encoding quality, however I am constantly getting encoder overloaded and dropping frames hard. I have attached a picture of my output settings. I have also attempted to stream with Look-ahead and Psycho visual tuning disabled and it made no difference. Also, changing the quality preset to quality or even performance still has no impact. I have even tried capping my FPS in game to give the GPU more headroom.. still getting encoder overloaded message. I have no idea what the issue is but I am able to achieve 1080p60fps streams with no dropped frames in SLOBS just fine, but not in OBS Studio... So much for OBS v23.0.0 being optimized for RTX encoders.. or am I missing something? I will be going back to SLOBS until I figure out how to fix this.

Thanks for your help.
 

Attachments

  • OBS Settings.jpg
    OBS Settings.jpg
    98.5 KB · Views: 893

themigty

New Member
Exact same problem. Encoder overloaded, but my actual encoder from the card doesn't even reach 50% usage in the task manager.
Using RTX 2070 and Ryzen 2700
 

Flamingo

New Member
Same issue here. Never had a problem with NVENC before this update.

9900K
32gb ram @ 3200
1080Ti on newest driver
500gb ssd
 

themigty

New Member
Update: Problem is appears to be gone after uninstalling OBS, clearing all folders and re-doing settings, where I mostly used default values.
 

Ch0ke_tv

New Member
Update: Problem is appears to be gone after uninstalling OBS, clearing all folders and re-doing settings, where I mostly used default values.
What do you mean "clearing all folders?" I just did a clean install of windows after wiping all my drives and it still overloads... SLOBS works just fine tho. I don't understand this.
 

Ch0ke_tv

New Member
So the only way I have found to output at 1080p60fps without overloading is to limit the in-game framerate to 60fps or enable V-sync... both options suck, especially if you play competitive shooters like I do... So I guess SLOBS is best still... what a disappointment. So much for dual PC quality from a single PC...
 

WizardCM

Forum Moderator
Community Helper
Change the preset from "Max Quality" to "Quality" and turn off "Psycho Visual Tuning". Both of these use CUDA and therefore result in slightly higher GPU usage (which gives you better quality).
 

MrPlebabe

New Member
Exact same problem here on RTX 2070 using Nvidia driver version 417.7, thinking it may be a driver issue or a bug. I tried all the steps for troubleshooting on this Nvidia guide: https://www.geforce.com/whats-new/guides/broadcasting-guide with no fix. I tried even dropping stream quality to 1280x720 60fps lanczos 32 6000 bitrate and it still gave the same errors with the overloading. Very unfortunate. Maybe just and RTX issue. Possibly also a new driver release needed as I am trying to do so while playing Apex Legends which is un-optimized and needs a driver fix. Hopefully it is resolved soon for now SLOBS it is. -_-
 

Kaionacho

New Member
I also have this problem with my GTX 670 using Nvidia driver 419.17.

Before the update to 23 i could record BF4 in 720p60fps with these settings https://puu.sh/CUdti.png without problem,
now with the same settings, not even using NVENC(new) i'm dropping frames like crazy. I just spend ~2h trying different settings, switch to NVENC(new), try different settings there, even going down to 1500 Bitrate didn't change much

gonna try to install an older version of obs and Nvidia driver tomorrow, getting late
 

Ch0ke_tv

New Member
Update: So my base resolution is 1440p (2560x1440). That is the native resolution of my monitor and the resolution I play all my games at. I changed the base and in-game resolution to 1920x1080 and I no longer have the encoding overload message, but playing at 1080p on a 1440p monitor sucks!! So I think I will just continue to use SLOBS as it works fine with 1440p until they can figure out how to optimize the downscaling... do any of you also play at 1440p?
 

RonUSMC

New Member
I do @Ch0ke_tv and I haven't tried that actually. I have an Asus ROG 25" and its at 166hz.

I also have an I9-7900x that is overclocked to 3.3 and it still gives horrendous render lag. I try pushing to the 1080 instead of x264 and its about the same. My CPU never gets above 15% as well, which irritates me. It barely uses this massive CPU and still gives me hellacious lag. When I render something in Adobe it gets the CPU to 80% and crunches like crazy.
 

Attachments

  • 2019-03-02 (3).png
    2019-03-02 (3).png
    14.1 KB · Views: 238

Ch0ke_tv

New Member
I'm having same issue with nvidia 1070. Only fix was to go back to h264. Don't use slobs.

SLOBS works.. OBS doesn't. That is the issue. I am wanting to use the new h264 NVENC with OBS but without drastically limiting my in-game framerate, I can't stream at 1080p60 or 720p60 without overloading the encoder. It shouldn't be like that.
 
SLOBS works.. OBS doesn't. That is the issue. I am wanting to use the new h264 NVENC with OBS but without drastically limiting my in-game framerate, I can't stream at 1080p60 or 720p60 without overloading the encoder. It shouldn't be like that.
Sorry, I meant "I don't use slobs". I was having some other issues and ended up updating vlc and removing a 3rs party vst audio plugin "reaplug". Just reset to nvenc new and all seems good so far. I did use this guide https://obsproject.com/forum/resources/nvidia-nvenc-guide.740/
 

koala

Active Member
Nobody posted a log, so I can only guess, but usually disabling Windows Game Mode fixes most drastic lags and choppy video for super powerful machines like i7 8700k+gtx 2xxx that should handle video well without restricting running games too much.
 

c0nsecro

Member
Hey there,
I've streamed and recorded Fallout 76 today with OBS v23.0.1. The engine of that game doesn't kill my hardware, so my first try: recording with the new NVENC Encoder in 1440p DSR-resolution (2715x1527) and streaming WITH CPU at CBR 6000 bitrate, downscaled to 720p. I've get the "encoding overload" message the whole time, CPU-usage 20%, GPU-load full, but still GPU-memory left. I've changed the resolution back to 1080p and the problem was still there. I've deactivated the NVENC-recording and just streamed with CPU => encoding overload message the whole time. I didn't change the settings from OBS v22 to v23 in my streaming tab, only in recording I switched to the new NVENC-encoder and set setting to "max. quality". Quality setting is CQP and the level is 15, but when I get an encoding overload only with using the CPU, the problem should be there. My streaming setting are 6000 bitrate, cpuencoder-settings "medium" and profile "high".

My system:
- CPU: i9-7900x
- GPU: GTX1080
- Memory: 32 GB

I've added the logs too.
 

Attachments

  • 2019-03-03 20-09-38.txt
    32.1 KB · Views: 61
  • 2019-03-03 21-34-17.txt
    41.6 KB · Views: 24
  • 2019-03-03 21-46-48.txt
    46.9 KB · Views: 21

Agamemnus

Member
Render lag is because your GPU is maxed out. Why it happens in OBS but not in SLOBS I don't understand, but that's the cause. OBS needs at least some of your GPU % to be able to draw the picture.

I also notice you have replay buffer AND streaming going at the same time? Is this also happening in SLOBS? Because if not, then that could be why you have different results between the two. Try disabling the replay buffer all together and go again.
 

YToLDSCHooL

New Member
I can report that I face the same problem as well.
OBS 23 is unusable, even if it doesn't report any framedrop sometimes, the actual stream is powerpoint.
SLOBS is running fine with the old NVENC.

GPU: RTX 2080
 
Top