Bug Report NVENC micro stutters on two different systems for over 2 years now.

Ryfek

New Member
#1
Hi there. The NVENC stutters have been a problem for me since I started recording my games with a graphics card (over 2 years). I cannot find a solution to this problem. You can see the issue in the link down below. The game runs fine for most of the time, but after a drastic change in the scene - like killing an enemy in the video 5 second later, or changing a room in The Binding of Isaac - it starts to stutter. Then after another change in the scene like exiting a room or opening inventory it goes back to normal.

https://youtu.be/mXgOY2FAg_o?t=1750

OBS does not post any problems whatsoever. It always says that the video is locked to 60 FPS. I'm having this issue on my main PC with R7 1700 + GTX 1070 and on my second one with i5-4670k + GTX 1660. I'm using only SSD drives, heck even an NVME one on my Ryzen build so it's not a storage disk bottleneck. The games I record are not hard to run so it's not a GPU bottleneck but it also happens with more demanding 3D games. The stuttering never happens when I record using x264 but my second PC with an old i5 can't handle 1440p recording. I'm using 2 monitors with different framerates on my main PC but the stuttering happens even with only a single monitor on a second PC. Changing the quality settings does nothing. Changing the refresh rates on my monitors does nothing. Don't know if the log I included is the one you are looking for, but it's the one I got after recording the Hollow Knight video. Once I tried to stress the GPU by running some 4K videos in the background while recording those easy-to-run indie games and it somewhat made the stutters less frequent but they still happened. I seriously can't find ANY solution to this problem. Everything like game capture, monitor capture, window capture, CBR, CQP, V-SYNC, G-SYNC, limiting frames, updating drivers, formatting my PC did not work. Is there ANYTHING I can do to make those stutters dissapear?
 

Attachments

#3
From your log file...
Do you need you Base resolution that high? 2560x1440?

It also says "Recording stopped due to hotkey..." ??

My monitor resolution (on triples) is 5760 * 1080, but my Base resolution is 1920*1080. I don't want to render the entire 3 screen setup, and you have to compromise your canvas to something the majority of the people viewing have...
 
#4
I'm just recording in 1440p, what is the problem? That's my native screen resolution 2560 x 1440. YT renders it to so many options from 144p, 360p, 720p, 1440p etc. so everyone can watch it on their devices. People record in 4K without any problems so why did you even mention it?

I'm pressing hotkeys to start and stop recording, that's it.
 
#5
Well, I mentioned it because you seemed to have a stutter problem, and it is noteworthy that you're base canvas is very large.
YT does indeed render at other resolutions, but if you're system is struggling to do what you're asking, you need to consider scaling back things until you get it sorted out.

But, i won't mention it again.
 
#6
GTX 1060 and higher wouldn't even brake sweat while recording in 4K 50 MB/s so it's not a system bottleneck. Stuttering happens even while streaming in 1080p 7500 KB/s.
 
#10
Bump with some update. When OBS is set to 30 fps it should still be watchable, but it's AWFUL. 60 fps recording looks like 30 (even though it says its 60 with no dropped or duplicated frames even though they are duplicated), only when I switch to 120 fps recording the video is smooth as butter, with no problems at all! Don't know why OBS duplicates frames like this and has no problems reiording it in 120 fps. Please look into that, I've had this problem for years and finally it's solved thanks to recording in 120 fps.

@Edit:
And the funny this is that monitor on my second PC is 60 Hz with system capped at 70 in riva and the 120 fps switch in OBS works!
 
Last edited:
#12
There are no other capture sources and as I said there's no difference if I record with game capture, window capture, screen capture, lock the fps in OBS, etc. Seriously I've triend EVERYTHING and the 120 fps is the only thing that helped me out. Bug happens on both of my systems with completly different hardware. One has 2 different refresh rate monitors (but it happens even when they are both set up to 60 Hz) and the other one has only 1 monitor (60 Hz).

@Edit:
I've just checked. While recording in 30 fps every third frame is duplicated resulting in 20 unique fps with half of the frames being shown for 2/3 of the time. While recording in 60 fps every sixth frame is duplicated. Haven't checked the 120 fps frame duplication as Hollow Knight is running in 60 fps only, but I'm sure there are duplicated frames aswell. I'll try to record some 30 fps footage which is by far the worst example of the bug and include another log file.
 
Last edited:
#13
Here a quick 21 seconds video recorded in 1440p, 30 FPS, NVENC (New) 16000 CBR:
https://youtu.be/DZ12KZrKZVs

Here's a log file:
https://obsproject.com/logs/CWc8QIs3Vk-2u8-G

As you can see the video is EXTREMELY choppy with some weird glitches. It does not happen all the time. Last few seconds are fine, but the bug happens pretty frequently. The same thing happens on my second system so it's no difference if thats an i5 or Ryzen, older 1070 or newer Turing based 1660, old SSD drive or some new NVME ones. Both systems are up to date, both have no problems while recording with shadowplay or OBS with x264 encoding. Changing pretty much all the setting gives no results. Changing monitors does nothing. Formatting PC's does nothing. As I said it even happens while streaming 1080p 5k bitrate videos. I'm seriously out of options with this one, I've been struggling with this for over 2 years and finally recording in 120 fps can make my videos look like 60 fps all the time. That's insane.
 

Harold

Active Member
#14
Code:
03:47:55.797: - scene 'Stream LOL':
03:47:55.797:     - source: 'Przechwytywanie okna' (window_capture)
03:47:55.797:     - source: 'Przechwytywanie gry' (game_capture)
03:47:55.797:     - source: 'Cel napiwkow' (browser_source)
03:47:55.797:     - source: 'Top Donejty' (browser_source)
03:47:55.797:     - source: 'Urządzenie do przechwytywania wideo' (dshow_input)
03:47:55.797:     - source: 'Donejty' (browser_source)
03:47:55.797: - scene 'Stream Isaac':
03:47:55.797:     - source: 'Przechwytywanie gry 5' (game_capture)
03:47:55.797:     - source: 'Top Donejty' (browser_source)
03:47:55.797:     - source: 'Cel napiwkow' (browser_source)
03:47:55.797:     - source: 'Donejty' (browser_source)
03:47:55.797:     - source: 'Urządzenie do przechwytywania wideo' (dshow_input)
03:47:55.797: - scene 'Rimworld -13.3':
03:47:55.797:     - source: 'Przechwytywanie gry 2' (game_capture)
03:47:55.797: - scene 'Isaac-21.4':
03:47:55.797:     - source: 'Prace' (window_capture)
03:47:55.797:     - source: 'Przechwytywanie gry 3' (game_capture)
03:47:55.797:     - source: 'Urządzenie do przechwytywania wideo 2' (dshow_input)
03:47:55.797: - scene 'Hollow Knight -16.1':
03:47:55.797:     - source: 'Przechwytywanie gry 4' (game_capture)
03:47:55.797: ------------------------------------------------
There are FIVE game capture sources that could all be interfering with each other.
Just because the scene isn't active it doesn't mean the source isn't either.
And you didn't answer my other question.
 
#15
I actually did remove EVERY other game capture just a second after and belive me it's as choppy as it was. And I did answer your second question LOL.
 
#18
For troubleshooting purposes, create a new scene collection and only add a single capture source, nothing else.

Then, try the following changes on your NVENC settings:

1) Change to "Quality" preset;
2) Disable "Lookahead" and "Psycho Visual Tuning";
3) Reduce B-frames to 2.

Then set your capturing FPS to 60, make sure all your monitors have the exact same refresh rate and resolution (Windows 10 doesn't play nicely with mismatched monitors) and cap ingame FPS to 60.

Fixed post due to correction.
 
Last edited:
Top