Multiple Audio Problem

leprosteve

New Member
Hello!
I went through all the steps to enable multiple audio tracks (I want to record screen sharing audio and microphone audio separately). My two sources show up just fine and both show activity in Audio Mixer. As is recommended, I labeled them as separate Tracks (Microphone is Track 1 and Desktop is Track 2, for example) and enabled only Audio Tracks 1 and 2 in Advanced Output Settings.
Here's where it gets weird.
If I have Microphone as Track 1, the audio will only pick up the Microphone. If I switch the labels and have Desktop as Track 1, the audio will only pick up the Desktop. It seems to be this way for any two number options (3 and 4, 5 and 6, etc); it will only pick up the audio will the smaller number Track.
Has anyone else encountered this?? I've been VERY careful to match the enabled Tracks with what I label my Microphone and Desktop.
Thank you for any help! Haven't been able to find any resources that address this.
 
Hmm, maybe check that:
Track no. 1 - all audio (SUM microphone and screen sharing)
Track no. 2 - microphone
Track no. 3 - screen sharing

I got this config.
But i use Track no. 1 for first audio language, Track no. 2 for second audio language and use ffmpeg to record.
 

Lawrence_SoCal

Active Member
If I have Microphone as Track 1, the audio will only pick up the Microphone.
How are you determining the audio will on pick only Track 1?
Issues I've seen commented over last couple of years is OBS actually working properly, but when a user checks a recording they think something is wrong. And common causes are:
- recording to a format that doesn't respect (or support) your audio track settings
OR
- using a media player that can't understand/handle/process the audio tracks [and that becomes its own complete can of worms, outside my area of expertise]

Or, are you noticing the audio issues on test stream to a streaming service (YouTube, Facebook, Twitch, etc)?
 

leprosteve

New Member
Thank you for the reply!

Since I'm using two totally different audio sources, I just note the corresponding Track to the audio that is being recorded, and cross reference it with what I'm hearing in my given media player.
I double checked the format and attempted both mp4 and mkv; it didn't make a difference which one I used.

I identified that it's (mostly?) my media player's fault (I import files into Wondershare Filmora and VLC Media Player). I finally got it to show two audio files, but when I play them, they're the same (the lower numeric value as recorded on OBS). (Screenshot 1)
After doing a little Googling, I started playing with Avidemux and got a different problem. It has two distinct audio files, but I can't play them together; the one with the lower numeric value (0, in this file) is still the only one playing. At least I can export them separately into Filmora, which effectively solves the problem with a work around.
Basically, I've found a way to make it work for my purposes, but out of curiosity, why can I not play the audio files together anywhere? And do you know if there's a reason why it's just giving me the same audio file twice instead of the two separate ones I record? This is the same file loaded into Filmora and Avidemux.
 

Attachments

  • Screenshot (1).png
    Screenshot (1).png
    136.8 KB · Views: 11
  • Screenshotb (2).png
    Screenshotb (2).png
    162.4 KB · Views: 10

leprosteve

New Member
Hmm, maybe check that:
Track no. 1 - all audio (SUM microphone and screen sharing)
Track no. 2 - microphone
Track no. 3 - screen sharing

I got this config.
But i use Track no. 1 for first audio language, Track no. 2 for second audio language and use ffmpeg to record.
Yup, I tried that several times. It didn't seem to matter what order I'd put the Tracks, it would only replay one of them in any media player.
 
Top