Move transition

Move transition 2.2.1

shibetpc

New Member
@shibetpc to build this plugin you need to do an in tree build. So make sure you can build obs first. Check out the move transition repository to plugins/move-transition and add "add_subdirectory(text-freetype2)" to plugins/CMakeLists.txt. Next build and run.
Ok, thanks for that info. Stupid question: I'm using an Arch based linux distribution, so the version of OBS I'm using is coming from the user repository. Can I build this against the 'portable' version and then move the /plugins/move-transition/* data to my existing install?
 

Exeldro

Active Member
@shibetpc In theory build a version and add it to an existing install should be possible, but I don't know enough Linux to help you with that.
 

frankdyring

New Member
Great plugin! Would it be possible to use some of the same code to be able to zoom / pan / tilt a source and in that way create a sort of PTZ effect to a stationary camera? Could be something like assigning a hotkey and then source "A" will zoom in X%
 

Exeldro

Active Member
@frankdyring Just make multiple scenes with the same source, 1 full frame, 1 zoom at position and 1 zoom at other position.
Add hotkeys to switch between the scenes.
 

Cykelero

New Member
This plugin is delightful; transitions go a long way to make everything feel nicer . Thanks for making it!

There seems to be an issue around using transitions that don't move or zoom, on appearing sources; for instance, when trying to make sources appear with simply a fade. The fade works, but on the very first frame of the transition, you can see the source's final appearance. Or said differently, the source animation's end frame flashes at the very beginning of the transition.
Is this something you've noticed?
 
This plugin is delightful; transitions go a long way to make everything feel nicer . Thanks for making it!

There seems to be an issue around using transitions that don't move or zoom, on appearing sources; for instance, when trying to make sources appear with simply a fade. The fade works, but on the very first frame of the transition, you can see the source's final appearance. Or said differently, the source animation's end frame flashes at the very beginning of the transition.
Is this something you've noticed?
Yes noticed this too, might be particular with layers with transparencies?

Another thing I've noticed that is different (and inferior IMHO) to the original motion-effect implementation, is that the 'resizing' of animated sources that are changing size happens at the end of the animation, whereas with motion-effect it was done in the middle of the animation. This is particularly noticeable if you're doing a 'zoom' effect - the layer that is getting bigger and bigger will be at low resolution, until it snaps to full resolution at the end. With motion-effect. it would snap in the middle of the move, which wasn't seamless, but far less distracting.

Otherwise this plugin is unbelievably good.
 
@kineticscreen I failed to reproduce the snapping you are describing. Can you provide a video to show it? Or give me the settings your are using?
I'll get back to you if I can reliably reproduce it. At the moment it only seems to happen on one particular piece of footage, within one project, so there are too many variables to be useful. If I can recreate or see it happening elsewhere I'll post something more useful.
 

toplachi

Member
The 1.2.0 version doesn't work on my mac... but versions up to 1.1.4 still do ... Thank you that this is already available to other platforms!
 

Exeldro

Active Member
@toplachi I try to make plugins multi platform as much as I can. But I don't have a Mac or Linux (development) environment to test and debug it, so I am depending on others to fix and test it for me.
As far as I can see the Mac build did not give me any errors. Did you get an error message with version 1.2.0 (in the log file)?
 

toplachi

Member
Recent log files don't have errors.

I'm not sure if this is related to this case, this is what I can see from the log file when I first try move transistion (1.2.0)

glTexImage2D failed, glGetError returned GL_INVALID_VALUE(0x501)
01:21:50.155: device_texture_create (GL) failed

I then installed earlier versions of move transition and they are working. Reinstalled ver 1.2..0 back again but didn't encounter the error message mentioned above.
 

paulkilroy

New Member
Sorry for the basic question, but if I install the macos binaries, what happens when OBS wants to update to a newer version?
 

paulkilroy

New Member
Sorry, I'm sure I'm doing something wrong, but downloaded the Mac binaries, added the Move Transition, and am only getting the transition cut to black for the duration, then it brings up the new scene. Any ideas? Both scenes use the same video capture device, just some text and images are different between them.
 
Top