MIDIControl - Control OBS, Soundboard, Twitch chat with MIDI Devices

Free MIDIControl - Control OBS, Soundboard, Twitch chat with MIDI Devices 1.9.2.1

OSBooter

New Member
I've attempted to install this plugin again today. I even tried an older version wondering if there was something else causing problems.

My setup (assume latest versions)
Win10
32GB RAM
Dual SSD, Plenty Storage
OBS with lots of plugins
MIDIControl installed.
loopMIDI installed.
Cubase Pro 11
Studio One 5
Ableton Live 11 Lite
Lots of Cubase Plugins, Sounds, Etc.
I bring the music software because I do use my MIDI keyboard for other stuff when I'm not on OBS.
If I could use the MIDIControl interface for other software, that's great too.

Is there a more remedial recipe for making this work? Possibly a video? I see a lot of videos for obs-midi, which is still in alpha and doesn't seem quite ready yet.

I've installed MidiControl and loopMidi.
There is nothing in loopMidi. What do I add? Is this integral to making this tool work with OBS?
I've started MIDIControl after opening OBS.
None of my scenes or other settings are available in the pulldown menus. Is that normal?
In your overview post, the name of the midi keyboard appears in green next to the midi icon. I don't see that. Is that normal?
When I tap keys on my Novation LaunchKey Mini III, they show up in the "Midi Device", "Channel" and "Note" segments.
I can add a keybind with no checked boxes and nothing set. I can't modify it.
If I check any box for a new keybind, I can't add it.

I'm obviously missing something, or doing something wrong.

I'd be grateful for suggestions about how to get this going.

Cheers!

Chris

View attachment 78796
Have you added websockets into your obs installation?
 

LaughterOnWater

New Member
Have you added websockets into your obs installation?

@OSBooter , thanks for your reply.

I'm trying out obs-midi while I get feedback on why MIDIControl could be failing.
I've included other loaded modules just in case there's a known conflict.

Loaded Modules:
win-wasapi.dll
win-mf.dll
win-dshow.dll
win-decklink.dll
win-capture.dll
win-capture-audio.dll
vlc-video.dll
text-freetype2.dll
streamup.dll
StreamFX.dll
spectralizer.dll
scene-notes-dock.dll
scene-collection-manager.dll
rtmp-services.dll
obs-x264.dll
obs-websocket.dll <--- It's amazing how many other plugins rely on this eh?
obs-vst.dll
obs-transitions.dll
obs-text.dll
obs-shaderfilter.dll
obs-qsv11.dll
obs-outputs.dll
obs-ndi.dll
obs-midi.dll
obs-filters.dll
obs-ffmpeg.dll
obs-color-monitor.dll
obs-browser.dll
move-transition.dll
media-controls.dll
logi_obs_plugin_x64.dll
image-source.dll
gradient-source.dll
frontend-tools.dll
enc-amf.dll
downstream-keyer.dll
decklink-ouput-ui.dll
decklink-captions.dll
coreaudio-encoder.dll
audio-monitor.dll
 

Etuldan

Member
I've attempted to install this plugin again today. I even tried an older version wondering if there was something else causing problems.

My setup (assume latest versions)
Win10
32GB RAM
Dual SSD, Plenty Storage
OBS with lots of plugins
MIDIControl installed.
loopMIDI installed.
Cubase Pro 11
Studio One 5
Ableton Live 11 Lite
Lots of Cubase Plugins, Sounds, Etc.
I bring the music software because I do use my MIDI keyboard for other stuff when I'm not on OBS.
If I could use the MIDIControl interface for other software, that's great too.

Is there a more remedial recipe for making this work? Possibly a video? I see a lot of videos for obs-midi, which is still in alpha and doesn't seem quite ready yet.

I've installed MidiControl and loopMidi.
There is nothing in loopMidi. What do I add? Is this integral to making this tool work with OBS?
I've started MIDIControl after opening OBS.
None of my scenes or other settings are available in the pulldown menus. Is that normal?
In your overview post, the name of the midi keyboard appears in green next to the midi icon. I don't see that. Is that normal?
When I tap keys on my Novation LaunchKey Mini III, they show up in the "Midi Device", "Channel" and "Note" segments.
I can add a keybind with no checked boxes and nothing set. I can't modify it.
If I check any box for a new keybind, I can't add it.

I'm obviously missing something, or doing something wrong.

I'd be grateful for suggestions about how to get this going.

Cheers!

Chris

View attachment 78796
As the OBS icon is in red, it means that there is a communication issue between OBS and MIDIControl.
Check in OBS, in menu Tools, "Websocket Server Settings" that it's enabled, and set the same ip/port (derfaut port is 4444 , so default IP will be 127.0.0.1:4444) and password in MIDIControl options.

Strange thing about the MIDI Device not displayed as green in the status bas, but 1rst step is the OBS configuration
 

trikr

New Member
is there any posibility to adjust the background-led behaviour? i'd like to switch from blinking to constant light for volume-mute and highlight the last activated "transition" configuration on my apc mini (like the "active scene" behaviour). would be nice to have a more detailed soundbar indicator, too (red=mapped loop / red blinking=playing loop / green=oneshot mapped / green blinking=oneshot playing).

PS: nice plugin -> well done sir :)
 
Last edited:

DJFLuFFy_vs_joe

New Member
I used the old version with a launchpad mini it did the job.
I always wanted to have some feedback from the LEDs that are in the buttons.
Today i updated to the new version. and WOW the led turned on when the scene was active.

however. i wonder if it is possible to make all the inactive scenes for example Red so i know what buttons are the other scenes.
and make toggle actions for example orange/green.

anyway. i love this app.

Keep up the great work
 

palermo

New Member
hi @Etuldan, hi all,
thx, Etuldan for the nice proggy. its one of the reasons, i moved to win from osx. ;)

i have read some pages here, but not all of it. after using your software i need some input.
1. the icon (floppy) for saving, is it doing anything? i am clicking on it - no feedback - now i quit the app after some entries. this works...
2. the speaker-icon with x - what does it mean?
and the mainpoint:
3. i need to automate some parameters in filters eg. opacity in color key.
its not working.
i know the "...a log of missing filters min/max values (see in %AppData%\MIDIControl\FilterLog.log ), and you can add them by modifying filterminmax.csv according to the log".
plus i ve changed the min and max-parameters.
i did that with different entries and filters. nor of them is working with the faders.
the same faders on my apc mini is working fine with volumes.
buttons for scenes and even hotkeys for lower thirds are working fine too.
any ideas?
and sorry, if the answer is somewhere in this thread. ;)
 

palermo

New Member
ok. maybe hard to answer. let me try this way: i have 8 faders on my akai mini and want to change the opacity in a filter. how can i do it…?
 

palermo

New Member
update: now i can - no idea why its working now, maybe the update or reinstalling - control a filter eg. color key/opacity with a fader on my akai mini on ONE source.
if i use the same filter, even with a new name, on a new source, i can select the filter in midicontrol, but the parameter opacity is not available and in filterlogs it cries for the "color_key_filter_v2.,MinValue,MaxValue", but this line is already in the filterminmax.csv...
 

palermo

New Member
now i found a way its working - even with the same filter. maybe it helps
here it needs a special order:
1 - select the filter on a source
2 - move the parameter u want to midify
3 - go to midicontrol
4 - + / new entry
5 - name it
6 - move the midi-fader or knob u wanna use
7 - "adjust filter" on
8 - select the filter
9 - select the parameter
10 - ADD
dont forget to save.
 

LaughterOnWater

New Member
As the OBS icon is in red, it means that there is a communication issue between OBS and MIDIControl.
Check in OBS, in menu Tools, "Websocket Server Settings" that it's enabled, and set the same ip/port (derfaut port is 4444 , so default IP will be 127.0.0.1:4444) and password in MIDIControl options.

Strange thing about the MIDI Device not displayed as green in the status bas, but 1rst step is the OBS configuration
@Etuldan, thanks for your reply.

I checked the web-sockets settings in question. They were as suggested. Other plugins require web sockets too. I uninstalled obs-midi to and re-installed MIDIControl and looperMIDI to run this test. Perhaps there is a conflict.
Additionally, when I tried to remove the MIDIControl 1.9.0.0, I got an alert from Norton. It says the uninstaller didn't have permission to remove its own start menu stuff. There may be a permissions thing that needs to be addressed in the uninstaller.

Lastly, when I went to install V1.9.1.0, created yesterday, both Chrome and Norton barked out an alert and would not let me download or install it. This is above and beyond the normal blue "Run Anyway" alert. Again, it's probably a permissions challenge for the installer. I did not attempt to override because I'm cautious. The previous version gave no such alerts. I'm reinstalling obs-midi for now. I'll absolutely try again when an the Norton-friendly version becomes available. I hope this helps.
 

SpudLovely

New Member
Hello

I recently got a couple of midi devices and was using the other common midi plugin to control basic scene switching, but was advised to try this cause it allows much, much more control of OBS directly. But I cant get it to see OBS. I installed websocket. I deleted my previous DLL file for the other plugin prior to install. I tried my local IP, net IP, lan IP, etc. It recognized the midi input and output, but refuses to connect to OBS, multiple different types of passwords tried. And the twitch authentication also refuses to log in. Any fixes or known conflicts? It sees my midi connection fine, just not my OBS.
 

segerlive

New Member
This program works beautifully but I recently updated StreamFX and it doesn't seem to adjust filters correctly anymore. Been trying different things in the csv file to no avail. Any help?
 

Etuldan

Member
@Etuldan, thanks for your reply.

I checked the web-sockets settings in question. They were as suggested. Other plugins require web sockets too. I uninstalled obs-midi to and re-installed MIDIControl and looperMIDI to run this test. Perhaps there is a conflict.
Additionally, when I tried to remove the MIDIControl 1.9.0.0, I got an alert from Norton. It says the uninstaller didn't have permission to remove its own start menu stuff. There may be a permissions thing that needs to be addressed in the uninstaller.

Lastly, when I went to install V1.9.1.0, created yesterday, both Chrome and Norton barked out an alert and would not let me download or install it. This is above and beyond the normal blue "Run Anyway" alert. Again, it's probably a permissions challenge for the installer. I did not attempt to override because I'm cautious. The previous version gave no such alerts. I'm reinstalling obs-midi for now. I'll absolutely try again when an the Norton-friendly version becomes available. I hope this helps.
All source code is available on github, and you can recompile+generate setup from it.
There is absolutely no bad stuff on midicontrol. And nothing I can do if a random company decide to randomly flag another random software as malware.
 

LaughterOnWater

New Member
All source code is available on github, and you can recompile+generate setup from it.
There is absolutely no bad stuff on midicontrol. And nothing I can do if a random company decide to randomly flag another random software as malware.
Again thanks for your reply @Etuldan. I'll merely wait until Norton calms down. They tend to get cranky with new, relatively unknown software. There is absolutely no bad reflection on your code in my remarks. Some coders prefer getting feedback when Norton or other security services squawk so they can figure out exactly why Norton is squawking and adjust the code accordingly... for instance, so that permissions criteria don't set off security alarms during install or uninstall. If that's not your thing, I get it. I'm in no hurry, and I'm not well-versed enough in C# to compile someone else's stuff on my rig. Again, it's not a negative reflection on your code. Others are obviously having great success. I'm looking forward to being able to install a future version! I hope this helps. Be well!
 

SpudLovely

New Member
Fixed my issue. No idea why it fixed it, but rolled back to an earlier version. Tried that, instantly recognized by OBS. Since you added more launchpad support I tried that version now too. No connection issue, newest version working great as well. Wonderful software, super versatile. Using it to control two separate midi surfaces now and its working great. Arduino based controller, and a Launchpad X.

If you take any suggestions for new features, since it has twitch integration I'd love to one day be able to redeem channel points commands in my own chat. I have a lot of points based commands controlled by a chat bot that would be great to access on the same control surface. They trigger web based things. I might be able to make a redeem based off of a This has been the one of the most important pieces to tie together all of my ideal -make shit work fast- setup. Thanks!
 

palermo

New Member
hi @Etuldan,
i have a akai apc 40 and a akai apc mini.
is it possible to dublicate ALL commands for a second controller?
where (filename) are the commands stored?
and - is there a way, to get the transitiontime on a knob?
thx for your answer.
 
Just ran into this bug the other day when using this tool. When I connect MIDIControl to OBS and leave it connected when I close it, I get this error every time. I also get the same thing when I switch to a different scene collection without disconnecting it first.
midi mixer active error obs.png
 

Etuldan

Member
hi @Etuldan,
i have a akai apc 40 and a akai apc mini.
is it possible to dublicate ALL commands for a second controller?
where (filename) are the commands stored?
and - is there a way, to get the transitiontime on a knob?
thx for your answer.
%APPDATA%\MIDIControl
options.json => general options.
keybinds.json => default profile keybinds
keybinds-xxx.json => xxx profile keybinds

Json files, so standard texteditor should be ok.
 
Top