Resource icon

Free MIDIControl - Control OBS (and SoundBoard) with MIDI Input 1.2.4.1

Etuldan

Member
Etuldan submitted a new resource:

MIDIControl - Control OBS (and SoundBoard) with MIDI Input - Remote control OBS with a MIDI device

MIDIControl is an external software (Windows Only), to remote control OBS with any MIDI device.
Switch scene, show/hide source, mute/unmute any scene/source with a MIDI device.
Also, you can play any local audio file (like a soundboard)

If you have an Android device, you can setup it as a MIDI device, for example with this app : https://play.google.com/store/apps/details?id=com.seemayr.midicontroller&hl=en (if your device support MIDI)

In order to be able to use your MIDI...
Read more about this resource...
 

Rockum

New Member
I gave it a try and was not noticing OBS responding. When I tried another MIDI port it crashed. Now it crashes on launch. Does MidiContol save the last used MIDI port? If so where is it stored? I would like to delete any configuration and experiment with other MIDI Ports/ Devices.

Thanks.
 

Etuldan

Member
I gave it a try and was not noticing OBS responding. When I tried another MIDI port it crashed. Now it crashes on launch. Does MidiContol save the last used MIDI port? If so where is it stored? I would like to delete any configuration and experiment with other MIDI Ports/ Devices.

Thanks.
By default, MIDIControl listen on all MIDI interface. You can disable any MIDI interface in settings.
And for any 'entry', the midi device, ports and note are saved. Means you can have 2 separates keyboard doing different things.
 
Been looking for something to do exactly this. But it seems like Toggle Sources might not behave as expected, particularly in Studio Mode.
Specifically, instructions to show or hide a source are completely ignored unless the scene is the current one. Even if the scene is in the Preview monitor, it will not show or hide sources.

This is especially problematic when using Nested Scenes to display universal overlays over other scenes - the only way the items within the nested scene can be toggled is if the netsed scene itself is the main program output - defeating the purpose.

With other implementations of Websocket, such as Deckboard, the toggling of sources within a nested scene happens immediately, without needing to transition again. This is particularly useful for instant display of graphics or overlays.
 

Etuldan

Member
Been looking for something to do exactly this. But it seems like Toggle Sources might not behave as expected, particularly in Studio Mode.
Specifically, instructions to show or hide a source are completely ignored unless the scene is the current one. Even if the scene is in the Preview monitor, it will not show or hide sources.

This is especially problematic when using Nested Scenes to display universal overlays over other scenes - the only way the items within the nested scene can be toggled is if the netsed scene itself is the main program output - defeating the purpose.

With other implementations of Websocket, such as Deckboard, the toggling of sources within a nested scene happens immediately, without needing to transition again. This is particularly useful for instant display of graphics or overlays.
Seems there are 2 issues :

- In Studio mode, currently, the show/hide source will work only for preview (which is useless, you are right). I'll toggle it also for the real output.

- About Nested Scene, to be honest didn't thought about it. It's clearly a great idea. I'll try to implement it (to be sure, main scene A, which include 'fake' scene B. In B, there is a source ZZ. While in scene A, you want to enable/disable ZZ ?)

Also would be good to have the ability to 'set transition'.
I'll try also to do this.
 
Fantastic. You might find that fixing the source switching only in preview might also fix Nested scenes. Happy to test a beta if it helps.
 

Etuldan

Member
Fantastic. You might find that fixing the source switching only in preview might also fix Nested scenes. Happy to test a beta if it helps.
Note that the current updated version from some minutes ago is not about this, but a more general fix ;)
I'll try to do it later (hopefully tomorrow)
 
BTW having the source hide/show only happening in Preview is also useful - it allows you to turn something on, and then transition to it. Would be good if there was a choice for it to be either live or preview.

And while I'm making unsolicited feature requests, I don't know if it's possible to do (because Deckboard also can't do it) but see if you can make it that you can toggle sources within a group. You can toggle the group as a whole, but the sources within it aren't an option.
 

Etuldan

Member
BTW having the source hide/show only happening in Preview is also useful - it allows you to turn something on, and then transition to it. Would be good if there was a choice for it to be either live or preview.

And while I'm making unsolicited feature requests, I don't know if it's possible to do (because Deckboard also can't do it) but see if you can make it that you can toggle sources within a group. You can toggle the group as a whole, but the sources within it aren't an option.
Version 1.1.3.0 should supports Nested Scene and for source hide/show, an automatic 'null transition' to output for Studio Mode (which is only a workaround, waiting to implement "Transition" and so on.

I'm working right now on how Groups works.

(also, dependencies included were updated)
 
Weird. Ever since the last update, it now no longer detects midi over the network via rtpMidi. And I tried uninstalling and reinstalling the older version, but it still doesn't work now. Local midi devices on the PC work fine.
Annoying because the whole point is to control OBS on the PC from my Macbook Pro.
 
Aside from the above, the way that the sources are being shown / hidden seems like a bit of a hack. One of the side effects is that when you show or hide a source in a scene that is not the current one in the Program, the Preview monitor is changed to the current scene in Program. This is true whether the scene you're affecting is in the Preview, or not open at all.

I know nothing about this, but I think there might be a different way of interacting with the sources via Websocket than the method you're using currently. With Deckboard for instance, showing or hiding a source doesn't cause the momentary greying of the transition buttons, which presumably means they're not using a null transition to make it instant.
 

Etuldan

Member
Weird. Ever since the last update, it now no longer detects midi over the network via rtpMidi. And I tried uninstalling and reinstalling the older version, but it still doesn't work now. Local midi devices on the PC work fine.
Annoying because the whole point is to control OBS on the PC from my Macbook Pro.
Could you check that the midi in not in the "MIDI Interface to ignore" nor on the "MIDI Forwarding" ? Also, could you check that no other software is trying to use this MIDI interface ? (MIDI is exclusive)

Aside from the above, the way that the sources are being shown / hidden seems like a bit of a hack. One of the side effects is that when you show or hide a source in a scene that is not the current one in the Program, the Preview monitor is changed to the current scene in Program. This is true whether the scene you're affecting is in the Preview, or not open at all.

I know nothing about this, but I think there might be a different way of interacting with the sources via Websocket than the method you're using currently. With Deckboard for instance, showing or hiding a source doesn't cause the momentary greying of the transition buttons, which presumably means they're not using a null transition to make it instant.
Yes, it's a 'hack'. There is no way to send (from what I found) in the real output without using it in preview.
So yes, it switchs preview to the current real output, switch hide/show, swich the real output from preview, then switch the preview to the original one.

But the preview should be switched back after all.
 

Etuldan

Member
Weird. Ever since the last update, it now no longer detects midi over the network via rtpMidi. And I tried uninstalling and reinstalling the older version, but it still doesn't work now. Local midi devices on the PC work fine.
Annoying because the whole point is to control OBS on the PC from my Macbook Pro.
I just tried (with rtpMIDI, on loopback, ensuring 'real' midi interface is disabled in MIDIControl) and it works perfectly. If there is still an issue, it may be related to the MIDI interface, and something I did wrong. Let me know, and I'll send you a debug version (with massive log output) .
 
I just tried (with rtpMIDI, on loopback, ensuring 'real' midi interface is disabled in MIDIControl) and it works perfectly. If there is still an issue, it may be related to the MIDI interface, and something I did wrong. Let me know, and I'll send you a debug version (with massive log output) .
Interesting. I can't get it to register anything via rtpMIDI. If I open Midi2Key it is seeing the midi notes, so they're definitely coming across the network. I'm not sure if this problem was inroduced with the most recent update, or the previous one.
Is there a file I can delete to completely reset your application?
 

Etuldan

Member
Could you try to 'inspect' MIDI in Devices (with something like http://www.midiox.com/ , in menu Options, MIDI devices for example, see if all MIDI interface are 'OK' ? )
Also, the MIDI In interface is listed in MIDIControl, in the Options , "MIDI Interface to ignore" ? If yes, then it's a bug about catching MIDI event in MIDIControl. If no, then the MIDI Interface is bugged.)
 

Matias228

New Member
If I may add Volume for faders would be awesome too! And Midi feedback to the devices would be super useful, if you use something like an APC Mini or Launchpad etc. you could use that to switch on (off)) the LEDs on the pads...
 
Top