Microphone Crackling During Gameplay Recording (not streaming)

57Penguins

New Member
Hey there,

This is my first time ever posting in a forum so hopefully I do alright. I usually am pretty good about troubleshooting and solving my issues on my own; however, I am at a complete loss on this one.
I have been using OBS to record videos for YouTube for a little while now, a little over a month, with relatively no problems. However, just a few days ago, I noticed my mic audio had crackling pretty much whenever I spoke, at any volume.
The really interesting part is that the mic audio is perfect anywhere else, but as soon as I open a game, the mic audio starts cracking, but if I'm recording just my desktop or internet pages, it's completely fine. Also, my mic audio is fine in discord and Audacity.

It is important to note I do not stream, just record.

I have tried numerous different things to try and correct this issue, far too many to possibly list here, but I will try to mention everything that I can remember.
Things I have tried:
1. Using a De-Clicker plug in for Audacity
2. Setting everything to 44.1khz and lowering the bitrate in the audio output settings for my microphone.
3. checking driver updates and even tried rolling back to a previous audio driver (not realtek)
4. Removing all filters on the microphone and adding them one at a time - no use.
5. Tried changing the output format to MOV (from a previous thread post) but this did not work.

I am at a point of complete loss, desperation, and depression. I could really use someone much smarter than me to help me resolve this issue.

I have posted the log from my most recent test recording. I can easily recreate the issue so if there is anything at all that I can provide that anyone would think to be useful, I would be happy to post it, just let me know.

Thank you for reading, and I'm very much looking forward to any help.
 

Attachments

  • 2022-10-01 12-47-23.txt
    11.9 KB · Views: 20

PaiSand

Active Member
 

57Penguins

New Member
Hey PiaiSand,

Any suggestions on how to correct Max Audio Buffering Issue?
It's stating that this is from a CPU usage issue, but OBS states that during recording my CPU usage is often less than 1%, and task manager isn't showing anything crazy when recording.

Thank you,
 

PaiSand

Active Member
Don't forget to turn ON Windows 10 Game Mode
About the max audio buffering, it normally corrects itself restarting OBS or the computer if necesary.
What the majority do is set all the audios to 48Khz as it's better, unless you have an audio source not supporting it.

Run OBS as admin. Always.
Verify the CPU and GPU drivers are up to date. If you don't fear to mess up with, check BIOS updates.
Don't set monitor/display source on the same scene as window and/or game source.
Recording in CQP is better but remember the CQ level must be between 23 and 15. You have set it to 14.
 

57Penguins

New Member
Hey PaiSand,
I will turn on Game Mode and set the CQ level to the default 20 and see if that helps.

I have also discovered just now that this may not actually be an obs isssue. I did a test recording solely in Audacity where I spoke for a little bit, then opened a game and spoke and I got the very same crackling, it appears to occur only during playing a game.

Also, I have restarted both OBS and the computer several times since discovering this issue, so I'm not sure why there would be an audio buffer issue.

Needless, to say, still looking for any advice you may have. I'll try to do another test recording after work tonight and maybe post another log.

Please any advice any one has would be great. Would really like to have clean audio again.
 

PaiSand

Active Member
In that case, check on your mobo vendor page an update for the audio driver. It's good practice to keep an eye on this mobo updates.
 

57Penguins

New Member
Hey PaiSand,

If you or anyone wanted some closure on this problem. It appears that turning on Game Mode (which I turned off originally to get OBS to record better) seems to have fixed the issue. I've been working on this for literally days and that one setting fixed it. I can't believe it. Dude, you probably didn't know it, but you've been a freaking huge help.

Thank you so much.
 
Top