Looking for CPU Saving suggestions before deciding to upgrade

hamferglar

New Member
Hey Everyone,

One of my first times posting on the forum... I've recently started streaming again after a while and went through the effort of upgrading my overlays, alerts, scenes, etc. What I didn't account for is how these alerts and overlays would affect my CPU performance. On my busiest scene (labels, an animated webcam boarder and a super alert), my CPU reaches up to 19% and that's without streaming or recording. On top of that, while I'm playing my main game which is Valorant, my frames will drop down to almost 50 FPS when a super alert occurs, and doesn't even cap out at 144FPS which it does no problem without OBS open/streaming. I've also tried lowering all my graphics quality settings to the lowest settings in game which doesn't help.

I've read the CPU Usage post on the main page, and while I see that these are ways to lower my CPU usage, a lot of these suggestions seem to sacrifice the quality of the stream (resolution, FPS output, etc) and I'm not prepared to do that. (900P 60FPS)

So I thought I'd go on a whim here, post a few of my logs from my previous streams that were fairly busy with alerts and whatnot, and see if there's anything that can be suggested to save my gameplay. If not, and it seems that the only way is to upgrade my CPU, I will take that into account.

Thanks in advance!
 

Attachments

  • Stream Log - 2022-07-18 18-58-07.txt
    546.7 KB · Views: 8
  • 2022-07-16 17-16-15.txt
    933.3 KB · Views: 4
  • 2022-07-16 17-18-12.txt
    147.8 KB · Views: 5

koala

Active Member
You activated rescaling in the encoder in settings->output->streaming->rescale output. Disable this. This runs in CPU space and is a bottleneck. Instead just set your output resolution in settings->video->output resolution. This rescaling takes place on the GPU and uses next to none resources, since the GPU is specialized on that kind of operation.
 

hamferglar

New Member
You activated rescaling in the encoder in settings->output->streaming->rescale output. Disable this. This runs in CPU space and is a bottleneck. Instead just set your output resolution in settings->video->output resolution. This rescaling takes place on the GPU and uses next to none resources, since the GPU is specialized on that kind of operation.
Great I will definitely try this! I will try to stream again with this change and see if there's any improvement... I'm also wondering if there's any way to make my overlays (I use streamelements) less intensive? I have my overlays as a browser source as normal but every time an alert comes up it noticeably affects the game and the stream.
 
Top