Is there a way to mute a sound from a certain window in the video but you can hear when recording?

blunt_bear

New Member
So I want to record a certain window using OBS but have something playing in the background like YouTube or Windows Media Player, and I want to be able to hear that audio while recording, but I don't want it to be heard in the video. But I want the sound from the window I'm recording on to remain in the video so I can't just simply mute the desktop audio.

Sorry my explanation is all over the place but is there a way around this?
 

Sukiyucky

Member
You don't control via a window. You control via an application, audio device.

Use the App Volume and Device Preferences in Windows Sound
  1. Right click on the speaker icon in the windows tray
  2. Choose Open Sounds Settings
  3. Scroll down to Advanced sound options
  4. Click on App volume and device preferences
  5. Launch Windows Music Player or the browser you are using to bring up YouTube (*)
  6. That application will show up in the App list
  7. Control audio volume via the slider for the application
  8. Control mute by clicking on or off the speaker icon for the application
(*) Initially applications will not be listed. Only when they are requesting audio support will they be listed. Settings will be saved and recalled from this point on after you have specified the settings.

If you want more dynamic control, right click on the speaker icon in the windows tray
  1. Use Windows volume mixer to mute and set volume levels. Settings will be remembered and recalled per application.
 

blunt_bear

New Member
You don't control via a window. You control via an application, audio device.

Use the App Volume and Device Preferences in Windows Sound
  1. Right click on the speaker icon in the windows tray
  2. Choose Open Sounds Settings
  3. Scroll down to Advanced sound options
  4. Click on App volume and device preferences
  5. Launch Windows Music Player or the browser you are using to bring up YouTube (*)
  6. That application will show up in the App list
  7. Control audio volume via the slider for the application
  8. Control mute by clicking on or off the speaker icon for the application
(*) Initially applications will not be listed. Only when they are requesting audio support will they be listed. Settings will be saved and recalled from this point on after you have specified the settings.

If you want more dynamic control, right click on the speaker icon in the windows tray
  1. Use Windows volume mixer to mute and set volume levels. Settings will be remembered and recalled per application.
Thank you for the detailed instruction but this causes me to not hear the sound at all. I want to be able to hear the audio, but not have it onto the recording.
 

Sukiyucky

Member
Make sure to setup the Monitoring Device in Audio.
The monitoring device should be set to your headphones

Click on the cogwheel for any source listed in the audio mixer panel to bring up advanced audio properties.
Fiddle with the drop down for audio monitoring for the source.
Monitor Off = Your not going to hear audio for that source in the monitoring devices; audio will be captured on a specified track
Monitor On and Output = You will hear audio in the monitoring device for that source and it will be captured on a specified track
Monitor Only and mute output = Your will hear audio in the monitoring device for that source and it will NOT be captured

In your case, set it to Monitor Only and mute output
 

blunt_bear

New Member
Make sure to setup the Monitoring Device in Audio.
The monitoring device should be set to your headphones

Click on the cogwheel for any source listed in the audio mixer panel to bring up advanced audio properties.
Fiddle with the drop down for audio monitoring for the source.
Monitor Off = Your not going to hear audio for that source in the monitoring devices; audio will be captured on a specified track
Monitor On and Output = You will hear audio in the monitoring device for that source and it will be captured on a specified track
Monitor Only and mute output = Your will hear audio in the monitoring device for that source and it will NOT be captured

In your case, set it to Monitor Only and mute output
This is exactly what I was looking for thank you!!
 

AydenMK8

New Member
Make sure to setup the Monitoring Device in Audio.
The monitoring device should be set to your headphones

Click on the cogwheel for any source listed in the audio mixer panel to bring up advanced audio properties.
Fiddle with the drop down for audio monitoring for the source.
Monitor Off = Your not going to hear audio for that source in the monitoring devices; audio will be captured on a specified track
Monitor On and Output = You will hear audio in the monitoring device for that source and it will be captured on a specified track
Monitor Only and mute output = Your will hear audio in the monitoring device for that source and it will NOT be captured

In your case, set it to Monitor Only and mute output
Hey! So, I've done exactly what you said but now I can't get either of the windows' audio on my recording. Any ideas why this may be?
 

SamwiseLA

New Member
I must be missing something :(
When I turn down Edge or Chrome, the volume goes down in OBS as well...
If I mute it in the mixer, I don't hear it in OBS. :/
 

Gled_mid

New Member
Is there any way to do the opposite of this original thread ?? ie, i want to mute audio coming from my speaker but recording should have the audio. Thanks.
 

senamon

New Member
Is there any way to do the opposite of this original thread ?? ie, i want to mute audio coming from my speaker but recording should have the audio. Thanks.
There's! In fact, I've also looked at this thread in a search for this info, and it has an answer. It's just the instructions aren't clear, and with the lack of screenshots, it's hard to orient yourself in all the settings.

Essentially, you need to prepare these things:
  1. A separate browser or audio player;
  2. Open the Volume Mixer in Windows;
  3. Open the Advanced Properties for the same browser/player in your audio sources in OBS.
A separate app is needed because you can control where the audio goes only for a specific app (e.g., you can't control it for a single tab in the browser, as far as I understand).

Now, that you've prepared it, open your volume mixer: right-click on the sound icon in the bottom right -> click 'Open volume mixer' (it's in Windows 11; in Windows 10 it might be called slightly differently). In the opened menu, there's a list of active apps with options to choose input or output devices. You are interested in the output device-that's where the magic begins.
By default, the output device is the active audio device (which it better be headphones for streaming/recording). But, in my laptop, for instance, there's a built-in audio system; and in the Output Device options, I can manually choose my built-in system as the device for a specific app. Now, because my built-in system is not active (headphones are), the audio from that specific app is not playing in the headphones-and it's not playing from the laptop as well. The sound goes nowhere. But OBS can pick it up.

If you come back to OBS, you can choose that built-in system as an audio source. And, once you choose it as the source in preferences, you will notice that it picks up the volume of what is playing within OBS-even though you don't hear it yourself. I think you need the Monitor On option enabled, so check that too.

And that's kind of it! It's a combination of Windows and OBS settings. I don't know if this setup can be reproduced with any device (for instance, I don't know how it would work if you don't have a built-in audio system on your PC), but that's a general gist of it. Good luck!
 
Top