I need some assistance.

Hello all, first-time poster here. I'm sure you've all heard this a million times before, but I was hoping if I could get some assistance with my laptop. It's quite underpowered- a Dell XPS 15 9550 with an Intel Core i7-6700HQ CPU @ 2.6 GHz (4 cores, 8 logical processors), 32 GB of RAM, and 1TB of storage (HDD). I have two graphics cards: an Intel HD Graphics 530 and an NVIDIA GeForce GTX 960M. I don't stream, but I record using OBS; as most newcomers have stated on this forum, I experience lag and dropped frames whenever I try to record. I have read and followed every tutorial to the letter, but to no avail. I have checked multiple log files, and they all point to 'Rendering Lags/Stalls' and 'Encoding Lag/Overload'. In accordance with the tutorials for troubleshoting dropped frames and encoding overload, I have reduced the settings for my recordings, to- once again, no avail. I lack the funds to buy a new laptop. What I'd like to ask all of the more experienced members of this forum is thus: Is there a setting on my computer that I'm missing? Can someone point me to a thread for discussing configurations for underpowered laptops? Do any of you know where I can purchase newer components for my laptop so it ay be upgraded? Any help would be greatly appreciated. Thanks in advance for your time and consideration.
 

Attachments

  • 2022-03-07 09-23-49.txt
    5.9 KB · Views: 10
  • 2022-03-07 09-25-18.txt
    16.6 KB · Views: 4
  • 2022-03-07 13-43-38.txt
    23.2 KB · Views: 5
  • 2022-03-07 18-41-02.txt
    11.6 KB · Views: 8
  • 2022-03-07 17-29-51.txt
    20.5 KB · Views: 8
  • 2022-03-07 16-39-34.txt
    19.2 KB · Views: 5
  • 2022-03-07 15-56-41.txt
    14.5 KB · Views: 6
  • 2022-03-07 15-56-25.txt
    11.6 KB · Views: 5

Lawrence_SoCal

Active Member
realize the OBS logs do NOT provide a bunch of OS level detail
And discussions on under-powered are general, the fact that it is a laptop is largely irrelevant, other than thermal throttling. For thermal throttling, (ie to avoid) you need make sure plenty of airflow. Other than that, desktop and laptop optimization is likely to be similar/same

- What are you doing for real-time monitoring of hardware resource utilization? if you aren't doing this, that is the equivalent of driving a car blnd-folded
- so, yes, 1st step is to optimize at OS level. A lot of Internet guides are from naive/ignorant types who have no clue what they are talking about... unfortunately. And some of them can really get you into trouble
- I'd recommend starting with guides on optimizing OS for virtual desktop (VDI) environments, as that is focused on reduced CPU, RAM, and especially graphics processing overhead. With that said, you have a decent amount of RAM, so I'd focus more on making sure unnecessary background processes NOT running ... what are those? depends..sorry
- Personally, I turn off a lot of the WIn10 eye candy type stuff
- Then, you are running on a SSD right, not a HDD? Swapping from a HDD to SSD (presumably SATA on that age system) will make a huge performance difference
- rescaling takes extra effort, but then less data to process. Do I have this right, you are running on a 4K monitor, with that CPU and GPU?

I checked and the couple of logs I looked at were incomplete/partial logs. I'm not going to check every log posted. Point to a specific log, or upload new, where you aren't playing with resolutions, everything is connected/working (input, camera, whatever) and you actually record for a minute or more. I take it the 2nd to last log is a decent one to work with?

- read posts/ article on why NOT to use CBR for recording [you could start with https://obsproject.com/forum/threads/best-settings.140188/#post-514693 @FerretBomb comment #2 ] including why NOT to record to MP4, unless you really know what you are doing (in which case you wouldn't be posting here as you did).
- The CoreAAC encoder is known for higher quality, but did you test to see CPU impact?
- And for downscaling, I recommend researching which algorithm/scaling methods are more performant (ie lower CPU demand at impact to quality)

And recognize, you may well be straining your system, especially the GPU to drive a 4K monitor. Then you are trying to add real-time video encoding which is VERY computationally demanding. Helped by using NVENC.. but still..
Have you tested turning off Psychovisual Tuning and/or Lookahead?
 
"What are you doing for real-time monitoring of hardware resource utilization? if you aren't doing this, that is the equivalent of driving a car blind-folded."
I'm using Task Manager/Resource Monitor, and I have an icon in my Taskbar which displays real-time hardware usage.

"I'd recommend starting with guides on optimizing OS for virtual desktop (VDI) environments, as that is focused on reduced CPU, RAM, and especially graphics processing overhead."
Do you have any suggestions?

"Personally, I turn off a lot of the WIn10 eye candy type stuff"
Like what?

"Then, you are running on a SSD right, not a HDD?"
I actually thought I was using an HDD, but I just checked my system information and it turns out I'm indeed using an SSD.

"Rescaling takes extra effort, but then less data to process. Do I have this right, you are running on a 4K monitor, with that CPU and GPU?"
Yes, I have a 4K monitor.

"I checked and the couple of logs I looked at were incomplete/partial logs."
Pick any one from the three I'm about to upload.

"The CoreAAC encoder is known for higher quality, but did you test to see CPU impact?"
Not yet. Is that for video or audio?

"Have you tested turning off Psychovisual Tuning and/or Lookahead?"
Not yet. I will.
 

Attachments

  • 2022-03-07 13-43-38.txt
    23.2 KB · Views: 9
  • 2022-03-07 16-39-34.txt
    19.2 KB · Views: 5
  • 2022-03-07 17-29-51.txt
    20.5 KB · Views: 5

dmemphis

Member
I use similarly powered desktop PCs- quad core I7s from 2.6ghz on up.
Are you capturing gaming? I have seen folks with issues gaming and using OBS
on the same computer. I don't game, I use it as a camera production switcher system
with graphic card lower than yours- typically GT710 and GTX750. I record with no issues
(while streaming too). I do however, record to a separate SSD drive from the OS drive.
I have recorded 1080p at 10k bps mkv format with no issues while streaming at about 3kbps.
Today I'm typically running at 720p resolution, which gives me more headroom.
My streaming uses the NVENC. PM me if you want to talk about it.
 

koala

Active Member
It seems nobody looked at your logfiles.

Code:
13:43:46.976: error:   Driver does not support the required nvenc API version. Required: 11.1 Found: 9.1
13:43:46.976: error:   The minimum required Nvidia driver for nvenc is (unknown) or newer
The current Nvidia driver is some 511.x. Get and install it, then use nvenc as encoder instead of x264, which may be too cpu intensive for your Laptop.

Code:
13:43:40.838: video settings reset:
13:43:40.838:     base resolution:   3840x2160
13:43:40.838:     output resolution: 1280x720
[...]
13:43:46.873: [jim-nvenc] scaling enabled, falling back to ffmpeg
[...]
13:43:46.874:     width:        1280
13:43:46.874:     height:       720
These entries tell you activated Settings->Output->Recording->Rescale Output to 1280x720, although the output was already rescaled to 1280x720 in Settings->Video. Disable rescaling in the encoder settings, because this is a huge performance hit. Rescaling in Settings->Video instead is free.

You don't capture from your Laptop with 4k resolution, instead you capture with some capture device with a resolution of 1920x1080. So use a canvas size of 1920x1080 in Settings->Video! If you use 4k here and rescale to 1280x720, you first upscale the capture device input from 1920x1080 to 3840x2160, then downscale this to 1280x720, which is not only bad for performance but also bad for quality.
So use a canvas size of 1920x1080 and an output size of 1280x720 in Settings->Video and don't enable rescaling in the encoder settings.

Final remark: don't use advanced output mode. You used an improper rate control for recording in advanced mode (CBR instead of CQP). Use simple output mode instead and just choose an appropriate quality in the "Recording quality" dropdown, which is probably either "High Quality, Medium file size" or "Indistinguishable Quality, Large file size" to avoid this kind of error.
 
I use similarly powered desktop PCs- quad core I7s from 2.6ghz on up.
Are you capturing gaming? I have seen folks with issues gaming and using OBS
on the same computer. I don't game, I use it as a camera production switcher system
with graphic card lower than yours- typically GT710 and GTX750. I record with no issues
(while streaming too). I do however, record to a separate SSD drive from the OS drive.
I have recorded 1080p at 10k bps mkv format with no issues while streaming at about 3kbps.
Today I'm typically running at 720p resolution, which gives me more headroom.
My streaming uses the NVENC. PM me if you want to talk about it.
Will do!
 
It seems nobody looked at your logfiles.

Code:
13:43:46.976: error:   Driver does not support the required nvenc API version. Required: 11.1 Found: 9.1
13:43:46.976: error:   The minimum required Nvidia driver for nvenc is (unknown) or newer
The current Nvidia driver is some 511.x. Get and install it, then use nvenc as encoder instead of x264, which may be too cpu intensive for your Laptop.

Code:
13:43:40.838: video settings reset:
13:43:40.838:     base resolution:   3840x2160
13:43:40.838:     output resolution: 1280x720
[...]
13:43:46.873: [jim-nvenc] scaling enabled, falling back to ffmpeg
[...]
13:43:46.874:     width:        1280
13:43:46.874:     height:       720
These entries tell you activated Settings->Output->Recording->Rescale Output to 1280x720, although the output was already rescaled to 1280x720 in Settings->Video. Disable rescaling in the encoder settings, because this is a huge performance hit. Rescaling in Settings->Video instead is free.

You don't capture from your Laptop with 4k resolution, instead you capture with some capture device with a resolution of 1920x1080. So use a canvas size of 1920x1080 in Settings->Video! If you use 4k here and rescale to 1280x720, you first upscale the capture device input from 1920x1080 to 3840x2160, then downscale this to 1280x720, which is not only bad for performance but also bad for quality.
So use a canvas size of 1920x1080 and an output size of 1280x720 in Settings->Video and don't enable rescaling in the encoder settings.

Final remark: don't use advanced output mode. You used an improper rate control for recording in advanced mode (CBR instead of CQP). Use simple output mode instead and just choose an appropriate quality in the "Recording quality" dropdown, which is probably either "High Quality, Medium file size" or "Indistinguishable Quality, Large file size" to avoid this kind of error.
Thanks for your input; I'll make the changes and get back to you with my results.
 
Here's a new logfile with my latest configuration. I'm still experiencing dropped frames.
 

Attachments

  • 2022-03-09 17-12-52.txt
    29.9 KB · Views: 7
Top