Question / Help Help!! PC OBS Not Recieving Audio From S9 Mixer, But MacBook Is!?

DJ McCrae

New Member
I am a DJ trying to stream mixes to Twitch by using OBS, and my mixer is a Pioneer DJM-S9. OBS recognizes the mixer but doesn’t receive sound, no matter if it is the Input Audio Capture Device, Output Audio Capture Device, or Desktop Audio. I notice that in my PC’s sound settings that it isn’t receiving audio either because “No Jack Information Found”.

I thought it might be a software compatibility issue but my MacBook OS X’s OBS DOES receive the audio. And i did not have to download any 3rd party software to re-route the audio for OBS to receive audio.

When I have the mixer disconnected from the PC, OBS does receive audio if play music from my DJ Program “Serato DJ Pro”. I have spent days and days trying to figure this out. If you need anymore information please ask!! Help!

DJ McCrae
 

Faulty Systems

New Member
I've got roughly the same problem. I've posted a thread about it just this afternoon.

I think it has something to do with the way the DJM routes the master output back to itself. In my case windows sound settings does recognize the mic input.
But only when I have the sample rate set to the same setting in all applications. Have you checked the sample rate settings? Set them all to 48 of 44.1 and see if windows recognizes the input. Also try messing with the "exclusive mode" settings of the audio device settings in windows.
 

Faulty Systems

New Member
In my case I have to press a button at the rear of my Xone px5 in order to route the master output into input channels 9 and 10. Audacity for example does recognize the input but OBS doesn't. You also can't select a specific input channel in OBS, just the device itself. Maybe it's just in possible to set it up this way.

Does serato has a broadcast option? Cause I've found a workaround but I haven't fully tested it yet.
 

DJ McCrae

New Member
I found out how to do it!!! Get a Stereo to AUX cord, plug the red and white stereo jacks into the Master Out on your Pioneer S9 (seems like this will work with any mixer/ controller) and plug the AUX into your desktop’s Mic jack. Then go to your computers sound settings, there will be 4 tabs at the top of that screen showing Playback, Recording, Sounds, Communications. Click the tab Recording and it will show the devices that are able to record. Play music with your mixer while looking at the recording devices to see which one has audio levels. Hopefully your computers Mic will show audio playing, if you find it, rename it so you can easily find it in OBS when you are assigning it to your Audio Input Capture. (Doesn’t matter which Audio Input Capture it is, could be 1,2,3, etc.)

The problem was fixed and could hear everything coming out of my mixer! BUT I was having really bad static from the computers Mic jack if any AUX cord was plugged into it. To fix the problem I went to my Audio Input Capture, right clicked on it and selected the Filter tab. I added the filers: Noise Suppression, and Noise Gate. Then magically the static stopped. I didn’t make a single change to the filters, somehow just adding them made the static stop.

Hopefully this works for you too
 

DJ McCrae

New Member
In my case I have to press a button at the rear of my Xone px5 in order to route the master output into input channels 9 and 10. Audacity for example does recognize the input but OBS doesn't. You also can't select a specific input channel in OBS, just the device itself. Maybe it's just in possible to set it up this way.

Does serato has a broadcast option? Cause I've found a workaround but I haven't fully tested it yet.


I found out how to do it!!! Get a Stereo to AUX cord, plug the red and white stereo jacks into the Master Out on your Pioneer S9 (seems like this will work with any mixer/ controller) and plug the AUX into your desktop’s Mic jack. Then go to your computers sound settings, there will be 4 tabs at the top of that screen showing Playback, Recording, Sounds, Communications. Click the tab Recording and it will show the devices that are able to record. Play music with your mixer while looking at the recording devices to see which one has audio levels. Hopefully your computers Mic will show audio playing, if you find it, rename it so you can easily find it in OBS when you are assigning it to your Audio Input Capture. (Doesn’t matter which Audio Input Capture it is, could be 1,2,3, etc.)

The problem was fixed and could hear everything coming out of my mixer! BUT I was having really bad static from the computers Mic jack if any AUX cord was plugged into it. To fix the problem I went to my Audio Input Capture, right clicked on it and selected the Filter tab. I added the filers: Noise Suppression, and Noise Gate. Then magically the static stopped. I didn’t make a single change to the filters, somehow just adding them made the static stop.

Hopefully this works for you too
 
Top