FYI: macOS Virtual Cam on OBS 26.1

Not open for further replies.


New Member
also confirm that issue

Can't get Virtual Camera OBS on Mac Mini 16GB M1.

No VC in Zoom and other apps.

on which files I should remove signature in
Last edited:


New Member
Same as above. The "start virtual camera" in the Controls of OBS 26.1.2 doesn't work for me. And thus I can't get zoom to recognize the virtual camera. How can we solve the problem? I'm using MacBook Air Mac Catalina 10.15.7. Thank you in advance for any help.


New Member
A suggestion from a colleague has a (potentially) workable solution for those struggling with the lack of virtual cams on a Mac/Teams combo: If you have a dual monitor setup, share one full display. Then, right click on a given scene and select "Fullscreen Projector Preview" to that shared screen. I've tested from other devices and it does appear to successfully send that scene via Teams. Switching between scenes is slow and manual, because you'll need to exit and restart a new projector, but it could be done. I'm in a situation where there's only one primary scene I need and the others are luxury, so this might work. I say might because I haven't tested it at length and my computer (MBP 15", mid 2014, running 10.15.7) pretty much immediately goes full jet engine.


New Member
Just downloaded OBS 26.1.2 and can confirm I am not able to see the virtual cam in Google Meet or Zoom.
Running MacOS Big Sur 11.1.


New Member
Please test if the resolution of the cam is set to 1280x800 or 1280x720, whether the VirtualCam then works.


New Member
I removed the signature from Skype and Teams. Now the preview works, but no output through the network. No one can see my video.

# everything executed with sudo

codesign --remove-signature "/Applications/"
codesign --remove-signature "/Applications/ Helper (Renderer).app"
codesign --remove-signature "/Applications/ Helper (GPU).app"
codesign --remove-signature "/Applications/ Helper (Plugin).app"
codesign --remove-signature "/Applications/"

codesign --remove-signature "/Applications/Microsoft"
codesign --remove-signature "/Applications/Microsoft Teams"
codesign --remove-signature "/Applications/Microsoft Teams Helper (GPU).app"
codesign --remove-signature "/Applications/Microsoft Teams Helper (Plugin).app"
codesign --remove-signature "/Applications/Microsoft Teams Helper (Renderer).app"

Works fine e. g. with Google Meet.
It worked for me on Big Sur and after deleting microsoft keychain cache. :-)


New Member
Okay I deleted the Plug-In, and suddenly I dont have a cam at all. When I open photo Booth it says: No camera connected. When I try to find the original mac cam in the "camera" section it doesnt show any camera. Does anybody know what to do?


New Member
Same happening here, but with removing the code signing I could otherwise use Teams, but OBS keeps seemingly randomly (yet not immediately) crashing on me often after Catalina update + 26.0.2 > 26.1.2 update at the same time. Something changed there. Tried 26.0.2 and that crashes now, too, which it pretty much never did. :/ Have removed virtual cam plugin and others that could be old (and 32bit or otherwise something Catalina doesn’t approve) yet still crashing. I don’t know if I’m still missing something else.


New Member
OBS virtual camera does not show in Google Meet with 26.1.2. It was slow in 26.1 but showed.

Update: Google Meet shows a message that camera is starting then shows a frozen image from The virtual camera.
Last edited:


New Member
Solved! I had the same problem: everything worked alright (zoom, meet, etc), except for Teams. The virtual camera was detected, apparently no problem at all, but other participants could not see my video. Alternatively, I was using the teams web client in Chrome, but the quality was not very good. Using combined information from other posts in this forum, and experimenting, I have solved the problem this way:

1- Quit OBS and teams completely.
2- Uninstall OBS (export your scenes before if needed), remove its application support directory (/Library/Application Support/obs-studio), and the virtual camera plugin (/Library/CoreMediaIO/Plug-Ins/DAL/obs-mac-virtualcam.plugin). Don't worry: the new installation will restore them both.
3- Install OBS version 26.1 (NOT 26.1.1 nor 26.1.2). Looks like something in those versions caused the problems with teams. Here you have the link: .
3- Run it, and the wizard will come up. I chose use for virtual camera.
4- Start virtual camera (remember now it is on the right side panel, not in the tools menu). Your password will be required because the plugin will be placed in the DAL directory again).
5- Run Teams. Ta-da!! Virtual camera up and running again! :)


New Member
Note that in OBS Studio v26.1 on macOS, if you already have the original version of the virtual camera plugin from johnboiles, you may need to uninstall it first before using the built-in version of the plugin:

Make sure OBS is closed, and then do the following:
  1. Open a new Finder window

  2. Hit "CMD+SHIFT+G", then enter /Library/CoreMediaIO/Plug-Ins/DAL/

  3. Delete the file named obs-mac-virtualcam.plugin - you might be asked for your password to confirm the deletion

  4. Hit "CMD+SHIFT+G" again, now enter /Library/Application Support/obs-studio/plugins

  5. Delete the folder named obs-mac-virtualcam - again, you might be asked for your password
Now you are set to use OBS' built-in virtual camera plugin

hi @
in my installation : OBS 26.1.2. Mac OS Big Sur 11.2 doesn't exist -->/Library/Application Support/obs-studio/plugins.
The OBS virtualcam doesn't work for example in Skype. I'am very sad about it and I don't have any idea about a solution .
perhaps someone has a proposal/idea I'm very interested.........


New Member
Hello, I'm a student. It's urgent! :(

Yesterday, somehow after entering all the codes in Terminal; virtual camera OBS has appeared in Teams.
Then, I had to uninstall everything.

I have OBS 26.1.0
macOS Catalina 10.15.7.

I scanned the whole trees pages of this Forum.
Can y
Hello all! I'm still searching for an answer on this...Virtual Cam works for Discord only in browser, but is not recognized on the Discord app.


New Member
The virtual camera doesn't show up for FaceTime or Google Meet. It does however show up for Zoom, Quicktime, and Final Cut (haven't checked iMovie), which is good... Is it supposed to work across all video conferencing or is it limited to just Zoom?

I'm on Catalina 10.15.6


New Member
Puede alguien ayudarme. No puedo encontrar paneles personalizados de obs Studio en mac.


New Member
To enable Virtual Cam for Zoom (OBS 26.1.2)

codesign --remove-signature /Applications/

All working fine again.


New Member
@LPH : Open settings, goto video, set Base Resolution and Output Resolution to the same value. Google Meet sometimes has problems with scaling.


Thank you for the response. Both are (and were) set to 1280 x 720. I tried Google Meet at 360 instead of auto and the lag is still present. The lag is up to 15 seconds.
Not open for further replies.