[FFMPEG VAAPI encoder: 'streaming_h264'] Failed to open VAAPI codec: Function not implemented

syori

New Member
Code:
02:37:52 AM.241: CPU Name: AMD Ryzen 7 2700 Eight-Core Processor
02:37:52 AM.241: CPU Speed: 2764.164MHz
02:37:52 AM.241: Physical Cores: 8, Logical Cores: 16
02:37:52 AM.241: Physical Memory: 24043MB Total, 14249MB Free
02:37:52 AM.241: Kernel Version: Linux 5.9.1-arch1-1
02:37:52 AM.242: Distribution: "Arch Linux" Unknown
02:37:52 AM.242: Window System: X11.0, Vendor: The X.Org Foundation, Version: 1.20.9
02:37:52 AM.242: Portable mode: false
02:37:52 AM.309: OBS 26.0.1.r72.g810c5ecc (linux)
02:37:52 AM.309: ---------------------------------
02:37:52 AM.310: ---------------------------------
02:37:52 AM.310: audio settings reset:
02:37:52 AM.310:     samples per sec: 48000
02:37:52 AM.310:     speakers:        2
02:37:52 AM.313: ---------------------------------
02:37:52 AM.313: Initializing OpenGL...
02:37:52 AM.392: Loading up OpenGL on adapter X.Org Radeon RX 560 Series (POLARIS11, DRM 3.39.0, 5.9.1-arch1-1, LLVM 10.0.1)
02:37:52 AM.392: OpenGL loaded successfully, version 4.6 (Core Profile) Mesa 20.2.1, shading language 4.60
02:37:52 AM.406: ---------------------------------
02:37:52 AM.406: video settings reset:
02:37:52 AM.406:     base resolution:   1920x1080
02:37:52 AM.406:     output resolution: 1920x1080
02:37:52 AM.406:     downscale filter:  Lanczos
02:37:52 AM.406:     fps:               60/1
02:37:52 AM.406:     format:            NV12
02:37:52 AM.406:     YUV mode:          sRGB/Full
02:37:52 AM.406: NV12 texture support not available
02:37:52 AM.410: Audio monitoring device:
02:37:52 AM.410:     name: Default
02:37:52 AM.410:     id: default
02:37:52 AM.410: ---------------------------------
02:37:52 AM.411: Failed to load 'en-US' text for module: 'decklink-ouput-ui.so'
02:37:52 AM.488: A DeckLink iterator could not be created.  The DeckLink drivers may not be installed
02:37:52 AM.488: No blackmagic support
02:37:52 AM.493: [obs-browser]: Version 2.8.7
02:37:52 AM.497: os_dlopen(libnvidia-encode.so.1->libnvidia-encode.so.1): libnvidia-encode.so.1: cannot open shared object file: No such file or directory
02:37:52 AM.497:
02:37:52 AM.497: FFMPEG VAAPI supported
02:37:52 AM.507: [pango]: Loaded system fontconfig
02:37:52 AM.510: VLC found, VLC video source enabled
02:37:52 AM.510: ---------------------------------
02:37:52 AM.510:   Loaded Modules:
02:37:52 AM.510:     vlc-video.so
02:37:52 AM.510:     text-pango.so
02:37:52 AM.510:     rtmp-services.so
02:37:52 AM.510:     obs-x264.so
02:37:52 AM.510:     obs-vst.so
02:37:52 AM.510:     obs-transitions.so
02:37:52 AM.510:     obs-outputs.so
02:37:52 AM.510:     obs-libfdk.so
02:37:52 AM.510:     obs-filters.so
02:37:52 AM.510:     obs-ffmpeg.so
02:37:52 AM.510:     obs-browser.so
02:37:52 AM.510:     linux-v4l2.so
02:37:52 AM.510:     linux-pulseaudio.so
02:37:52 AM.510:     linux-jack.so
02:37:52 AM.511:     linux-decklink.so
02:37:52 AM.511:     linux-capture.so
02:37:52 AM.511:     linux-alsa.so
02:37:52 AM.511:     image-source.so
02:37:52 AM.511:     frontend-tools.so
02:37:52 AM.511:     decklink-ouput-ui.so
02:37:52 AM.511: ---------------------------------
02:37:52 AM.511: os_dlopen(../obs-plugins/obs-browser->../obs-plugins/obs-browser.so): ../obs-plugins/obs-browser.so: cannot open shared object file: No such file or directory
02:37:52 AM.511:
02:37:52 AM.511: ==== Startup complete ===============================================
02:37:52 AM.512: Switched to Preview/Program mode
02:37:52 AM.512: ------------------------------------------------
02:37:52 AM.515: All scene data cleared
02:37:52 AM.515: ------------------------------------------------
02:37:52 AM.523: pulse-input: Server name: 'pulseaudio 13.99.2-13-g7f4d7'
02:37:52 AM.523: pulse-input: An error occurred while getting the source info!
02:37:52 AM.523: [Loaded global audio device]: 'Desktop Audio'
02:37:52 AM.525: pulse-input: Server name: 'pulseaudio 13.99.2-13-g7f4d7'
02:37:52 AM.525: pulse-input: Audio format: s16le, 44100 Hz, 2 channels
02:37:52 AM.525: pulse-input: Started recording from 'alsa_input.usb-Kingston_HyperX_Quadcast_4110-00.analog-stereo'
02:37:52 AM.525: [Loaded global audio device]: 'HyperX QuadCast'
02:37:52 AM.525:     - filter: 'Noise Gate' (noise_gate_filter)
02:37:52 AM.525: Source ID 'linuxbrowser-source' not found
02:37:52 AM.525: Failed to create source 'Web Clock'!
02:37:52 AM.530: v4l2-input: Start capture from /dev/video0
02:37:52 AM.531: v4l2-input: Input: 0
02:37:52 AM.531: v4l2-input: Resolution: 640x480
02:37:52 AM.531: v4l2-input: Pixelformat: YU12
02:37:52 AM.531: v4l2-input: Linesize: 640 Bytes
02:37:52 AM.531: v4l2-input: Framerate: 30.00 fps
02:37:52 AM.534: xshm-input: Geometry 1920x1080 @ 1080,1080
02:37:52 AM.536: Switched to scene 'WebCam'
02:37:52 AM.538: ------------------------------------------------
02:37:52 AM.538: Loaded scenes:
02:37:52 AM.538: - scene 'WebCam':
02:37:52 AM.538:     - source: 'Background' (group)
02:37:52 AM.538:         - source: 'Background Image' (image_source)
02:37:52 AM.538:         - source: 'Web Clock' (linuxbrowser-source)
02:37:52 AM.538:     - source: 'Games' (group)
02:37:52 AM.538:         - source: 'OsuLazer' (xcomposite_input)
02:37:52 AM.538:         - source: 'Minecraft' (xcomposite_input)
02:37:52 AM.538:         - source: 'Borderlands 2' (xcomposite_input)
02:37:52 AM.538:         - source: 'Resident Evil Bench' (xcomposite_input)
02:37:52 AM.538:         - source: 'TBOI' (xcomposite_input)
02:37:52 AM.538:     - source: 'Webcam' (group)
02:37:52 AM.538:         - source: 'Camera' (v4l2_input)
02:37:52 AM.538:         - source: 'Frame' (image_source)
02:37:52 AM.538: - scene 'Break':
02:37:52 AM.538:     - source: 'Breaker' (image_source)
02:37:52 AM.538: - scene 'Scene 2':
02:37:52 AM.538:     - source: 'Screen Capture (XSHM)' (xshm_input)
02:37:52 AM.538: ------------------------------------------------
02:37:52 AM.588: Failed to open file '/mnt/2736-12AC/30G/Фоны (Надо разобрать)/Коды/Java-code-3337044_1920.jpg': No such file or directory
02:37:52 AM.588: gs_image_file_init_internal: Failed to load file '/mnt/2736-12AC/30G/Фоны (Надо разобрать)/Коды/Java-code-3337044_1920.jpg'
02:37:52 AM.588: [image_source: 'Background Image'] failed to load texture '/mnt/2736-12AC/30G/Фоны (Надо разобрать)/Коды/Java-code-3337044_1920.jpg'
02:37:53 AM.069: adding 21 milliseconds of audio buffering, total audio buffering is now 21 milliseconds (source: HyperX QuadCast)
02:37:53 AM.069:
02:38:38 AM.734: ---------------------------------
02:38:38 AM.734: [FFMPEG VAAPI encoder: 'streaming_h264'] settings:
02:38:38 AM.734:     device:       /dev/dri/renderD128
02:38:38 AM.734:     rate_control: CBR
02:38:38 AM.734:     profile:      578
02:38:38 AM.734:     level:        40
02:38:38 AM.734:     qp:           0
02:38:38 AM.734:     bitrate:      2500
02:38:38 AM.734:     maxrate:      2500
02:38:38 AM.734:     keyint:       120
02:38:38 AM.734:     width:        1920
02:38:38 AM.734:     height:       1080
02:38:38 AM.734:     b-frames:     0
02:38:38 AM.734:
02:38:38 AM.746: [FFMPEG VAAPI encoder: 'streaming_h264'] Failed to open VAAPI codec: Function not implemented
 

Attachments

  • 2020-10-26 02-37-52.txt
    6.9 KB · Views: 93
Top