Question / Help Cant stream photoshop


New Member
I have tried Lunaomi's approach and it worked fine. The only problem I have is that while it now shows the image and interface, any submenu is not shown. Like when i right click on a layer to choose an action there it is not on screen only registers the mouseclicks, same goes for any menu from the top row or sub menus from the side panel. It IS shown in monitor capture though. Anyone know how I can make them show up in window Capture?

Dengeki Matsuko

New Member
So, as far as I can tell, there's only two ways to "fix" this issue:

1. Disable Aero (Windows 7 only)
2. Disable Graphics Performance in Photoshop

These aren't fixing the issue. It's only a mask. Disabling Aero is only going to help those on Windows 7, but there are people who either are stuck using Windows 8/8.1/10 or don't want to go back to Windows 7, so option 1 is not an optimal solution. Disabling graphics performance in Photoshop can be devastating for those who don't have a good enough CPU to pull in the load the GPU was taking in, so that option can't be an optimal solution, too. Even with my setup, with an i3 4160, I still can see slow-downs and glitches when the CPU is taking in the load. There has to bee another way to fix this and I've already tried Lisa's supposed fix as well with no avail.


Omg, i had 2 years problems with this, and i just saw this topic. Ive been on these forums before, but never took the time to search on this problem. I tried Lunaomi approach and its working like a charm!

Thank you verry much!

ps.: I used an alternative method, by making 2 sourches. 1 source using windows capture, which captured the outer photoshop (tools, layers and stuff), and the other source was game capture and took capture of the painting/photo you were working on. Fiddle some with the resize, and you have 2 sources layered on eachother. But sometimes they wont lineup (shifting), so you have a mouse cursos which wasnt aligned with realtime.

Lunoami's works for sure, as long you disable graphic processor


Seems i yelled to hard. When you disable Graphic processor, you disable also OpenGL, which is need for rotating the screen/drawing in small percentages. Without Graphics processor you can only rotate 90 degrees, which is for drawing useless.


New Member
Hi there

Thanks Lisa for the optional solution.
However, I've tired the way but it's not fit for multiple files editing. You can only do one window/one file while using this way.

For me, there was an other solution may useful. But it requires a laptop with multiple graphic card operating system such as nVidia Optimus.
The solution is simple:
1.Right click on PS, select "run with graphic processor" and direct to "high performing processor" (or nVidia processor or any other options related to this), to force the whole PS work on the nVidia processor.
2.Right click on OBS, do the same thing above.

Then, OBS should be able to capture the whole PS window. If there is still not working or part working, please close all the little window of PS tool and restart the PS.

Well, that's one way for my last computer. I set up a new desktop. It's not work again.

I'll keep looking for solutions on desktop. Hope the way above may help you developers to make the OBS better. :-)


New Member

Just signed up to see if I can get some help with this issue

Reading through, it looks like Lunaomi' might have the answer, which the layered option, however, my OBS settings (Ive just downloaded OBS for my PC recently) does not seem to have all of these options that Lunaomi showed in her images

Lunaomi image

But this is how the options looks on mine



Is there anyway to get up the options that was shown in post?


New Member
I had the same issue and what I did was to initially disable graphics performance. Once window captured started displaying properly, I then went back to preferences to enable graphics performance again. Only drawback with using this method was that I had to do it pretty much every time I started a new recording.

While the workaround doesn't really take too much time, it's still very inconvenient to keep on disabling and enabling graphics performance every time you record a speed/paint or a photo manipulation. Hopefully the devs fix this in future versions of OBS.