Question / Help Cant stream photoshop

Noxychu

New Member
OBS was perfect for me to stream while I draw; but then after a few weeks, it stopped working right.
Photoshop is still displayed, but the open file is no longer visible. (has the little tab that shows its open, but doesn't show the image itself)

It was working great.. then it wasn't.
I've been uninstalling/reinstalling and it still seems broken.
I did not touch or change any settings at all, it just decided to not work when I turned it on one day.

Is there something that could have been turned off/on that I can fix myself? Is this intentional?

Any information would be great.
 

Jack0r

The Helping Squad
Forum Moderator
Re: Photoshop- Was working, then it wasn't? Is this intentio

Try deactivating Aero. For example switch to the basic theme.
I could replicate that the Menus are gone with Aero active. Using Window capture in the latest 018test version.
Using Monitor capture the Menus are working with both Aero on and off.
 

Senekrum

New Member
Greetings.

I decided to try and stream while working in Photoshop, but for some reason OBS does not capture the actual .psd image, only the window and the layers.
To better explain what I mean, I will use the following screenshots as examples:

The document, as it shows when viewed in Photoshop


The Photoshop window, as it shows up in both preview and streaming modes

Notice how it won't even show the guideline (the red, vertical line from the first screenshot; it's a Photoshop feature, not part of the actual image).

For the record, yes, I am using a laptop and I did read the laptops topic in this section. Photoshop is using my Nvidia card and so is OBS. I tried using Compability mode, to no avail.

Also, one other issue I have encountered is that I am unable to stream my desktop. It just shows a black screen. Yes, I did try running it with my Intel card; no change.

So, how do i fix these issues?

Thanks in advance.
 

z0rz

Member
Re: OBS doesn't display images in Photoshop+desktop black sc

It probably has something to do with Window Capture. Do you have Aero turned on? And have you tried Monitor Capture at all? The performance impact of Monitor Capture shouldn't matter with Photoshop.
 

Senekrum

New Member
Re: OBS doesn't display images in Photoshop+desktop black sc

Thanks for the reply.

To answer your questions:
No, I do not have Aero turned on (as far as I know, Windows 8 doesn't even have the theme anymore).
As for Monitor Capture, after poking around a little bit, I managed to get it working (had to change the video adapter setting to my integrated card, rather than simply using the Nvidia control panel to select what GPU to use for OBS).

The problem still persists with Photoshop Window Capturing, though. Any word on that?
 

Kharay

Member
Re: OBS doesn't display images in Photoshop+desktop black sc

Actually, in Windows 8, there is no way to disable Aero, it's just always on. Regarding your problem -- The only thing I can imagine is that in some way or another the actual picture is not actually part of the window being captured; ie -- rendered in some other plane.

Monitor Capture really does seem like the safest bet to me as well; its performance should be sufficient for Photoshop, in Windows 8 anyhow.
 
Re: OBS doesn't display images in Photoshop+desktop black sc

I had the same issue in Windows 7, Monitor capture was the only way to get it all to show correctly.
 

Senekrum

New Member
Re: OBS doesn't display images in Photoshop+desktop black sc

Kharay said:
Actually, in Windows 8, there is no way to disable Aero, it's just always on.
Aero was discontinued and the theme Windows 8 uses is Metro. Yes, there are certain features from the old theme that still accessible, but it is gone as a whole.

But yes, it would seem that Monitor capture is my best bet for the time being. Was just hoping there'd be a way to fix the Window capture issue. Oh well.

Thank you for your answers, everyone.
 

Breakagirl

New Member
Re: OBS doesn't display images in Photoshop+desktop black sc

Hi there. I registred because I found this topic when i encountered the same issue, and found a solution.

When using Window Capture, make sure to activate the option " Capture Layered Windows ". It should work.

Hope this will help some of you.
 

alpinlol

Active Member
just use monitor capture? its not like anyone would actually care about the fps.

you can disable aero if you want a "decent" performance out of monitor capture under win7
 

Aeladya

Member
geniusgfx said:
hi,

i have a problem with streaming photoshop, i tryed streaming in window capture and only this apears

http://prntscr.com/2n1cy7

i tryed disabling hardware acceleration in photoshop and the problem still exist

You have to stream using monitor capture, I asked the same question, unfortunately because Photoshop operates with separate windows or something you have to stream using monitor capture.
 

nagualtonal

New Member
hi! i just found the solution! the trouble wasn't from obs, is from photoshop, you need to deactivate the "use graphic processor" in the performance preferences
 

Jack0r

The Helping Squad
Forum Moderator
I merged the threads, so you dont have to say that three times. While in general I would not want to use Photoshop without said option, you can of course try it. If it works for you thats great. Under Windows 8 I would definitely recommend to use a Monitor capture instead.
 
So this isn't an ideal solution, but monitor capture is not an option for me since I'm using it as a whiteboard and I am broadcasting multiple windows so when I pop back and forth it would disappear. But, I have two potential workarounds.

1. Detached Window+Navigator

This is the way I'm going, although I may reconsider; it's pretty easy though.
  • Set up a new workspace, call it whatever you like. Window > New Workspace
  • Arrange all your tools along one side, as compressed as you can get them and still use them. I have the palette and tools easily available mostly.
  • Detach the window you're working in by just clicking and dragging the tab; it should pop out the window.
    • note: there is a setting somewhere in the preferences that can disable detaching the window, if your window won't pop out, look for that and enable it
  • Enable the 'Navigator' window, undock it, if necessary, and then re-dock it along the bottom.
For me, doing the above leaves about 75% of my screen real estate available.
  • Now, resize the navigator window by clicking and dragging the resize bar as far up as you can get it.
  • Now, you have what is in effect a re-drawn version of your image, it's generally a smaller version of the whole with a big red line around what is visible in your window, but we're using it now to display the entire image in a way that OBS can actually capture it.
  • So, now resize your detached window, making it as big as possible (or whatever size you want it to be), then, use the zoom tool to zoom out so that the entire extent of the image is visible in the window; I had to zoom (if you don't know, BTW, click while you have the zoom tool selected and move left and right to zoom: it's a nice smooth zoom that I just found by accident a couple days ago [I have little experience with Photoshop to this point]).
  • Now you should have the image fully displayed in the Navigator, and the red square will surround the entire image.
Now, set up OBS:
  • Add a Global source (or however you want to add it to the scene), capture the main Photoshop window (not your image's detached window, as that won't display); this should bring up the whole photoshop window, including the Navigators re-draw of your image.
  • Now, you can 'Edit Scene' and reposition/resize/clip the window as usual; I just move it where I can grab the extents, alt-drag each side to be just inside that red box, and then resize it to fit in the window with a right click on the image, then 'Position/Size > Fit To Screen' but of course you can click on the name of the source in the 'Sources:' listbox instead.
Voila! You now have your image in Photoshop without having to do a monitor capture!

2. A Different or Virtual Computer+Remote Desktop

Okay, not an ideal solution; but

  • You can either:
    • Use one of the various tools out there to create a virtual machine, and install Photoshop on it instead of your main box. I like VMware's 'VMware Player' since it should support some hardware graphics acceleration..
    • If you have another computer that's capable enough, just run Photoshop on it instead.
  • Then, run Remote Desktop or VNC or similar to remote into your Photoshop machine and capture it that way. With VMware Workstation, at least, you can even use Unity so the application just appears as an additional window on your main desktop; assuming OBS can capture that, you should be golden.
  • Just putting a couple extra bullets here; this isn't really probably worthy of an entire sub-section but I already arranged things this way.
  • So I figured why not put a couple bullets and not ruin the whole format of everything.
  • This space intentionally left blank.
Hope that helps someone!

And hey, if anyone's interested, you can check out PlayLaughLoveLearn on YouTube/Twitch.tv/DeviantArt, we'll be definitely going through some Photoshop stuff, as well as OBS topics; playing games and such; modding various games; programming; fractals; and whatever else interests me... I'll leave out the links, we're easy to find if you are interested.

Heel veel liefs en beste wensen!

To: You
From: my <3
—Lisa
 
Last edited:

geniusgfx

New Member
Hello everyone, did anybody solve this issue that u cant stream photoshop normaly?

i have windows 8 and cant stream it proprely
 

Jack0r

The Helping Squad
Forum Moderator
Then you can pretty much only try what Lisa suggested above or find a better capture method and add it to OBS.
 

Lunaomi

New Member
Hello, I just made an account to post this. For many artist streamers like myself, monitor capture isn't really the best thing, as it's nice to be able to freely switch between the program to my tabs without people seeing my browser. Now, Lisa's approach, which is very well thought out, is bit overcomplicated, when really, this is an easy fix.
I used nagualtonal's approach and it fixed everything for me, with WAY less steps!
hi! i just found the solution! the trouble wasn't from obs, is from photoshop, you need to deactivate the "use graphic processor" in the performance preferences
Now, on the OBS side of things, you're gonna want to make a new scene and add a source for "Window Capture". If you right click on the source for the window capture, go to properties. Make sure your settings look something like this :



The window should obviously be whatever photoshop file you're working on. Hit "Okay". If you start a preview of the stream, you should see the usual photoshop setup, but no actual file. HERE'S WHERE THE FIXING PART HAPPENS! :D

Next, like how nagualtonal said, the rest is mostly photoshop's problem. I use Photoshop CS6 on Window's 8, but I think it's pretty much a universal fix. When you're in the program, go to the "Edit" tab. Scroll down until you see "Preferences", which should open up a list, and click the one that says "Performance". A window will open up in photoshop, and you'll see something that looks similar to this:



Make sure the "Use Graphics Processor" is UNCHECKED! Hit "Okay", restart your photoshop, and reopen the file you were working on. Congratulations, you should have fixed your issue!



Hopefully this approach was a bit simpler and explained it better. Save a life yo!

(If this didn't help, then I would recommend trying Lisa's approach :P)
 
Top