Question / Help Cannot set "Desktop Audio Device"

American_Gent

New Member
I recently downloaded OBS onto my mac, I spent about 4 hours of my day figuring out how to use this program with help from the internet. But now I'm stuck at this Desktop Audio Device.

From what I've learned so far the Desktop Audio Device is used to record the game audio, so I assumed I could just go and change it from the settings. But I can't, the only option I have when I click on the drop down menu is "Disabled". Theres no options for speakers or anything, its just "Disabled".

If this is an obvious question I'm sorry, I'm new to OBS.
If I could receive a solution to my problem that would be great.
 

Heidi Hornlein

New Member
A follow up question: I downloaded and installed the software but in settings the "Desktop Audio device" is still disabled. How can I resolve this?
Thanks
 

Narcogen

Active Member
Installing those programs doesn't enable the "Desktop Audio Device" setting to work. It creates a different device for you to manually select as an audio source. You need to add the input source you want to the scenes you want; what it is called depends on what software you're using (WavTap, SoundFlower, LoopBack, iShowU, etc).

Basically you'll be selecting the virtual device created by one of the above software packages as the new default output for program audio on the Mac, and then making sure that virtual device is an input source in your scenes.

You'll then need to either use OBS' audio monitoring feature, a monitoring feature in whichever software package you chose, or, failing that, something like the freeware LineIn to send that audio to an actual hardware device so you can hear it while streaming/recording.
 

Heidi Hornlein

New Member
Hi back again. I now learned to set up the Multi-Output device in the Audio Midi set up.
The next step would be to find it in the system preferences, but it is not there. I rebooted the Mac, still not there. What do I need to do to go ahead? Thanks for your advice!
 

Attachments

Narcogen

Active Member
Preferences > Sound > Output

If it doesn't show up there, the multi-output device wasn't created properly.
 

Heidi Hornlein

New Member
well, I don't know what I could have done wrong. It shows up in the Midi set up window, but not in the preferences>audio of my computer, even after rebooting several times.
I simply have no idea how I can resolve the problem to run OBS on my MAc.
 

Narcogen

Active Member
Multi Output Sound.png
Here I've created a multi output device. It includes my built-in output and a USB audio device called Fast Track.

Once I have created and named this device, it should show up as an output device in the Sound control panel shown on the right.
 

Heidi Hornlein

New Member
Thank you again for your help. I will have a go again.
Actually, yesterday the devices I created showed up in system preferences, and today they are gone again. It is crazy. I try to figure out what is going wrong - without actually knowing what I am doing as a non-tech person.
 
Last edited:

Narcogen

Active Member
Afraid I'm not really able to assist further as I don't use iShowU myself. But any properly created multi-output device should display as an option in the MacOS Sound preferences panel. If it doesn't, there's something wrong. I couldn't say if the reason why it doesn't is because of iShowU or not.
 

ScottBinder

New Member
I recently downloaded OBS onto my mac, I spent about 4 hours of my day figuring out how to use this program with help from the internet. But now I'm stuck at this Desktop Audio Device.

From what I've learned so far the Desktop Audio Device is used to record the game audio, so I assumed I could just go and change it from the settings. But I can't, the only option I have when I click on the drop down menu is "Disabled". Theres no options for speakers or anything, its just "Disabled".

If this is an obvious question I'm sorry, I'm new to OBS.
If I could receive a solution to my problem that would be great.
Hey, did you ever manage to solve your issue with the desktop audio being disabled? I am just getting started and am having this same exact issue! I hope you get this and might be up for helping me.
Thank you, Scott
 

Johne154

New Member
Your devices show up under Mic/Auxillary Audio (1..6, etc.). It's a Mac thing. Ignore Desktop Audio and don't let it hang you up.
 

Johne154

New Member
I just created another output device, hoping it would work, but nothing shows up in the preferences panel, same output as in screenshot above while the midi set up panel now looks like that:
Any idea who and what could help me with that?
Set your Master Device: to iShowU Audio Capture
 

Narcogen

Active Member
You can also add them as sources in a scene and leave them all disabled in Settings > Audio.

Just be sure you're adding iShowU as an Output source, and external devices like microphones as Input sources.
 

Johne154

New Member
Thanks for that bit of info, Narcogen!

I think this is specific to Macs and OS X. No matter what I've tried, Desktop Audio and Desktop Audio 2 are always Disabled. But Mic/Auxillary Audio are always available and work just fine to access Audio Devices on Macs. As I check out videos on YouTube, I've noticed all the folks using "Desktop Audio" devices are running OBS under Windows.
 
Last edited:

Billy Gerhard

New Member
I got the whole setup as described above, but the iPhone still isn't outputting when I use it as a Video Capture Device. Any suggestions?
 
Top