Question / Help Black Bars Around Video Capture Resolution Challenge (Canon, CamLink, OBS)

DrewnoMars

New Member
Hi Team!

I have an issue with my Video Capture Device source.
I am using a Canon M50 EOS camera at 16:9 ratio and filming 1080p 30fps.
Using Elgato 4k Cam Link.
In OBS Video setting I have Base/Output resolution at 1920x1080.

I can't get rid of these black bars, any help?

I could have sworn it worked just fine my first couple times. Not sure what I might've accidentally changed.
 

Attachments

  • OBS Video Capture Issue.png
    OBS Video Capture Issue.png
    296 KB · Views: 2,993

DrewnoMars

New Member
I might be a complete idiot on this one, but my info doesn't pull up an option for fill screen. I can change aspect ratio but at 16:9 if still has the box around it.
 
I am having the same issue as well.

I went into Effect Filters and I selected Crop/Pad, and I was able remove the black bars in the popup window, but the black bars are still on the sides on the canvas after I click the close button.

2020-07-03_16-16-56.jpg
 

uncleflip

New Member
I have similar problems with my Canon, using the EOS webcam utility beta. It frequently underscans like that. I am absolutely sure my issue lies in the Canon software, and not OBS. However, it always seems to rear up when I am using OBS to feed Zoom. That's when I have all my camera issues. Soon as I stop feeding Zoom, OBS behaves again.
 

bmurrz

New Member
I had the same issue with my Sony 7rii and the fix was in camera settings, aspect ratio set to 16:9. It had previously been set to 3:5 for photography.
 

Yorre

New Member
I have similar problems with my Canon, using the EOS webcam utility beta. It frequently underscans like that. I am absolutely sure my issue lies in the Canon software, and not OBS. However, it always seems to rear up when I am using OBS to feed Zoom. That's when I have all my camera issues. Soon as I stop feeding Zoom, OBS behaves again.

I had the same problem and I think I figured it out, atleast for me. I noticed that I had the picture mode selected when I turned on the camera. However, this is what causes the problem. To solve the problem, you jave to put the camera in filming mode and not picture mode. This helped for me and I hope this will also work for you.
 
Top