Background Removal - Portrait Segmentation

Background Removal - Portrait Segmentation v0.4.0

Ukis

New Member
Hello!
Is there any option to use that "Background Removal" filter on "Browser" instead of "Video capture device"? To make it possible to work with OBS Ninja? That filter just doesn't appear when I try to add it on "Browser" instead of "Video capture device". :(
Thanks!
 
Hi, I need help with these instructions for Background Removal by Shilkrot. Step by step would be appreciated. I have installed the .so file and everything is there, but a black cam. I was told I was missing a component or part of the installation. It's a native Mac cam that doesn't show up. Thanks so much in advance!
  • Mac OSX: Unzip obs-backgroundremoval-macosx.zip to /Applications/OBS.app/Contents/. e.g. $ unzip -o obs-backgroundremoval-macosx.zip -d /Applications/OBS.app/Contents/
 

pillarsoffranch

New Member
any chance you could make this work with the window capture source? I capture Zoom video and it would be great to remove the zoom window backgrounds on each window.
 
So I tried and I tried and I tried and finally installed this plugin so that the cams load in and can use BR. However, two things: I don't see to know how to add an image for the background. Assuming that it is different than the native Chroma key that came with OBS. Also, it seems that a lot of the plugins having to do with the green screen says, "no properties available". It might be that their is no image that is loaded, but I think it's across the board.

My question is how do I add an image to Background Removal? Is it done the same way that the Chroma key does it by putting the image above the video capture device or done some other way? Thanks!
 
So I tried and I tried and I tried and finally installed this plugin so that the cams load in and can use BR. However, two things: I don't see to know how to add an image for the background. Assuming that it is different than the native Chroma key that came with OBS. Also, it seems that a lot of the plugins having to do with the green screen says, "no properties available". It might be that their is no image that is loaded, but I think it's across the board.

My question is how do I add an image to Background Removal? Is it done the same way that the Chroma key does it by putting the image above the video capture device or done some other way? Thanks!
Well, I'm back to square two! I have everything up on screen, but my internal mac cam. I tried something and it didn't work! I thought I was on the right track. I could see myself and all the properties listed, but it wasn't working properly and didn't know how to add an image. I thought now that it seemed properly installed a new copy of OBS would do the trick! It didn't erase all the other filters and add ons, but erased Br. I tried to recreate how I had installed it to make it work as little as it did, but must have been lucky when I dragged the right file to the right place, because I don't remember what I did. I guess a fresh start might help? Any ideas would be appreciated. Mac OS High Sierra and the current OBS and Background Removal. Thanks!
 
O.k. Well, I'm back on track! I successfully installed this software and I took notes that I plan to share with people in case they have the same issues I had. So happy and proud! However, I don't know how to use it yet, which I posted earlier. Tomorrow I will get a fresh start and see if I can find a tutorial on how to add background!
 
Hi Roy Shilkrot, Success....for a little while! I was able to play with it for about 20 min. and I choose to shut it down. I really spent a lot of time through trial and error figuring out how to install it though not having a programming background, but well worth it! I truly appreciate your efforts and I read somewhere that you are working three jobs so your time is limited! However, I truly hope that you will be able to develop it more. I believe it has the potential for it to become stock in future OBS releases after the bugs are fixed! All the best to you!
 

Empirekicking

New Member
Works very well, And so far not had one single crash however I can't use it.

On a single system and even though I have a good gaming system, my CPU is way too high just to have this addon. Using 60% to 78% of my CPU usage, WAY TO HIGH
 
Ok. So I am able to use this plugin long enough to try things. Pretty cool! However, whenever I choose Robust Matting it crashes. Any ideas? Installed improperly, too much CPU or something? CPU is at 65%. Thanks in advance.
 

dingdong1

New Member
Any chance we'll see Segmentation model support in the Mac version? I'm using macOS 10.15.7 and I don't see any the "Segmentation model" drop down. Whatever model it is using on macOS creates a very "busy" rapidly moving moving mask edge and is basically unusable because it is so annoying.
 

orangedeal

New Member
When enabled, the CPU load (9900k @ 5 GHz) rises from 2-4% to almost 40%. Inference device CPU and GPU - no difference. With an increase in X Frame, the load drops, but the speed of work also drops. How did Discord did something similar without a performance hit? Some kind of proprietary algorithm?
 
Just wanted to say that I was finally able to try "Robust Video Matting" and it hasn't crashed. I'm not really doing a whole lot with it other than mousing around, but I can see the possibilities. However, the crashing is inevitable. It happens intermittently. Thanks and I'm looking forward to more updates!
 
It works! Woohoo! The only thing I did differently was threw out the installer and the folder of your plugin from the contents menu. I kept it in there so that I could reinstall it if needed after many attempts at installing it. I have had OBS open for about a half hour now and it did not crash! However, choosing "Robust Video Matting makes it crash. Thanks Mr. Roy Shilkrot! I can't wait until the shimmering around the edges are fixed!
 
It works! Woohoo! The only thing I did differently was threw out the installer and the folder of your plugin from the contents menu. I kept it in there so that I could reinstall it if needed after many attempts at installing it. I have had OBS open for about a half hour now and it did not crash! However, choosing "Robust Video Matting makes it crash. Thanks Mr. Roy Shilkrot! I can't wait until the shimmering around the edges are fixed!
The next day....I did have Robust Video Mattung working in one of my many past attempts, but don't remember what I did to get it. I think I reinstalled it or something. I just retraced my steps and it's there, but not working. I thought I had installed something different and the new one worked when it did work, but I could be wrong. If anyone knows how to do this please let me know. I got everything else working fine. It doesn't seem to be crashing like it used to. Thanks!
 
I'm sorry to repeat myself, but I have been having more consistent results with BR and it's been fun! It appears that if I still choose Robust Video Matting it will crash OBS and then the 2nd or 3rd time it will work! Not sure what the reason is. Perhaps conflicts with other software? I'm not a programmer so I don't know. Just an FYI: I maxed out my i7 iMac with 64 gb. on OS High Sierra so I don't think it's CPU power although I do have many apps open all the time. Right now I have about 20 gb. active according to my activity monitor.

Also, does anybody know how to get that glow around the outline of your body to go away. Well, it's sometimes more, but I don't know the terminology. I would like to know if it's software related or maybe lighting related, so I can see what I can do to fix it. I am currently in a small space and this is a great tool for this when it is perfected. Yes, Mr. Shilkrot I realize their other commercial options as I thought you had mentioned somewhere else that can be used like Snap Camera or Zoom, but I am looking forward to a BR native to OBS and am grateful you have taken this on. Not being a programmer it appears that this is one of the hardest things to accomplish and you have taken it on. I will patiently wait for your updates.
 

VictorS

New Member
I am running into the issue of when I apply the background remover my image goes black. Remove the background removal filter and I can see myself again. Not sure what is happening. Cannot find an answer anywhere. Using iMac (24-inch, M1, 2021) macOS Monterey Version 12.2. Privacy setting are set to allow OBS do screen recording, use camera etc. Get black screen on both iMac native camera and external Logitech webcam. Any ideas on what I missing?
 
Mr. Shilkrot, I think their is a possibility it might be software conflicts with other apps, but I'm not a programmer. I formatted a new drive to OS 10.15 Catalina to be able to use StreamFX, so I started a new. It was just BR, SFX., Scene Collection Manager and now Scene Notes so far. Everything is working as it should. No matter what I try to experiment with it hasn't crashed. Even when I choose Robust Video Matting it doesn't crash like it always did before. Pretty neat! It's really been last night for a few hours and first thing I am playing with today for a few hours while multitasking, so who knows? On another note..I would love to see some instruction by the RVM people for any ideas to get rid of that stuff that outlines part of your body that I don't know what to call because I'm not a videographer. It might be lighting or a few filter adjustments that I don't have a clue about THANK YOU for this plugin! Can't wait for the updates!
 
Top