Audio fine in OBS but missing in recordings

NACTV

New Member
Suddenly, after working fine for years, the latest videos that I recorded in OBS have no sound despite sounding fine in OBS. All of the audio inputs are set to "Monitor and Output" and I hear them perfectly fine in my headphones in OBS. However, when I play the recorded videos back in VLC, there is no audible sound. The audio bitrate on these files is shown to be 2 kbps. I did not change any settings between the last time it worked properly and the first time it didn't.

For more context, we use the obs-asio plugin to capture audio from a USB mixer (Behringer U-Phoria UMC404HD). This has worked well for us in OBS 27.2.4, which we currently use. I tried to upgrade to version 28.0.1, only to find that the obs-asio plugin was not compatible with it, so I downgraded back to 27.2.4. After reinstalling 27.2.4, I recorded multiple videos to mp4 and there were no problems with the audio.

Then, despite not changing any settings, I recorded another video and, this time, there was no sound even though it sounded fine in OBS. I recorded a few more audio tests, and none of them had any sound either. I checked to make sure all of our audio sources had output enabled, which they did. I closed and re-opened OBS, then I rebooted the computer, and I made sure Windows was up to date. Then, I uninstalled and reinstalled OBS 27.2.4 and obs-asio 3.1.0. Still nothing. I even installed the CoreAudio AAC encoder to see if a different encoder would help. The audio bitrate then went up to 188 kbps, but still no sound.

Is there anything I could try that I haven't yet? I attached the log files from the last time it worked properly and the first time it didn't. Does anything stand out?

OBS Studio 27.2.4 (64-bit)
Windows 10 Pro 21H2
Intel Core i7-8700, 16 GB RAM
GPU: AMD Radeon RX 550
 

Attachments

  • 2022-09-12 12-16-22.txt
    44.8 KB · Views: 4
  • 2022-09-15 10-00-40.txt
    32.7 KB · Views: 0

NACTV

New Member
Update: The problem has been solved!

It seems that the ASIO input sources had been corrupted somehow. After I deleted them and created new ones, everything is back to normal.
 
Top