Audio dropouts each 7-8 minute

rockbottom

Active Member
It's still in play on the last log, the issues started when you introduced it to the audio chain. I think we're done here.

2 weeks ago I've got my hands on external USB audio card - Behringer UMC202HD and since then I'm trying to find a solution to record dj sessions
 

rockbottom

Active Member
I would check Audacity again to see if it's also still recording gaps. If it's still recording them too, I think you can TS easier with it than OBS. I suspect if you're able to get a clean recording with Audacity, you will with OBS too.
 

rockbottom

Active Member
Here's some info you may find interesting as I had basically the same issue with my old PC. The audio gaps in my recordings were being caused by the audio routing I was using. Originally I thought it was my soundcard but after I re-routed the soundcards audio through my GPU & started capturing the HDMI audio output from it, I was getting gaps. With the new PC, I made life simple & just use the on-board audio.

 

rockbottom

Active Member
Here's something else known to cause problems, disable "Use Device Timing". The is the only device I found that it is enabled. Behringer.

00:41:40.667: [win-wasapi: 'Desktop Audio'] update settings:
00:41:40.667: device id: default
00:41:40.667: use device timing: 1
00:41:40.670: [Loaded global audio device]: 'Desktop Audio'
 

rockbottom

Active Member
I don't use global audio sources, but I think you should select the actual device instead of just leaving it as "Default"

From my log, the device is selected. (HDMI Output)

15:08:06.466: [win-wasapi: 'Audio Output Capture'] update settings:
15:08:06.466: device id: {0.0.0.00000000}.{eefebedc-307c-47e4-bb41-c2507d571805}
15:08:06.466: use device timing: 1
 

rockbottom

Active Member
Before installing any plugins, make sure they compatible with the version of OBS you are using. This may or may not work correctly.

00:41:40.398: Failed to load 'en-US' text for module: 'obs-async-audio-filter.dll'
00:41:40.398: [obs-async-audio-filter] plugin loaded (version 0.2.1)

Limitation​

  • Not all binaries are tested.
    • Windows: 0.2.1 was tested with OBS 27.2.4 and 28.1.1.
    • macOS: Version 0.2.1 was tested on Intel mac.
    • Ubuntu: Version 0.2.1 was tested on Ubuntu 22.04.
 

alex.g

New Member
Here's some info you may find interesting as I had basically the same issue with my old PC. The audio gaps in my recordings were being caused by the audio routing I was using. Originally I thought it was my soundcard but after I re-routed the soundcards audio through my GPU & started capturing the HDMI audio output from it, I was getting gaps. With the new PC, I made life simple & just use the on-board audio.


Well, I've tried that a month ago before getting the behringer, however the audio quality was not good at all, and there was a ground loop. Will try with the settings u mentioned and see what happens.
 

alex.g

New Member
Here's another test with these changes:

disabled all devices in OBS audio settings - adding an audio source to each scene is far more reliable probably.
Global audio devices: Mic/Aux Audio - Behringer
deleted async filter to avoid issues
Device Timestamps disabled
Made a new blank profile without any scenes and recorded 17 minutes.

These are the results:

1:05 - drop
4:32 - soft/half drop
6:56 - drop
8:33 - drop
12:20 - drop

Now I will perform a few tests with Audacity by using low profile settings to see what happens there.
 

Attachments

  • 2023-08-13 13-36-47.txt
    46.4 KB · Views: 9

alex.g

New Member
It turns out I've managed to record something with Audacity without drop-outs which is 18 min.
I've just changed these settings in Audacity:
Rec level at 98%
sample rate 16bit (every other device is set to 24bit)
Host Windows WASAPI
Quality settings Medium/Dither Sharper
Unchecked - Auto-scroll if head unpinned in Preferences/Tracks
Buffer settings: 100 ms

 

rockbottom

Active Member
Audacity should be able to record at all bit-rates (16, 24, & 32) without issue. If it doesn't, there's something wrong in the audio chain.
 

rockbottom

Active Member
Works great
I had an error in the device manager for "Other" hardware showing up as Behringer UMC202HD with the little yellow exclamation plaquard icon, but the device was recognized and was working fine, that additional Behringer error in the device manager just... bothered me so damn much...

This fixed it

Read! the .pdf file it helps

...or just make sure you "Disconnect the UMC202HD" and "Uninstall" the old version which was the 5.51 in my case

Dont plug in device yet.... First install new driver set ...then plug in your device.
 

rockbottom

Active Member
Driver is stale, follow the directions above & update it. If the device remains restricted to 16-bit, it's defective.
 
Top