Terrible resolution and pink-tinted screen. What to do?


New Member
Hello, i recently moved to Linux and i have lots of problems getting OBS to work. First, the resolution was terrible. Now i get pink-tinted output and basically, everything goes wrong.
My specs (Incase there are problems with it):
OS: Arch Linux
CPU: AMD Ryzen 5 1500X
GPU: AMD Radeon RX550 4GB
Resolution: 1080p (I also record in 1080p)
I usually just record my web browser and my desktop, not games and other heavy stuff.
PS: I use both KDE and XFCE, and only X11.
Logs: https://obsproject.com/logs/xPIqYOk1U-1DKfcU


  • Screenshot_2021-11-06_15-32-34.png
    225.5 KB · Views: 48


New Member
Hi! i'm having the same problems. Here's what i found so far:

- I recorded a ton of videos for my channel, using the same OBS settings (using va-api encoder with my integrated amd graphics "renoir"). They all looked pretty good.
- Did a break for some time, when i got back... it's all messed up, blurry, flashing colors etc..

So what happened?

Either Mesa or libva-mesa-driver (which is needed for va-api hardware accel.) got updated, and broke everything.
How do i know this? Because i've been jumping from distro to distro, from pure arch itself, to some debian based distros.

- All fast paced distros suffer from this issue right now: Manjaro, Arch, Ubuntu 21.10, Pop!_OS 21.04 and 20.04.
- Kernel didn't matter, 5.10 LTS or the current one 5.14.

So, what about old distros?
Ubuntu 20.04 LTS works with no issues (even tried the new 5.15 kernel, and recorded fine), and i can bet linuxmint works too.
It's not about OBS, because i tried the old repo version in ubuntu 20.04, all the way up to the recent one.
I also tried flapak version, doesn't matter.

I just can't figure out if it's an issue with mesa itself, or with libva-mesa-driver.
For the record, i also tried to compile the latest mesa from AUR, which took a ton of time to do, and in the end i got the same blurry awful recordings.

If you disable hardware acceleration, it works, but whats the point? The fans go crazy as soon as i start recording.
If anyone found anything more, let me know

logs: https://obsproject.com/logs/1k4JpZwe1uC02AiG