Question / Help Stream Keeps Skipping Frames on stream and in real time pls help

WhalezYT

New Member
So i like to stream and i sadly cant do it bc everything keeps lagging , i have a decent pc do stream tho , i just dont know whats going on someone please help me , heres my log file , if its not enough or shows nothing ill post a new one.
 

Attachments

  • 2019-05-31 16-04-28.txt
    186.9 KB · Views: 34

Kyiolol

New Member
Try using ur GPU as Encoder, not ur CPU. Had the same problem with skipped frames and fixxed it with that.
 

Narcogen

Active Member
OK, a few things:

16:04:33.016: - scene 'Scene':
16:04:33.016: - source: 'Display Capture' (monitor_capture)
16:04:33.016: - source: 'Game Capture' (game_capture)
16:04:33.016: - source: 'twitch donatins/follwes etc' (browser_source)
16:04:33.016: - source: 'Game Capture 1' (game_capture)
16:04:33.016: - source: 'Game Capture 2' (game_capture)


16:04:33.016: - source: 'Overwatch' (game_capture)
16:04:33.016: - source: 'GCSGO ' (game_capture)
16:04:33.016: - source: 'H1Z1' (game_capture)
16:04:33.016: - source: 'Window Capture' (window_capture)
16:04:33.016: - source: 'Text (FreeType 2)' (text_ft2_source)
16:04:33.016: - source: 'Image 1' (image_source)
16:04:33.016: - source: 'Game Capture 6' (game_capture)
16:04:33.016: - source: 'Game Capture 7' (game_capture)
16:04:33.016: - source: 'Game Capture 12' (game_capture)
16:04:33.016: - source: 'Display Capture 1' (monitor_capture)
16:04:33.016: - source: 'Game Capture 8' (game_capture)
16:04:33.016: - source: 'Game Capture 11' (game_capture)


Don't mix display and game capture sources in the same scene; don't put multiple game captures in the same scene, use one and reconfigure it on a per-game basis; if you want to set up multiple game captures in advance, do them in separate scenes, or better, separate scene collections (that's what they are for). Mixing multiple captures and capture methods in a single scene like this is a recipe for bad performance, and hiding them does not make the performance hit go away.

16:04:28.810: Windows Version: 10.0 Build 17134 (revision: 765; 64-bit)

Your Windows is out of date. In this version, Game Mode is on and cannot be turned off except by editing the registry. This mode can degrade OBS performance. You should read the page linked at the bottom of the post for information on updating and turning off this feature.

16:13:11.990: Output 'simple_stream': Number of lagged frames due to rendering lag/stalls: 4578 (25.7%)
16:57:48.666: Output 'simple_stream': Number of lagged frames due to rendering lag/stalls: 14231 (16.4%)
17:01:29.814: Output 'simple_stream': Number of lagged frames due to rendering lag/stalls: 232 (3.5%)



Rendering lag caused by GPU overload. Probably caused in your case by the multiple game/display captures in multiple scenes, and game mode being on, but if resolving those doesn't make it go away, check here:

https://obsproject.com/wiki/GPU-overload-issues

16:13:11.990: Output 'simple_stream': Number of dropped frames due to insufficient bandwidth/connection stalls: 1836 (10.6%)
16:57:48.666: Output 'simple_stream': Number of dropped frames due to insufficient bandwidth/connection stalls: 2742 (3.2%)


Your network connection is unable to keep up with your selected bitrate (6000).

16:13:11.992: Video stopped, number of skipped frames due to encoding lag: 5762/19014 (30.3%)
16:57:48.667: Video stopped, number of skipped frames due to encoding lag: 17220/87555 (19.7%)
17:01:29.816: Video stopped, number of skipped frames due to encoding lag: 338/7724 (4.4%)


You are overloading your encoder, which in your case is your CPU on the veryfast preset. You need to either change to a faster preset, reduce your framerate, or reduce your frame size.

Alternatively you could switch to the NVENC encoder in your 1060.
 

WhalezYT

New Member
OK, a few things:

16:04:33.016: - scene 'Scene':
16:04:33.016: - source: 'Display Capture' (monitor_capture)
16:04:33.016: - source: 'Game Capture' (game_capture)
16:04:33.016: - source: 'twitch donatins/follwes etc' (browser_source)
16:04:33.016: - source: 'Game Capture 1' (game_capture)
16:04:33.016: - source: 'Game Capture 2' (game_capture)


16:04:33.016: - source: 'Overwatch' (game_capture)
16:04:33.016: - source: 'GCSGO ' (game_capture)
16:04:33.016: - source: 'H1Z1' (game_capture)
16:04:33.016: - source: 'Window Capture' (window_capture)
16:04:33.016: - source: 'Text (FreeType 2)' (text_ft2_source)
16:04:33.016: - source: 'Image 1' (image_source)
16:04:33.016: - source: 'Game Capture 6' (game_capture)
16:04:33.016: - source: 'Game Capture 7' (game_capture)
16:04:33.016: - source: 'Game Capture 12' (game_capture)
16:04:33.016: - source: 'Display Capture 1' (monitor_capture)
16:04:33.016: - source: 'Game Capture 8' (game_capture)
16:04:33.016: - source: 'Game Capture 11' (game_capture)


Don't mix display and game capture sources in the same scene; don't put multiple game captures in the same scene, use one and reconfigure it on a per-game basis; if you want to set up multiple game captures in advance, do them in separate scenes, or better, separate scene collections (that's what they are for). Mixing multiple captures and capture methods in a single scene like this is a recipe for bad performance, and hiding them does not make the performance hit go away.

16:04:28.810: Windows Version: 10.0 Build 17134 (revision: 765; 64-bit)

Your Windows is out of date. In this version, Game Mode is on and cannot be turned off except by editing the registry. This mode can degrade OBS performance. You should read the page linked at the bottom of the post for information on updating and turning off this feature.

16:13:11.990: Output 'simple_stream': Number of lagged frames due to rendering lag/stalls: 4578 (25.7%)
16:57:48.666: Output 'simple_stream': Number of lagged frames due to rendering lag/stalls: 14231 (16.4%)
17:01:29.814: Output 'simple_stream': Number of lagged frames due to rendering lag/stalls: 232 (3.5%)



Rendering lag caused by GPU overload. Probably caused in your case by the multiple game/display captures in multiple scenes, and game mode being on, but if resolving those doesn't make it go away, check here:

https://obsproject.com/wiki/GPU-overload-issues

16:13:11.990: Output 'simple_stream': Number of dropped frames due to insufficient bandwidth/connection stalls: 1836 (10.6%)
16:57:48.666: Output 'simple_stream': Number of dropped frames due to insufficient bandwidth/connection stalls: 2742 (3.2%)


Your network connection is unable to keep up with your selected bitrate (6000).

16:13:11.992: Video stopped, number of skipped frames due to encoding lag: 5762/19014 (30.3%)
16:57:48.667: Video stopped, number of skipped frames due to encoding lag: 17220/87555 (19.7%)
17:01:29.816: Video stopped, number of skipped frames due to encoding lag: 338/7724 (4.4%)


You are overloading your encoder, which in your case is your CPU on the veryfast preset. You need to either change to a faster preset, reduce your framerate, or reduce your frame size.

Alternatively you could switch to the NVENC encoder in your 1060.

Thanks man helped alot, but now my games run a little laggy when i play on stream, anyways of fixing that? (but on the stream they look fine)
 

Narcogen

Active Member
If you had Game Mode on before and the game was running fine but OBS was not, then turning off game mode has stopped the game from monopolizing your GPU, but that doesn't stop OBS from overloading it.

Reduce frame size, lower frame rate, cap in-game framerate until both the game and OBS run smoothly.
 
Top