Something about Windows 11 Version 22H2 seems to break OBS Game Capture with SWTOR. Just FYI.


New Member
Not sure what or why, unfortunately. Hopefully someone with more technical knowledge will eventually figure out what has changed between 21H2 and 22H2 somewhere down the line. Right now I'm not necessarily looking for a fix, as rolling back has solved my issue. I'm mostly just posting as a heads-up. Unfortunately I'm not sure I can really provide any kind of meaningful logs for this, since I've already rolled back.

What I can tell you is that I had SWTOR successfully being seen and recorded with Game Capture in OBS (Version 28.0.3) while using Windows 11 Version 21H2.

I updated to Version 22H2 this morning, and Game Capture stopped working correctly. Just showed a black screen with the SWTOR cursor.

At this point I tried pretty much every fix you'll come across when googling the issue. None of them resolved it. I'm on a desktop computer with one GPU, though to be sure I selected the same option for OBS and SWTOR anyway. I'm running OBS with admin privileges, I tried multiple compatibility modes, confirming both OBS and my computer are 64bit, etc etc. Display and Window Capture both work fine, although Window Capture tends to lag. Display Capture seems smooth as butter and could work, but it was just the principle that was bothering me. Why did it work, and then not work?

Anyway, rolled back to Version 21H2 and now Game Capture successfully works again. So there seems to be something about the 22H2 update that is messing up with OBS and SWTOR when trying to use Game Capture as your source.

For the record, other games worked just fine with Game Capture as a source on 22H2, so I can't necessarily say it's all Windows' fault. Although I do find it odd that it worked fine on one version of Windows 11, but not the other. I did also experience 3 total lockups just today on 22H2 (one in SWTOR, two in another game) that required me to hard reset my computer. Unfortunately I can't pin this directly on the Windows update, as this has occasionally happened before although definitely not this frequently.

TL;DR if you use SWTOR and OBS with Game Capture as a source, be aware that you might run into issues on the latest Windows 11 update.