Skype audio delay

Discussion in 'Questions and Help' started by AyyVeeBee, Dec 31, 2013.

  1. AyyVeeBee Member

    So I am new to OBS and to streaming in general. My problem is I am streaming with an elgato using my xbox one, but for voice chat we are using skype and I have it set up where my microphone audio device is my Astro A40, and the desktop audio device is my Astro A40s. They are plugged into my computer so I can talk on skype and here my friend through them. The problem is that the voice is ahead of the gameplay so I am wondering is there a way I can delay just the skype audio and my microphone audio? Hope that makes sense haha.
  2. Jim

    Jim Developer

    USB 2.0 devices are delayed. If you're on a desktop, I wish you could have been somehow warned of this beforehand so you could buy an internal card or USB 3.0 device instead, which have no delay, but what's done is done, and if you're on a laptop with only USB 2.0 ports, then you couldn't have bought anything else anyway.

    Here's what you're going to have to do if you want to sync the device to your desktop:

    In Advanced settings:
    Set "scene buffering time" to 2000. This will allow you to set large negative audio offsets.
    Set global audio time offset to 1500.

    In the elgato's source properties:
    Set Audio time offset to -1500

    That should fix the issue. If you need to adjust the value further, just know that the offsets must match, for example, 1400 and -1400 if that works better.
  3. AyyVeeBee Member

    Thanks, I will try that and see if it works!

    EDIT: Works perfectly just how you told me to set it. Skype audio syncs up perfectly now, thanks again!
  4. VitoRaff New Member

    Hello, I'm sorry for posting on a old thread but I'm having the exact same problem as the topic creator did. So I just wanted to follow up on this. As mentioned my problem is the exact same but I'm using a HDPVR2, but also I'm using a camera (just for me) during my double commentary.

    Thanks in advance for any assistance.
  5. particlepants Member

    this looks okay for the most part but the problem is the audio is now not in sync with the game, if you could set a negative delay on the "use buffering" instead of "audiosync offset" that would be better, I don't know if this is possible but it would be cool to be able to do this in an update or something

Share This Page