Question / Help Quicksync and GPU encoding super laggy

SBMjackmo04

New Member
1. I have an AMD rx 580 graphics card, and it records very laggy videos even at 480 p. I can use relive perfectly fine, but I need the OBS audio settings and stream overlays and such. Why is relive so much smoother than OBS and not cause as much of a performance drop? Are there solutions to make it like relive?

2. My quicksync recordings are perfectly fine even at the quality preset. However, the streams are extremely laggy even when I limit the in game frame rate. I have good enough internet to stream and watch 8000 bitrate, so it’s not a WiFi issue (I think). I have an i5 8400. I’m pretty sure that quicksync is powerful enough stream 720 p since I can easily use it to record 1080p60. Quick sync only lags in games that I have higher FPS in such as over watch and Fortnite, but more graphically demanding games such as BFV and Subnautica work perfectly fine.

I really want to use OBS because relive has audio stuttering all the time.
 

SBMjackmo04

New Member
I just tested streaming with quicksync while locking the in-game fps to 30 and I get the same results.
Here is a log to a recent stream that I tried the stream I used to test is the first part of the log file. You can see that I lost 0.1% of my fps due to rendering lag and 0.1% due to encoding lag, but the stream gets super laggy every time I build or edit anything. I set my bitarte down to 2500. I streamed in 720p and 480p yesterday and the same things happened. I just recorded with quicksync at 17000 bitrate 1080p60 and there was no lag in the video. (you can watch the saved stream on twitch for another 2 weeks here: https://www.twitch.tv/videos/434050523 - The laggy stream)
 

Attachments

  • 2019-06-03 14-21-01.txt
    28.5 KB · Views: 45

Narcogen

Active Member
14:21:01.703: Windows Version: 10.0 Build 17134 (revision: 765; 64-bit)

Windows is out of date and Game Mode is on by default and cannot be disabled except by updating or editing the registry. More information is available at the page at the bottom of this post.

14:32:10.514: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 3 (0.1%)
14:32:10.514: ==== Recording Stop ================================================
14:32:10.514: Video stopped, number of skipped frames due to encoding lag: 26/2909 (0.9%)


Small amounts of rendering and encoding lag indicate you're just at the edge of what your hardware is capable of. Switching to 720p60 or 1080p30 would likely resolve these issues, if updating and turning off Game Mode alone does not.

14:39:15.500: [rtmp stream: 'adv_stream'] Interface: Realtek RTL8811AU Wireless LAN 802.11ac USB 2.0 Network Adapter (802.11, 157 mbps)

Wireless is really not recommended for reliable, high quality, 1080p60 streaming.

Suggest also using the Auto-Configuration Wizard in the Tools menu if you're looking for a baseline from which to start adjusting settings for your machine.
 
Top