Problem with Apple VT H264 Hardware Encoder


New Member
Imac (2020 i9 amd 5700xt) figured id try Hardware Encoding because it would make sense to use less cpu if im gaming on my mac. (i know i know) It actually worked very well and used extremely little cpu compared to x264 encoding, until i looked at the result. The file looks great, but it takes a while to play in anything I use to play videos (quicktime, vlc). Like it plays fine until i skip ahead, then i have to wait like 30 seconds for it to load. On top of that, Final Cut won't even re encode the video. It just freezes. Reminds me of a corrupt video file I made by accident once while combining mp4s. All my tests lead me to believe its hardware encoding causing this. Anyone know why its causing this? Would love to use hardware encoding if possible.

log file


New Member
Yeah same thing happening to me. I’m using MBP 16” i9. The thing I noticed is that Apple VT Hardware Encoder only works for Streaming not for recording. I’ve used Apple VT Hardware Encoder for streaming to YouTube at 1080p60 @ 12000Kbps and it worked exceptionally well. CPU was basically untouched by the processing. My Streamlabs consumed around 80-90% of my CPU resources.

Now lets move on to Recording. I’ve had no success with VT Hardware Encoder at all. Keep on getting that error message saying please check the stream and recording settings whatsoever.

But I could actually record using VT Software Encoder which is weird. But the result was trash. The recorded video was choppy as hell. As if I’m recording with Intel Celeron.

So in the end I figured that the only way to record was by using the Software x264. It stresses out my CPU big time though. Streamlabs consumed around 200-250% most of the time when I set my bitrate to 12000Kbps for 1080p60 recording.