Question / Help Possible Render Lag?

El_Nieto_PR

New Member
I just recently built a new PC. I went with the AMD 3950x because I heard there's nothing this CPU can't do. My main goal is to stream and game from the same PC. At the beginning, my stream were fine; I was able to stream in 720p/60fps no problem. But, recently, I've noticed that the streams is not running at true 60fps. I don't know why. I took my OBS settings from a youtube video. Everything is stock, nothing is overclocke. I've attached Log Files in hope that one of you could translate for me? I read around that the GPU could possibly be the culprit for the lag, but I made sure the stream is encoded by the CPU and not the GPU, or does that not really matter? I have a GTX 1080 (not Ti). Thank you for your time and help in advance.
 

Attachments

  • 2020-02-02 21-01-33.txt
    17.2 KB · Views: 296

koala

Active Member
I went with the AMD 3950x because I heard there's nothing this CPU can't do.
Well, you know, it cannot bring out the trash. For all other tasks, your assumption is valid.

With your issue, you have lagged frames due to rendering lag, and this is due to GPU overload. Limit the resource use of your game by restricting the game to 60 fps/activating vsync. And for a start, don't use the slow preset of x264, this is wasting CPU cycles with no visible improvement over medium. Use the medium preset.
Also, disable Game DVR (background recording) in Windows gaming settings.
And what kind of drive is your V:? In case this is a network drive (NAS) or a USB drive, don't record to it. Use a built in SSD or hard drive.
 

El_Nieto_PR

New Member
Well, you know, it cannot bring out the trash. For all other tasks, your assumption is valid.

With your issue, you have lagged frames due to rendering lag, and this is due to GPU overload. Limit the resource use of your game by restricting the game to 60 fps/activating vsync. And for a start, don't use the slow preset of x264, this is wasting CPU cycles with no visible improvement over medium. Use the medium preset.
Also, disable Game DVR (background recording) in Windows gaming settings.
And what kind of drive is your V:? In case this is a network drive (NAS) or a USB drive, don't record to it. Use a built in SSD or hard drive.
I did everything you said, and, it worked! The stream is back to 60fps (Output 'adv_stream': Number of lagged frames due to rendering lag/stalls: 10 (0.0%))! However, I guess I have another issue. I have a 144Hz monitor and, well, I enjoy playing multiplayer games close to that refresh rate; I'd be ok with 60fps, if I only played single-player games. I do feel like multiplayer gaming is much smoother at 144Hz. So, my next question would be: do I have to upgrade my graphics card in order to be able to play at 144Hz and stream at 60fps at the same time?
To answer your last question, the V: drive is an M.2 drive. Thank you so much for your help!
 

FerretBomb

Active Member
It'd probably be best to run the monitor at 120hz instead of 144 if possible; this would allow an even divider down to 60fps for streaming. OBS would discard every other frame, making for a stable frame-timing, whereas with 144 it'd skip frames erratically, leading to stuttery-looking video.

Any GPU can be overloaded if the game is run un-capped; even a 2080Ti or Titan RTX would run into the issue you were having with GPU over-load. You can try running OBS as Administrator, too. There was a workaround added in OBS Studio 24.0.3 which allows OBS to 'claim' GPU time before the game, which can really help a lot in reducing or eliminating rendering lag with many setups. It WILL result in *slightly* lower in-game performance, but only by the tiny amount OBS needs for its back-end tasks (color conversion, scaling, compositing, etc).
 

El_Nieto_PR

New Member
It'd probably be best to run the monitor at 120hz instead of 144 if possible; this would allow an even divider down to 60fps for streaming. OBS would discard every other frame, making for a stable frame-timing, whereas with 144 it'd skip frames erratically, leading to stuttery-looking video.

Any GPU can be overloaded if the game is run un-capped; even a 2080Ti or Titan RTX would run into the issue you were having with GPU over-load. You can try running OBS as Administrator, too. There was a workaround added in OBS Studio 24.0.3 which allows OBS to 'claim' GPU time before the game, which can really help a lot in reducing or eliminating rendering lag with many setups. It WILL result in *slightly* lower in-game performance, but only by the tiny amount OBS needs for its back-end tasks (color conversion, scaling, compositing, etc).
So, if I run OBS as admin it will "claim" GPU time before the game? Setting the fps to 120Hz made the stream smoother, but not 100% smooth. I appreciate your feedback, btw!
 

FerretBomb

Active Member
Yep, Jim got together with Microsoft to hammer out a workaround where OBS gets 'first dibs' on GPU time. It doesn't always work, but in a lot of cases it does.
100% smooth, you'll need to run at 60fps. It's still dropping every other frame to produce a 60fps stream, and some applications will use different interpolation techniques that can look odd when that happens. It's like temporal downscaling, instead of resolution downscaling... there's going to be some amount of quality loss.

Also, if you run more than one monitor and they're not ALL at the same refresh rate, do be aware that there's a long-standing multi-refresh rate problem with Windows; it doesn't handle 3D acceleration across multiple monitors with disparate refresh rates well. There's a fix coming in Win10 v2004 later this year. You can work around this by keeping OBS on the same monitor as your game (inconvenient, yes) or right-clicking in the Preview area and choosing "Disable Preview". At the very least to test and see if the stream/recording smooths out.
 

El_Nieto_PR

New Member
Thank you so much for your quick and helpful replies, guys! I open OBS as admin and I was able to stream at 60fps, while gaming at 120fps! I think this might be the "sweetspot," for now! You guys have successfully helped me solve my problem! Many thanks, friends!
 
Top