Resource icon

Pan Zoom Rotate 1.3

That's very strange that you can't select the file, while other .lua files are selectable. Since it has the same file extension as the other Lua filter files, the OBS scripts file loader should allow you to at least select it and try to load it. Did you remove the previous instance from the scripts list using the "-" button? Actually, you shouldn't need to do that if you overwrote the previous filter-PZR.lua file in the folder with this new version. It should recompile the new shader when OBS is opened.
So I reinstalled it and it shows up in scripts like it did at the beginning and it is back to "no properties available." We're back to square one unfortunately. Thanks so much for your willingness to help me.
 
Hi Khaver, I've just discovered something that may help me with your script. I am not a programmer, so please bare with me. I had learned through many many attempts to install background remover and eventually figured out was where to put the .so file in the plugins folder (front end tools), but I just noticed their is an OBS lua.so and some other .so files in the Mac OS part of OBS. Is this the reason why the other .lua scripts work, but PZR doesn't? Or, is this in the wrong place? Or, is this so that OBS will recognize all the lua scripts that might get installed? Thanks.
 
Last edited:
I have some strange behavior going on that I'm sure is something I did to make happen, but what? In my virtual Win 10 PZR works fine on the sources I set it up before a few days ago, but now it says "no properties" and it crashes with a new source. The same OBS! Not sure how to fix it without erasing and reinstalling the whole thing. If it's just the PZR I may lose all uses of it. So sorry Khaver, You have been so nice in trying to help me on the Mac side I don't want to cause you problems.
 
Hi Khaver, I just wanted to let you know I did some playing around with PZR on my Win 10 virtual machine and it rocks! The VR Win 10 is not my main machine, so hopefully you will get it to work on a Mac someday, Thanks.
 

djsekops

New Member
Hi, I tried this too on a M1 Mac, no joy unfortunately. When the filename for the script was updated it had a suffix lua 2, and the number 2 makes it unselectable in OBS. Once that's removed OBS can load the LUA script but unfortunately the problem is still evident, the script has no properties within the filter or Scripts dialog.
 

Suslik V

Active Member
The shader program from the script is not compatible with OpenGL renderer of OBS. So it wouldn't work on mac or linux.
The compile errors with this shader visible even in Windows when the OBS is forced to use OpenGL renderer ("--allow-opengl" cmdline key, and advanced settings).

This and many many other errors may rise:
Code:
11:25:19.015: Error compiling shader:
11:25:19.015: Fragment shader failed to compile with the following errors:
11:25:19.015: ERROR: 0:40: error(#132) Syntax error: "float2x2" parse error
 
I don't know Mr. Khaver. I am back to square one. I was having problems installing your newer scripts so I went into my guest account and did the same thing that I did to get PZR going. I downloaded a fresh copy of OBS and planned on trying to install the newer scripts, but the mistake I made was when it asked me to keep both OBS's I said no just replace. I started off with a new OBS and had to reinstall some software which worked great. Now the scripts I got working and loved like PZR and Chromatic Aberration can't even be selected as they did when I started. I did start off with them. Hm...OBS must leave remnants no matter what you decide to do to download a new one. It surprises me. I realize it is entirely my fault, but I will keep at it. In a few days I will take more time to back things up and erase like scenes and try again....However, this past time I did remember to start a new profile and delete the scripts and effects to start a new. I will keep you posted.
 
I don't know Mr. Khaver. I am back to square one. I was having problems installing your newer scripts so I went into my guest account and did the same thing that I did to get PZR going. I downloaded a fresh copy of OBS and planned on trying to install the newer scripts, but the mistake I made was when it asked me to keep both OBS's I said no just replace. I started off with a new OBS and had to reinstall some software which worked great. Now the scripts I got working and loved like PZR and Chromatic Aberration can't even be selected as they did when I started. I did start off with them. Hm...OBS must leave remnants no matter what you decide to do to download a new one. It surprises me. I realize it is entirely my fault, but I will keep at it. In a few days I will take more time to back things up and erase like scenes and try again....However, this past time I did remember to start a new profile and delete the scripts and effects to start a new. I will keep you posted.

Success! I created a new guest login on my Mac. I went the whole nine yards this time as opposed to just logging into a guest account that couldn't be saved. I named it and gave it a password. I downloaded and installed the most current OBS. I clicked keep both instead of replace and as many of your scripts that I could think of and they all worked! Some more notes for other possible Mac users with this issue. When I downloaded the new OBS I saw the previous ones in the new log in when I was in the applications folder. As I mentioned I clicked "keep both. What was puzzling and a good thing is when I went back to my main Mac account all the new scripts and all my old software stayed intact. Not sure why. I thought the new login would allow a fresh unaltered copy of OBS and had nothing to do with my usual account, which allowed me to install things without any other software getting in the way. Oh! iI did try to create a new profile and scenes within my main Mac account and wasn't able to install your scripts for some reason. I'm having a ball with them and I truly appreciate all the work you have put into them. Again, sorry for the confusion or whatever inconvenience I may have caused you. Your SCRIPTS ROCK! THANK YOU!
 
Mr. Khaver, You outdid yourself on these updates! I downloaded and installed them all, but my favorite is Pan, Zoom and Rotate! I love how colorful the new descriptions are for all of them to. After trying it out on my Virtual Win 10 I wanted them for the Mac and finally I installed them properly and it worked!!! I had learned a lot about installing scripts and software and how they might affect each other to. Also, a shout out to you for your patience with me and making a Mac test .lua to help me, but then realized that it wasn't necessary! You are a good man! Having lots of fun! Thanks.
 

Milarvoz

New Member
Sorry I may be just dumb, but after I installed the script how do I use it. I can't find a way to make the sliders pop up :(
 

khaver

Member
Select a source you want to add the filter to, right click and select Filters. Pan-Zoom-Rotate should be in the list.
 
Top