"Overread 8" error causes sound to cut out, stream lag/freeze.

YouLousyKids

New Member
Hi. I need to fix this because it has been going on for the last five days of my stream, requiring me to stop streaming, restart OBS (or even reboot the laptop and then restart) and then resume my stream. I've had to do this an average of seven times in the two-hour streams for the last week. Logs for the last three days are attached.

My streams can be seen here: https://www.youtube.com/@YouLousyKids/streams (Days 100-105 specifically). Yes, I had streamed for 100 days pretty much without incident.

The error in my stream doesn't always have the same effect. The most common:
  • A blast of static in my headphones that lasts until I kill OBS. (Sometimes, it is there when I restart OBS and I have to reboot the computer.)
  • My sound cuts out and I can't hear the game or myself. (However, other PC sounds still play in my headset. I can play my media player to test it out.) When this happens, my viewers inform me that it is laggy or frozen.
  • I don't notice anything wrong at all but my viewers tell me in chat that they can't hear anything.
Possible causes (not sure WHY, but they're the only changes to OBS I made around that time):
  1. I added some more videos in a new scene to play for my viewers for my 100th show.
  2. I added a mask to my web cam so that I appear in a circle.
  3. I added a counter via a browser page that pulls in a url from Streamlabs.
Attempting to debug the problems, I killed the scene with the videos before the end of day 100's stream, and when that didn't help I killed the scene with the counter as well two days ago. Neither solved the issue. I can't believe it would be the mask layer on my webcam. Could it be?

Viewing my logs, every single one marks the time where the incident happens with "Error: Overread 8".

My setup:

Operating System
Windows 11 Home 64-bit
CPU
Intel Processor
RAM
16.0GB
Motherboard
Dell Inc. 0YD3W1 (U3E1)
Graphics
LG ULTRAWIDE (2560x1080@60Hz)
Intel Iris Xe Graphics (Dell)
4095MB NVIDIA GeForce RTX 3050 Ti Laptop GPU (Dell) 50 °C
SLI Disabled
Storage
476GB PC801 NVMe SK hynix 512GB (Unknown (SSD))
3726GB TOSHIBA EXTERNAL_USB USB Device (USB (SATA) )
Optical Drives
MATSHITA BD-MLT UJ230AS USB Device
Audio
Intel Smart Sound Technology for USB Audio
Microphone/Camera/Headset jack/Ringlight:
MOVO plugged into my USB splitter
Capture card:
Elgato HD60X plugged directly into my computer

I hope I've provided enough information. We've been suffering through this through my anniversary show and the holiday weekend, and I'm at a loss for how to resolve it. I have watched videos on YouTube about how to resolve errors and unfortunately it seems like my settings are fine, if not overcompensatingly low. (It'll tell me to change a setting from Absurdly High to just Very High and I'm on Medium.)
 

Attachments

  • 2023-09-02 17-05-49.txt
    46.1 KB · Views: 13
  • 2023-09-02 17-36-00.txt
    46.4 KB · Views: 9
  • 2023-09-03 00-11-43.txt
    42 KB · Views: 9
  • 2023-09-03 15-56-34.txt
    46.2 KB · Views: 10
  • 2023-09-03 16-12-22.txt
    45.4 KB · Views: 9
  • 2023-09-03 16-41-38.txt
    45.3 KB · Views: 11
  • 2023-09-03 17-44-11.txt
    44.7 KB · Views: 9
  • 2023-09-03 17-58-43.txt
    45.6 KB · Views: 10
  • 2023-09-03 18-15-48.txt
    41.9 KB · Views: 9
  • 2023-09-04 15-57-47.txt
    35.7 KB · Views: 10

YouLousyKids

New Member
I don't know if no one is replying because I posted an overwhelming amount of info, or if it's just that no one has an answer.

An update: One of of the occasions with an error, my microphone/camera/ringlight went out and so did my stream deck! I thought maybe it was something to do with errors being caused by my USB splitter, like maybe a kind of short or something. So today I used a new USB splitter. And...nope, that wasn't it.

I really hope someone out there has some idea that can help me. I hate how I have to reload my OBS 10 times during a 2-hour stream. It's bad for my fans and for my show. Please, does anyone have even a clue as to what I could try?

Do I have to uninstall and reinstall OBS? Do I have to throw out everything in my setup and start over? (I'd be wiping out a LOT of work on memes and streamdeck, etc.)
 

YouLousyKids

New Member
Nobody ever replied, but through continual debugging efforts I finally tried a different webcam/mic and had an uninterrupted stream. I have no idea what was actually happening, or how to resolve it, but it would seem the microphone was causing the errors somehow.
 
Top