Question / Help Only Audio Track 1 Records Sound for .MKV?

Scoobymenace

New Member
Hey so I'm wanting to get OBS setup so that it records audio tracks separately for Game Sound (Desktop), Mic / Aux and VoIP (Discord), although despite having everything setup correctly, only Track 1 ends up in the final recording? What's worse is, I can see each of the individual volume meters working as intended in the Audio Mixer window.

I made sure that each of the inputs were working as intended by assigning each audio source to Audio Track 1 separately then recording only that one audio source on Track 1 and making sure it was captured in the final recording. This shows it can capture each audio source no worries. The split second I try put Game on Track 1, Mic on Track 2 and VoIP on Track 3 it only picks up whatever is on Track 1.

I've attached screenshots of my configuration of OBS and Voicemeeter in case I'm overlooking something. Would really appreciate any help! This is giving me nightmares :(

Log: https://obsproject.com/logs/BZYCOqlLZ_Op5_6a
 

Attachments

  • OBS-1.JPG
    OBS-1.JPG
    27.1 KB · Views: 698
  • OBS-2.JPG
    OBS-2.JPG
    39.3 KB · Views: 753
  • OBS-3.JPG
    OBS-3.JPG
    75.9 KB · Views: 714
  • OBS-4.JPG
    OBS-4.JPG
    69.9 KB · Views: 639
  • SYS-1.JPG
    SYS-1.JPG
    39.5 KB · Views: 562
  • SYS-2.JPG
    SYS-2.JPG
    40.2 KB · Views: 544
  • VM-1.JPG
    VM-1.JPG
    129 KB · Views: 539

koala

Active Member
According to the log, you're writing 3 audio tracks to your video file. Looks good.
How did you verify the number and contents of audio tracks in your recording? Keep in mind media players never mix multiple audio tracks. You have to switch between them and you are able to listen to one at a time only.

To make use of a multi track audio recording, you have to load the recording into some postprocessing software, mix and edit the separate tracks to a mixed track and replace the 3 separate audio tracks with the new mixed track.
 

Scoobymenace

New Member
Did you set multi-track output in settings - output?

Yes I did, see attached screenshot :)

According to the log, you're writing 3 audio tracks to your video file. Looks good.
How did you verify the number and contents of audio tracks in your recording? Keep in mind media players never mix multiple audio tracks. You have to switch between them and you are able to listen to one at a time only.

To make use of a multi track audio recording, you have to load the recording into some postprocessing software, mix and edit the separate tracks to a mixed track and replace the 3 separate audio tracks with the new mixed track.

You just solved my issue! I forgot that media players such as VLC can only play 1 audio track at a time and was using that to verify it was working as a quick way to do so - cant believe that tripped me up! Thank you for pointing that out :)

On a side note, looks like in 2 previous recordings I forgot to check the Audio Track 3 box in Settings > Output so Im just talking to myself...whoops... Im new to this so learning as I go.

Thanks to both of you for the help!
 

Attachments

  • OBS-5.JPG
    OBS-5.JPG
    69.6 KB · Views: 645
Top