OBSTally - Tally-Lights using RaspberryPI GPIOs


New Member
Hello Deniz,
thanks a lot for your great script.
I tried to install your program at a Raspberry Pi Zero with Raspbian Buster with desktop and recommended software.

First I had a Websocket problem. Solved by installing the websocket manuell.

Then I had a Python problem:
Running at boot
Traceback (most recent call last):
File "/home/pi/OBSTally/obstally.py", line 41, in <module>
scene2 = root[4].text
File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 266, in _getitem_
return self._children[index]
IndexError: list index out of range

Solved by deleting python.

The last failure is another problem:
python obstally.py
Traceback (most recent call last):
File "obstally.py", line 143, in <module>
File "/home/pi/.local/lib/python2.7/site-packages/obswebsocket/core.py", line 73, in connect
raise exceptions.ConnectionFailure(str(e))
obswebsocket.exceptions.ConnectionFailure: [Errno 111] Connection refused

Do you have any ideas, to fix it?