OBS Voicemeeter

OBS Voicemeeter 1.0.0

I3ordo

Member
Hey @Andersama

,

Update:
It works like it should however, after closing and reopenning OBS, i see that it stops working until i start to modify the source by changing the "output"to "input" or vice versa.

It looks Like a "device in ise" error that occurs silently.

Older post:
i am digging your plugin right now, but i wonder, How do you have an audio mixer like that?

edit: found it, unlock UI through here and drag as you like:
1546728244474.png
 
Last edited:
Well, as I'm new and do not have privileges to open a new topic I have to start somewhere. Maybe one of you can help. I want to sweeten up the sound of my mic but the closest plug in available to do that is the compression and it's not getting what I want. Is there anyway to add an EQ vst from my Adobe Audition vst folder into OBS so I can use it there.
If you can help or point me to help it is sorely appreciated.
 

Andersama

Member
Well, as I'm new and do not have privileges to open a new topic I have to start somewhere. Maybe one of you can help. I want to sweeten up the sound of my mic but the closest plug in available to do that is the compression and it's not getting what I want. Is there anyway to add an EQ vst from my Adobe Audition vst folder into OBS so I can use it there.
If you can help or point me to help it is sorely appreciated.
This isn't exactly the place to get help, you'd have been better off in the discord. This is a resource thread, namely for people w/ issues w/ the plugin I've written.

But I do know what you're after, read through this: https://github.com/obsproject/obs-studio/wiki/Filters-Guide#vst-plugin
 

I3ordo

Member
I have replaced and using this plugin for most of the sources.

But there are times where i dont hear anything and see an empty "properties" section. Sometimesthe plugin cant communicate with plugin.

Is it possible to add a "re-initialize" function and a hotkey entry for this plugin?
 

Andersama

Member
See the comment I made under the existing review, Voicemeeter has to be started before you open up OBS. I already have written in using the api given a way for the plugin to try to start Voicemeeter. My experience so far was that particular function in the distributed .dll (at the time) gracefully fails. Feel free to let them know that you'd appreciate it if they could implement / distribute that part of the api.
 

Prexsply

New Member
Thank you for this plugin. IMHO the best audio plugin for obs used with voicemeeter virtual mixer. It just made things easier.
 

ryantheleach

New Member
@Andersama Clarification:

1551143410474.png


Voicemeeter lets you name the strips, to make it a lot easier to remember what is what. Additionally the channels are unlabelled in OBS.

1551143504570.png


If it's available through the API, what would be nice is to bring those names across, elsewise being able to name them within OBS would be fine. As a beginner it's pretty easy to get them confused otherwise. Additionally, there are multiple channels with the same name, e.g. I can't tell left from center. or which channels should map to what in OBS.

I don't even know where to begin with 'stages'. I've only used the most basic features of VoiceMeeter thus far, and have only been using the evaluation version, until I've got the cash to commit to streaming.
 

Andersama

Member
Ok, I sort've figured this is what you were talking about, better labeling of the actual layout. The labels you add yourself aren't available through the remote api, though I think I can set them.

You'll probably want to familiarize yourself w/ the system settings / options section. might make more sense of what you're looking at.
 

GridMonkey

New Member
Just an FYI, had this installed this with OBS 22.0.2, was going to test it out, as i use voicemeeter potato for everything, very used to it/understand it well. I played with your plugin 2 or 3 days ago, did some test audio and recordings but never set it up completely. Removed all the sources until i was ready to rework all my audio. Didn't get that far. Just installed OBS 23.0 and as soon as i opened OBS my audio went buggy. Plug in installed but no sources setup. I uninstalled the plugin and opened OBS and audio was fine. I'm not blaming anyone or any software. Just letting you know that there may be something a bit funky going on.
 

GridMonkey

New Member
I can send you log files, no problem. The issue seems to be with voicemeeter and my audio running outside OBS. The video i was watching is what stuttered, sounded like samplerate desync to me. i was not using any of your plugin sources, though they may have been configured. I did discover that 23 did do some things to one of my capture cards so that may also be the culprit. but here is my last log of 22.0.2, the log of 23 with glitches, and the log of 23 w/o your plugin. I have not yet put the plugin back in after i sorted the black magic capture device issue. Also none of these have been streams yet because testing still. I run a complicated setup so dont be afraid to message me and i can help sort some things.
 

Attachments

I3ordo

Member
For some reason, i cant get it obs v23 to pick up mic from B1 or B2, or any device from B1 or b2 as output.

It used to do the same behaviour before but all i had to do was to reconfigure the source , switch from output mode to input vice versa and it was working. now it does not.

This is a great plugin for anyone that wants have a voicemeeter oreitend workflow and i would like to see it back up and running again hopefully asap.

update: restartedOBS and it is working again.

Feature request:
A hotkey for pluginr reinitialization please. that would work wonders. I will try to come with a log next time it happens. cheers
 

Andersama

Member
@GridMonkey nothing stands out as being odd unfortunately. I'd double check everything, that all your devices match sample rates etc, but obviously you've switched between 22 and 23 and presumably that was the only obvious change, so I'm not sure what's the issue atm.

W/ how unstable it appears for you (and the marginal benefit it provides) I can't exactly recommend using it, but if you figure anything out, please let me know.
 

GridMonkey

New Member
@Andersama Im not terribly concerned about it, i have voicemeeter setup very solidly, and with the VAC and such, the audio and obs together work great. As i said it was voicemeeter that was having the issue i feel, and not your plugin, it might be the API getting overloaded ( the three ASIO mains are all 8 channel two of the three ASIO outputs are also 8 channel, and its just too much for it.) The post was more for you to know that there might be an issue sometimes with certain setups. I dont know enough about the coding side of things to get the info from voicemeeter or i could give you that as well. I still think its a great plugin and i might use it on a slightly less crazy vm setup
 

Andersama

Member
See I'm not inclined to think that b/c it works without issue on my end. Though one dev just reported that it crashes when multiple instances are opened, so I'll be trying to fix that.
 

I3ordo

Member
Feature Request:
a "plugin re-intialize" feature via hotkey or something so that the plugin re-checks with VM's outputs.

Current problem.

When i launch OBS, i get distorted audio from OBS's audio monitor which sends the monitor's audio to VM's AUX input.
To get rid of the distorted sound, i had to(within VM) change preferred sampling rate , either from 44100 to 48 or vice versa. It had some kind of "restart audio engine" effect on VM. After modifying the sampling rate of VM, the sound recovered. But recently, when ever i can the sampling rate from VM, the OBS plugin stops receiving sound from VM.

So i still would like to request a plugin re-intialize feature via hotkey or something so that the plugin re-checks with VM's outputs.

to replicate the error.

Go to VM and change preferred sampling rate to 48k or 44k.
You will notice that the plugin stops working completely.
1553324546187.png

ps: the reason i have to modify the pref. sampling rate is because of the distorted sound problem i get from launching OBS everytime and fix it by modifying it.
 
Last edited:

ryantheleach

New Member
I'm also encountering distorted audio with all devices set to 44.1khz. (I wish I could use 48, but that caused similar issues (without OBS) due to my wireless headphones (assuming they don't have enough bandwidth always, but I'm just coming up with BS theories, no idea to real reason, happened before VoiceMeeter as well))

The distorted audio only happens when OBS hooks correctly, and can take some time to manifest.

If OBS launches before VoiceMeeter, then no distortion happens, which in my mind, rules out potential CPU throttling issues, but could still be possible if VM audio processing plugin uses significant CPU usage.

This thread on VM forums seems to provide similar context, and similar findings. https://forum.vb-audio.com/viewtopic.php?f=8&t=477&sid=f3ab27a076b062674badfc60dc6047bd
 
Last edited:

ryantheleach

New Member
@I3ordo Your VM settings show that you have several devices with different sample rates, it's Highly Recommended by most voicemeeter guides that I've read that you use the same sample rates across all your devices, or have sufficient buffers (But I've not worked out how to customize buffer length).

If you are limited to a lower sampling rate by one of your devices, I'd recommend setting them all to either that sampling rate, or if very low, a multiple of the lower sampling rate.

e.g. those camera's, if you care about their audio quality, you should probably try to use 48k across the board, rather then 44.1k if you have the choice (assuming you can't boost them past 16, I don't imagine they have good audio anyway being cameras)
 
Last edited:
Top