Question / Help OBS Streaming Problem


New Member
Hello everyone!
I've been livestreaming on my YouTube channel for about a year in a half. Recently, I have started having a very irritating problem crop up during streams, and even though I have tried everything, nothing fixes it, and I can't figure out what is causing it.

What happens is I streaming like normal, and all of a sudden, the bitrate that the stream is uploading at starts jumping all over the place, even though I am using Constant Bitrate, or CBR. For example, if I am streaming at a bitrate of 12000 KBPS and have an audio bitrate of 320 KBPS, then it normally streams at a bitrate of 12250 to 12400 bitrate. Everything is good, right? But out of nowhere, without warning, it will go way up to above 20000+ KBPS, which is when frame drops start happening because my internet upload speed caps out at 21 MBPS.

To make matters worse, this isn't consistent. Sometimes I can stream for 45 minutes before it happens, sometimes 15. Sometimes it happens once and goes away, sometimes it happens again 5 minutes later.

There also isn't a way to fix it. I've tried lowering the bitrate, down to 10000, 9000, and then 6000. It still happens. I've tried stopping the stream, restarting OBS, and then starting the stream again. Sometimes the problem will be gone for awhile, sometimes it'll keep going, and then fix itself again. I've done speedtests to make sure it wasn't a network problem either.

I've seriously had it up to here with this ruining my livestreams. Her is a list of all the things I tried to fix it:

-Lowered the bitrate down, even all the way to 6000 KBPS (on a 21 MBPS upload connection)
-Done speed tests to make sure it wasn't a network error.
-Restarted my modem and router
-Reinstalled OBS Studio
-Reinstalled Windows, all my software, and OBS Studio
-Enabled new networking code in OBS Studio
-Tried streaming on the YouTube Backup ingest server instead of the primary one.

Again, no idea what the problem is, or why the bitrate would jump around so much when it is supposed to be constant.
Here is a screenshot of my streaming output settings:

Any ideas on how to fix this? This has made me so miserable and frustrated I've almost decided to quit streaming. I've also thought about experimenting with XSplit if it is just something as simple as an OBS Studio bug, but I assumed more people would have this problem if it was a bug.


Edit: Forgot to post an OBS Studio log, here is one:


New Member
This also happen to me if i use NVENC i switched back to x264 problem was solved never happen again
I'll do a test stream and see if that helps.

Only problem is that if I have to use 720p, I'll only be able to stream at 720p and even then it won't look great.


New Member
This also happen to me if i use NVENC i switched back to x264 problem was solved never happen again
It turns out that that fixed the problem. I don't know why as it shouldn't be that way. I'm going to do what I can to figure it out.

For reference, when did you experience this problem yourself, and GPU do you have?


Yours NVIDIA GeForce GTX 1060 3GB
My GPU NVIDIA GeForce GTX 1060 6GB
Driver Version 419.17 now updated to 431.60
nothing changed
Last edited: