Question / Help OBS Performance Issues With NDI Output Enabled


New Member
Hello! I recently purchased a gaming laptop to use for work and on the go. I've decided to start recording and streaming using OBS. I've used OBS and the NDI plugin many times before with my desktop and a second PC with no issues. Ever since I've tried to use NDI with my new laptop to stream to my gaming desktop I get a big performance hit in some games, especially CS:GO (the main game I'm trying to stream). I can stream and record 1080p 60FPS no issue directly from the laptop, but as soon as I enable NDI my FPS in game drops dramatically, often going below 60, where normally it is around 120-150. I would just use OBS locally on the laptop but storage space is limited as I only have a 256Gb SSD until I can upgrade in the future, hence why I try to record on the desktop. My setup is: game from laptop and stream through NDI over a 1GB LAN connection to the desktop. I've tried lowering game settings and recording settings with little to no help in alleviating the issue.

To recap my issue is that turning on the NDI output on my laptop will nearly half my FPS in game compared to recording locally. Any help to get this situated is greatly appreciated. I hope this all makes sense, I tried to explain the issue and setup the best I can.

Specs: (Laptop)
  • Intel Core I7-8750H
  • 16GB DDR4 Ram
  • NVIDIA RTX 2070 Max-Q
  • 144Hz 1080p Screen
  • 256Gb NVMe SSD
  • Windows 10 Pro
Specs: (Desktop)
  • Intel Core I7-3790K OC to 4.5Ghz
  • 32GB DDR3 Ram
  • AMD RX 470 4Gb
  • 60Hz 1080p Screen
  • 500Gb SSD (Boot)
  • 2TB Seagate HDD (Recordings)
  • Windows 10 Pro



Forum Admin
07:03:05.936: [rtmp-services plugin] Remote update of URL "" failed: schannel: failed to receive handshake, SSL/TLS connection failed
07:03:06.795: AutoUpdateThread::run: Failed to fetch manifest file: schannel: failed to receive handshake, SSL/TLS connection failed

Looks like you have more issues than just NDI. Disable or uninstall any bundled firewalls / antivirus / etc. If your gaming laptop uses a Killer chip (unfortunately most do), reset it to the default Windows driver.