Question / Help Obs overloaded encoder while streaming

#1
well, ive been trying to stream, but the problem is that no matter what i do, obs keeps saying "Encoder overloaded", ive tried to reduce some settings but it didnt work, it is not my computer, basically because its a 6 cores and 12 threads cpu, with a 6gb gtx 1060 playing with an upload speed of 8 mb, how can i solve this problem?
 

Attachments

#2
What seems to be going on is that you have problems on your network in negotiating what speed to use. In your log, there are times when you connect at 100Mbps, and at other times at 1000Mbps.

This can mean that you have a network configuration problem. You need to check all Ethernet cables to make sure they are of the same category (i.e. Cat 6 1000Mbps). Also check cable modem to make sure its LAN ports support 1000Mbps as well as all hubs, routers, and switches in your home that they are 1000Mbps.

You shoud not mix 100Mbps networking hardware/cables with 1000Mbps hardware/cables.

22:45:48.070: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmp://live-mia.twitch.tv/app...
22:45:48.178: [rtmp stream: 'adv_stream'] Interface: Realtek PCIe GbE Family Controller (ethernet, 100 mbps)


23:04:57.149: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmp://live-mia.twitch.tv/app...
23:04:57.205: [rtmp stream: 'adv_stream'] Interface: Realtek PCIe GbE Family Controller (ethernet, 1000 mbps)
 
#4
What seems to be going on is that you have problems on your network in negotiating what speed to use. In your log, there are times when you connect at 100Mbps, and at other times at 1000Mbps.

This can mean that you have a network configuration problem. You need to check all Ethernet cables to make sure they are of the same category (i.e. Cat 6 1000Mbps). Also check cable modem to make sure its LAN ports support 1000Mbps as well as all hubs, routers, and switches in your home that they are 1000Mbps.

You shoud not mix 100Mbps networking hardware/cables with 1000Mbps hardware/cables.

22:45:48.070: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmp://live-mia.twitch.tv/app...
22:45:48.178: [rtmp stream: 'adv_stream'] Interface: Realtek PCIe GbE Family Controller (ethernet, 100 mbps)


23:04:57.149: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmp://live-mia.twitch.tv/app...
23:04:57.205: [rtmp stream: 'adv_stream'] Interface: Realtek PCIe GbE Family Controller (ethernet, 1000 mbps)
thanks for the answer, i already have my pc connected to the modem with a ethernet cat 6 cable, the problem is still there, i have checked my internet connection it is a constant 8MB upload speed, so i dont know what to do
 
#5
All my stream connections run at 1.0Gbps at full duplex. There is no switching from 100Mbps from one session to 1000Mbps in another session like what is happening on your computer. OBS Studio determines speed of the network adapter by querying Windows at the time of RTMP connection and shows this message:

23:10:59.983: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmp://live-mia.twitch.tv/app...
23:11:00.007: [rtmp stream: 'adv_stream'] Interface: Realtek PCIe GbE Family Controller (ethernet, 1000 mbps)
23:11:00.956: [rtmp stream: 'adv_stream'] Connection to rtmp://live-mia.twitch.tv/app successful


Since your ethernet adapter is changing oddly from two different speeds, something is not right in your network. If you go to your network driver adapter and look at its speed and duplex setting, it is likely set to Auto Negotiation by default. This means the adapter is negotiating with other devices on the network at an agreed upon capability. If you set it to a fixed value (like 1.0Gpbs Full duplex), you are telling every device it communicates with that this is the only speed and duplex it will communicate with.

With Auto negotiation on, it is either your network adapter, the other device on the network that is running at a slower 100Mbps, or a middleman like a router/switch running at a slower speed. It could also be that there are devices on the networking producing so much network bandwidth that it can only operate at 100Mbps.

1575345471517.png


- Check to see if there are other devices on your local area network that are using the network. This includes all desktops, laptops, Wifi devices, smartphones. Everything.
- Make sure that when you stream, nobody else in the house is using the network. If dad is watching Netflix while you are streaming, well, that is not a good time to stream. If your brother is downloading files off the Internet, that isn't good either.
- Check the Ethernet cable for damage and see if:
  • RJ-45 plastic jacks are damaged
  • RJ-45 ports on the motherboard or cable modem/router/switches are damaged
  • The cable itself has been damaged
  • Cable is lying near strong magnetic interference like flourescent lights, microwave or speakers
When in doubt, just go buy another Cat 6 cable.

Lastly, go to your motherboard manufacturer website and update with the current network drivers. Don't use the Realtek driver from the Realtek website. Only use the motherboard manufacturer's implementation.
2:45:48.178: [rtmp stream: 'adv_stream'] Interface: Realtek PCIe GbE Family Controller (ethernet, 100 mbps)
 
Top