OBS on mac - can't turn desktop audio off

Mr_Schwarz

New Member
Hi all,

i seem to have the opposite problem to what most people are looking for regarding desktop audio. I have desktop audio, I don't want it and I don't know how to turn it off. See screen recording here (3min): https://youtu.be/_RpjhF2_bGU
Logfile attached.

System:
macOS Catalina v.10.15.5, MacBook Pro (16-inch, 2019), OBS 25.0.8, Motu M4 w XLR microphone.

Here is what happens:
1. In Settings - Audio - Devices - Mic/Auxiliary Audio: M4. Everything is disabled, no other audio source. I did have ishowu audio capture installed before but removed it (i think completely). When I tab on my mic I get movement in the meter in the mixer area.
2. I start a system audio source, such as youtube or spotify on my mac and the meter will show that it is receiving input. If I hit record and then play back the recording after, I will indeed hear the audio from the youtube vid I was playing or from Spotify. I can speak in the mic and my voice will be recorded as well, but mixed together with the audio from my mac.
2.1. also, if I play a youtube video and then stop it, the meter will continue to move. If I record again, it will sound like the last millisecond of sound from the yt video being played in a loop (much like a fast moving broken record).

What I tried:
* I unistalled all drivers I had for recording system audio: ishowu audio capture and ultraschall hub
* I restarted my mac multible times (shut down and boot up as well as restarts)
* I deleted OBS (including the files in /Users/USER/Library/Application Support/obs-studio) and reinstalled OBS
* in Settings - Audio - Devices - Mic/Auxiliary Audio I selected "MacBook Pro Microphone and turned the speakers off

Any advice on how to fix it?

Thanks
Chris
 

Attachments

Mr_Schwarz

New Member
Update:
i don't have the issue, when using a headset that is not connected through the motu m4. For example with my bluetooth headphones which also have a mic, only my voice is being recorded and no desktop audio.

I found a hint here from 02.2019 (https://obsproject.com/forum/threads/need-help.100199/post-393441) saying that OBS does not "deal with multichannel devices natively", and to look into using Loopback for "arbitrary virtual interfaces".

I am gonna research in that direction. If you have any input, please share.

Regards
Chris
 

Mr_Schwarz

New Member
Update 2:
I am not able to edit my previous posts, so here my last post.

I think I found out what the problem is - kinda. The principle issue is, that when one uses a multi input audio interface (like a Motu m4) unlike a DAW, OBS does not detect the different inputs and outputs of that audio interface. Instead it records all incoming signals from the device into one channel or track. In my head this behaviour doesn't really explain why my desktop audio was also being recorded but I think it has something to do with it - somehow.

How do I know (or believe to know)? I googled "OBS", "digital interface" and "problem" and found quite a discussion about OBS not having the ability to differentiate between the multiple inputs from an audio interface. Find the links below.

One solution that board member Narcogen proposes is using an additional piece of software named Loopback by the company Rogue Amoeba Software, Inc. It allows to create virtual audio devices which will be recognised by OBS als individual audio sources.

I solved my problem by creating two such virtual audio devices in Loopback. One I called "mic" and the other "system audio". I assigned Channel 1 of my M4, which is my XLR Mic input, to the two output channels of that virtual audio device. In the second virtual audio device, called "system audio", I assigned "ishowu audio capture" to the two output channels of that specific device. (I obviously reinstalled the ishowu audio capture driver again). I also added a monitor in Loopback that feeds the System Audio back in to my m4, so I can hear system audio while I am recording.
I do my own monitoring through the Motu itself.

Then in the OBS settings I was able to assign the both virtual audio devices to their individual mic/aux.

In the macOS audio settings you need to put audio output to "ishowu audio capture".

Works like a charm.

Loopback is not free, at the time of this writing it will cost you 118$. You can download it for free and test it out. After some time (20min) the sound will become really bad or so the trial warning says.

I still don't know, what caused my copy of OBS to record system audio and my mic to the same track and why I couldn't turn system audio off, but now I can and that's enough for me.

Hope this helps somebody.


Regards
Chris

Links
 

Mr_Schwarz

New Member
Just curious. If you mute your mic/aux does it still record The desktop audio?
you mean if I mute the mic/aux in the mixer of OBS? No, if i muted that, then no audio is being recorded - not the system sound nor my mic. In that setup I would have selected my audio interface as input source in the OBS audio settings.
 
Last edited:

Tangential

Member
you mean if I mute the mic/aux in the mixer of OBS? No, if i muted that, then no audio is being recorded - not the system sound nor my mic. In that setup I would have selected my audio interface as input source in the OBS audio settings.
I wondered if maybe your mic was picking up the syrem audio playing out your speakers
 

Mr_Schwarz

New Member
I wondered if maybe your mic was picking up the syrem audio playing out your speakers
I considered this possibility. I use closed headphones (Bayerdynamic DT770 pro), so even if the Mic was able to pick the sound up, it should not have picked up at the high volume at which it did. I verified by disconnecting my XLR mic by pulling the XLR cable out of my M4 while I kept it connected to the macbook via the usb connection. I obviously did not hear myself speak anymore, however I could still here die audio from the youtube video playing in Firefox.

Though I found a way for me to make the setup work, I am still curious as to what causes that behaviour.
 
Top