Bug Report OBS + NVENC + 337.50 Driver

Status
Not open for further replies.

isamu

New Member
I got it to work again by replacing the "nvEncodeAPI.dll" found in "C:\Windows\SysWOW64" with one of the previous versions of the dll file. You will need to boot in to Safe Mode to replace the file, also be sure to back up the dll file your replacing.

Please Note: For advance users only. Also note this is only a workaround.

Note 2: Previous versions of the dll can be found in "C:\Windows\System32\DriverStore\FileRepository" in folders named "nv_disp.inf_amd64_neutral_"



H1VlTG3NZ you are a GOD among men!!!!!!!!!!!!!!!!!!!!!!!



Seriously, you just won the internet!!!!!!!! Thank you SOOOOO much for this workaround! Now NVENC works for me no problem and I'm on Windows 7 64 bit. Thank you Thank you THANK YOU good sir! You just made my day!

Silly Nvidia....all they have to do is update that dll file and everyone will be happy. My pleas to them on their Shadowplay forum have fallen on deaf ears. :(
 
this did not work for me. i also created another thread because i can't seem to even get anything to stream besides blackness. I think it may be a hitbox player issue though since the stream opens fine with livestreamer on another computer.
 

siedenburg

New Member
@Iti
Jes that are the older .dll files from the last stable release.

@ubuntuaddicted
If you get a blackscreen than it work (the nvenc dll), because if the dll failed to load you get an error.
The blackscreen is an other problem, like worng configured properties for the game or that obs can't get the material if the game is in fullscreen. If last one is the problem you should try borderless or windowed in the game graphic settings.
 

achmetha

Member
All else fails try copy both "nvEncodeAPI.dll" & "nvEncodeAPI64.dll" to both System32 & SysWOW64
Your method worked fine, the .dlls were in a different folder for me (C:\Windows\System32\DriverStore\FileRepository\nvmii.inf_amd64_045c4b7ce6da185d)

For some reason, nvEncodeAPI64.dll goes in System32, and nvEncodeAPI.dll goes in SysWOW64 on my system.

I can now use NVENC again, thanks much sir!
 
not sure why i can't get this to work like others. I downloaded the dll's from whoever had uploaded them a couple days ago, put them in their respective folders, note that 64 was in system32 and the non-64 was in SysWOW64 so that where I put the files I downloaded and when I start OBS 64 bit I get this error:
10:41:27: NVENC supports 8 h264 presets
10:41:27: nvEncInitializeEncoder failed
10:41:27: Couldn't initialize encode
 

Joey

New Member
Just had to register to thank you guys, it worked perfectly the first time. I installed the 2 files in the DL link, installed them to the specified folder and restarted and its working!
 

Martin Bello

New Member
More simple, copy DLL files to OBS folder

x86
Get "nvencodeapi.dll" (335.23 work) and copy to "C:\Program Files (x86)\OBS"

x64
Get "nvencodeapi64.dll" (335.23 work) and copy to "C:\Program Files\OBS"

Atention! You will need to run OBS as an admin
Atention! You will need to run OBS as an admin
Atention! You will need to run OBS as an admin


Tested on v0.622b 32bit and 64bit
 

Attachments

BtbN

Member
I do not recommend copying files in your system directory, specialy ones related to important drivers. The results can be completely unexpected and could cause harm to your system.

The issue with NVENC has been fixed after consulting with nvidia and NVENC will work again in the next OBS release.
As it's a beta driver, it's not urgent enough to force a preliminary release, so for now just don't use the beta driver if you depend on nvenc.

Alternatively, place the attached fixed DLLs in your OBS directory. Make sure to remove them again after the next OBS release, as they have priority over the bundled ones!
 

Attachments

Last edited:

Boildown

Active Member
There is a new WHQL driver out from Nvidia. Who can confirm that it works with the latest OBS release for NVEnc encoding?
 
Status
Not open for further replies.
Top