Question / Help OBS how can I get rid of the mic playback?

ChainZ_GER

New Member
I am constantly hearing everything that comes thru my mic and it's super irritating. I also have no clue how to fix that, because even turning off my mic in the audiomixer doesn't help at all.

Please someone tell me how to disable the microphone playback so I won't always hear myself when OBS is open
 

DEDRICK

Member
Post your log, the HyperX Cloud II doesn't have side-tone so it should not be possible to hear yourself given that Audio Monitoring is turned off.

The standard features that allow you to hear yourself are:

Side-tone, a slight feedback of your own voice in real-time that acts as confirmation that the mic is receiving.
Audio Monitoring, you very specifically have to enable this in OBS.
Listen to this Device, option in Windows to listen to a recording device.

If it's not one of these 3 then something is non-standard or your headset drivers have some odd communication settings that get triggered when OBS launches.
 

ChainZ_GER

New Member
Post your log, the HyperX Cloud II doesn't have side-tone so it should not be possible to hear yourself given that Audio Monitoring is turned off.

The standard features that allow you to hear yourself are:

Side-tone, a slight feedback of your own voice in real-time that acts as confirmation that the mic is receiving.
Audio Monitoring, you very specifically have to enable this in OBS.
Listen to this Device, option in Windows to listen to a recording device.

If it's not one of these 3 then something is non-standard or your headset drivers have some odd communication settings that get triggered when OBS launches.
 

Attachments

  • 2019-01-21 19-06-24.txt
    6.7 KB · Views: 737

DEDRICK

Member
Code:
19:06:26.013: [DShow Device: 'FaceCam'] settings updated:

19:06:26.013:     video device: Logitech HD Webcam C270

19:06:26.013:     video path: \\?\usb#vid_046d&pid_0825&mi_00#6&38ab89e&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{bbefb6c7-2fc4-4139-bb8b-a58bba724083}

19:06:26.013:     resolution: 1184x656

19:06:26.013:     fps: 30.00 (interval: 333333)

19:06:26.013:     format: I420

19:06:26.069:     using video device audio: no

19:06:26.069:     audio device: Kopfhörermikrofon (HyperX 7.1 Audio)

19:06:26.069:     sample rate: 0

19:06:26.069:     channels: 0

19:06:26.069:     audio type: WaveOut

You have your Headset mic playing through your Webcam.

Turn off "Use Custom Audio Device" in the Video Capture device properties, near the bottom.
 

ChainZ_GER

New Member
Code:
19:06:26.013: [DShow Device: 'FaceCam'] settings updated:

19:06:26.013:     video device: Logitech HD Webcam C270

19:06:26.013:     video path: \\?\usb#vid_046d&pid_0825&mi_00#6&38ab89e&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{bbefb6c7-2fc4-4139-bb8b-a58bba724083}

19:06:26.013:     resolution: 1184x656

19:06:26.013:     fps: 30.00 (interval: 333333)

19:06:26.013:     format: I420

19:06:26.069:     using video device audio: no

19:06:26.069:     audio device: Kopfhörermikrofon (HyperX 7.1 Audio)

19:06:26.069:     sample rate: 0

19:06:26.069:     channels: 0

19:06:26.069:     audio type: WaveOut

You have your Headset mic playing through your Webcam.

Turn off "Use Custom Audio Device" in the Video Capture device properties, near the bottom.
Isn't it already turned off? Also, it did that even before I got my webcam. Oh, and I don't get where to find that setting in OBS.
 

DEDRICK

Member
Double Click your Webcam source in the source list.

When you first set up OBS in most use cases you can simply add your Webcam, maybe change the resolution of it, you don't have to do anything else because OBS uses the default Playback and Recording devices.

There is no setting in OBS that will cause you to hear your own microphone when you are first setting up, you have to very deliberately enable it through Audio Monitoring, which is buried in a properties menu that you have to dig to find.

If you heard yourself before getting your webcam, if you heard yourself the moment you set up OBS, it was not OBS doing it. It's more likely Windows or your headset drivers triggering a communication feature to enable sidetone.
 

RighteousPWN

New Member
I am having the same issue as the OP. I don't have any playback selected through OBS or windows. I have narrowed it down to the mic (blue snowball). it i enable playback i get a double playback. have disabled webcam to verify. This is going to sound dumb because I spent days going over this. I was able to stop it by unplugging and plugging back in the mic but it only worked while OBS was open, if closed and reopened the glitch happened again. I even disabled the mic in obs and it still happened. I tried different usb ports still nothing. I think there is some sort of glitch in obs. I am currently using the beta v23 but was having the same issue in v22
 

RighteousPWN

New Member
edit to my OP. Took advice and was in fact that my mic was going through the video capture device. idk how it ended up like that because i never set up that way but it happend. FIXED for ME
 

tripLLLe

New Member
Double Click your Webcam source in the source list.

When you first set up OBS in most use cases you can simply add your Webcam, maybe change the resolution of it, you don't have to do anything else because OBS uses the default Playback and Recording devices.

There is no setting in OBS that will cause you to hear your own microphone when you are first setting up, you have to very deliberately enable it through Audio Monitoring, which is buried in a properties menu that you have to dig to find.

If you heard yourself before getting your webcam, if you heard yourself the moment you set up OBS, it was not OBS doing it. It's more likely Windows or your headset drivers triggering a communication feature to enable sidetone.


Weeks. Weeks I have been scouring the forums and everything else I could find for a solution to this playback issue. Seems like a lot of people are having/have had it. I don't know how many times I've seen the words, "turn off mic monitoring, make sure you've got the correct devices selected, etc." Finally I can stop ripping my hair out! Thank you so much! Also, I've noticed it seems a lot of the people with this problem are using Blue Snowballs? Could be that it's just a common issue and a popular microphone. Probably that, but who knows? Anyway, thanks! I was starting to get headaches from listening to everything in the room twice.
 

Cindanela

New Member
I found the problem before I found this thread, but it was also video capture thing. I had checked use custom audio device. Thought I'd share an image if others have this problem in the future .

customaudio-png.74224
 

Attachments

  • customaudio.png
    customaudio.png
    4.2 KB · Views: 9,385
Top