OBS Freezing/Hanging without a crash file.

OldestStern

New Member
I am not entirely sure how to explain this, but OBS will consistently crash after around 7 minutes. I will post the last log file I found. OBS will simply freeze and stop responding, forcing me to kill it with task manager.
 

Attachments

  • 2022-11-11 13-48-19.txt
    19.8 KB · Views: 31

rockbottom

Active Member
None of those recordings are 7 minutes.

Log is a mess, could be several things. Start by disabling this crap: 13:48:19.279: Webroot SecureAnywhere: enabled (AV)
 

rockbottom

Active Member
HAGS should be Disabled & that Nvidia driver you have installed could be an issue too. FWIW, I've been using Studio driver 522.30 with no issues.

These aren't fixes for your recording stopping but should be done.
Disable Game Bar/DVR

Fix this Scene, create a new Scene for each Window/Game Capture, only (1) per Scene.

13:48:35.738: - scene 'Gaming Scene':
13:48:35.738: - source: 'Window Capture 2' (window_capture)
13:48:35.738: - source: 'Game Capture' (game_capture)
13:48:35.738: - source: 'Window Capture 3' (window_capture)
13:48:35.738: - filter: 'Color Key' (color_key_filter_v2)
13:48:35.738: - source: 'Image 3' (image_source)
13:48:35.738: - source: 'OpenVR Capture' (openvr_capture)
13:48:35.738: - source: 'Audio' (group)
13:48:35.738: - source: 'Audio Input Capture' (wasapi_input_capture)
13:48:35.738: - filter: 'Noise Gate' (noise_gate_filter)
13:48:35.738: - filter: 'Noise Suppression' (noise_suppress_filter)
13:48:35.738: - filter: 'Compressor' (compressor_filter)
13:48:35.738: - source: 'Audio Input Capture 2' (wasapi_input_capture)
13:48:35.738: - filter: 'Noise Gate' (noise_gate_filter)
13:48:35.738: - filter: 'Noise Suppression' (noise_suppress_filter)
13:48:35.738: - filter: 'Compressor' (compressor_filter)
13:48:35.738: - source: 'Desktop Audio' (wasapi_output_capture)
13:48:35.738: - source: 'HUD' (group)
13:48:35.738: - source: 'Overlay' (browser_source)
13:48:35.738: - source: 'Image' (browser_source)
13:48:35.738: - source: 'Wayne' (image_source)
13:48:35.738: - source: 'Dr Perky' (ffmpeg_source)
13:48:35.738: - source: 'Chatbox' (browser_source)
13:48:35.738: - monitoring: monitor only
13:48:35.738: - source: 'Capture' (group)
13:48:35.738: - source: 'Video Capture Device' (dshow_input)
13:48:35.738: - filter: 'Background Removal' (background_removal)
13:48:35.738: - filter: 'Chroma Key' (chroma_key_filter_v2)
13:48:35.738: - filter: 'NVIDIA Background Removal' (nv_greenscreen_filter)
13:48:35.738: - source: 'MS PAINT' (window_capture)
13:48:35.738: - source: 'Display Capture' (monitor_capture)
13:48:35.738: - source: 'Goblin' (image_source)
13:48:35.738: - source: 'meme' (image_source)
13:48:35.738: - source: 'Window Capture' (window_capture)
13:48:35.738: - filter: 'Chroma Key' (chroma_key_filter_v2)
13:48:35.738: - source: 'Text (GDI+)' (text_gdiplus_v2)
13:48:35.738: - source: 'Image 2' (image_source)
13:48:35.738: - source: 'Sound Alerts' (browser_source)
 

rockbottom

Active Member
If you decide to use your UHD 630 for encoding duties down the road, make sure to update the driver before you try.
 

OldestStern

New Member
How would I go about switching the encoding from my dedicated GPU to my Integrated GPU (UHD 630)?

I am not sure how to disable my antivirus.
 

rockbottom

Active Member
Don't switch, RTX2060 is more powerful than the UHD 630. The UHD 630 can be used for off-loading encoding.

Example: I use my iGPU (UHD 770) to encode all my streams while my 3090 encodes my recording.
 

.norman.

Member
 

.norman.

Member
I already did it with that. It said nothing was wrong. It continues to crash regardless of what I am doing.
that link is your log file. admittedly it doesn't offer much help. except turning on browser acceleration. but i figured it would at least be something that you could try.
 

.norman.

Member
most AV software has an exclusion list where you can "whitelist" certain applications and in some cases entire folders. I recommend excluding all folders associated with OBS.
 

rockbottom

Active Member
I do streams, would it be easier to use the UHD for encoding?

Not really easier but it gives you another option. Looks like the UHD 630 driver needs to be updated before it can be used for encoding. I keep it & almost all of my Intel Drivers up to date with Intel Driver Support Assistant.

Do what norman recommended with the anti-virus as it does appear to be the cause of the problem you are having.

Also, you should go back to my first few posts & correct the issues I pointed out. None of them appear to be completed in the latest log.
 
Top