Question / Help OBS doesn't register hotkeys when tabbed out


New Member
I have a Corsair k95 with 18 G keys (macro keys), and figured i'd use them as a replacement for a streamdeck. This worked on Streamlabs OBS, but I recently switched to regular OBS for performance reasons.

Now, the macro keys work fine as long as I am looking at OBS, but when I switch to another window, even in split screen, it doesn't pick up on the hotkeys anymore. I've found multiple threads about loading OBS in admin, but this also doesn't work.


as shown, I also use these keys to manipulate my youtube playlist in chrome, and these work fine, even when I am in a fullscreen game without running chrome in admin, so i've ruled out the Corsair iCUE being at fault. Anyone know a workaround for this? I'll be keeping tabs on the thread throughout the day, so feel free to ask more information if you need it.


New Member
i have fixed the issue for anyone else having this issue
adding a delay on the macros got it to work however i have to hit the key 1 to 8 times at random before it will take affect
adding 15ms delay between mutikey hot keys, ( example CTRL + KP 1 ) and then adding a 50 ms Delay between the key press down and release seems to have fixed it