Question / Help OBS crashing on start-up after updating to v24

faust81

New Member
Hello,
I tried to update OBS from 23.2.1 to 24.01 on my Mac OSX, after installing NDI and CamTwist app for streaming OBS to SKype calls.
When OBS finished installing last update, I could not start and i get the message:

"Failed to load locale/en-US.ini" or "Failed to load loale" at 3rd attempt.

So I downgraded it to the v23.2.1, I deleted the OBS folder in library/Application Support/ and tried to load from root using alternatively the following two commmand strings:
1) sudo /Applications/OBS.app/Contents/MacOS/OBS
2) sudo /Applications/OBS.app/Contents/Resource/bin/obs.

Unfotunately that did not help and i see on the terinal report a few warnings and error, that you can find in attachment.

I would appreciate your support so much.

Regards,
Fausto
 

Attachments

  • OBS crash report.pdf
    16.2 KB · Views: 20

Narcogen

Active Member
Minimum OS requirement for OBS 24 and higher is 10.12. If your hardware supports it you should update, 10.11 is now five years old.

Failing that, remove OBS completely by deleting the Application Support folder(s) and reinstall 23.x. The logfile indicates to me an incomplete/corrupt installation, most likely caused by trying to load 23 after having installed 24.
 

faust81

New Member
Hi, thank you for your replt. Indeed i downgraded but still that was not enough. Seems that uninstalling the camtwist plugin solved the issue.. I will try later to reinstall the camtwist plugin manually. Thanks.
 

faust81

New Member
Ok, if i copy the camtwist pugins in manually inside : /Library/CoreMediaIO/Plug-Ins/DAL as suggested in the installation guide o camtwist, obs crashes at startup. Then I moved the plugins from the DAL folder to the trash and OBS starts again. So it seems that my OBS 23.2.1 does not appreciate finding those plugins into that directory... the plugins are the v3.4.3 and are for Mac osx 10.10 or later..
 

Narcogen

Active Member
CamTwist is also quite old at this point and has not been updated in several years. At some point it may not be tenable to try and use much newer software (Skype for Creators and NDI) with older versions of OBS and CamTwist as well. Already I believe the NDI plugin requires new versions of OBS to function-- OBS 22 at minimum, and its possible that future revisions might raise this.
 
Top