OBS branch with AMD VCE support.

shaNker

New Member
shaNker if you mean tearing then download it again. Should have less now (ok, now >_< ). Bandicam has AMD APP support, right? Does Bandicam's CBR keep its bitrate somewhat stable?

VCE seems to ignore some settings like peak bitrate (resets to bitrate) and VBV buffer size sits at 10Mbps. CBR doesn't want to hard limit to bitrate.
Also my R9 290 takes mysterious control method 5. Maybe Media SDK 1.1 has more info.

Ok I don't get any tearing now but instead it LAGS horribly compared to the actual game play, unlike just using Bandicam or the OBS CPU encoding. When I do 720p encoding I don't get the green line at the bottom. Here are two very quick tests I did:
720P
1080P
Bandicam uses AMD APP yes, but it gives me the option to do CBR or VBR. I set it to VBR and it seems to work. You can download it and give it a shot, you have a very similar card to mine. I think yours is a bit of a step UP from mine. I have an R9 270x.
 

PoznanskaPyra

New Member
Hi. New version doesn't work. When, I streaming video (on twitch/youtube) picture doesn't appear. When, I recording on disk all it's ok.

PC
CPU:Intel Xeon E3-1230v2
GPU:HD7870
Sys:Windows8.1 and Catalyst 14.4

obd1.PNG

obs2.PNG



Ps.
Sorry for my english.
 

shaNker

New Member
upload_2014-5-4_19-15-12.png

I think I found an issue related to the green line in 1080p captures. Notice it shows for height "1 080 pixels" but under Original height it says "1 088 pixels"...? Where are the other 8 pixels coming from? Is something being written into the header incorrectly? I get this green line regardless of the player I use.

General
Complete name : E:\MineCraft 1080.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom
File size : 58.5 MiB
Duration : 20s 767ms
Overall bit rate : 23.7 Mbps
Encoded date : UTC 2014-05-04 15:42:23
Tagged date : UTC 2014-05-04 15:42:23
Writing application : Open Broadcaster Software v0.622b

Video
ID : 2
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.2
Format settings, CABAC : Yes
Format settings, ReFrames : 1 frame
Muxing mode : Container profile=High@3.1
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 20s 767ms
Source duration : 20s 734ms
Bit rate : 23.6 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Original height : 1 088 pixels
Display aspect ratio : 16:9
Original display aspect ratio : 16:9
Frame rate mode : Variable
Frame rate : 30.000 fps
Minimum frame rate : 29.412 fps
Maximum frame rate : 30.303 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.379
Stream size : 58.2 MiB (99%)
Source stream size : 58.3 MiB (100%)
Encoded date : UTC 2014-05-04 15:42:23
Tagged date : UTC 2014-05-04 15:42:23
mdhd_Duration : 20767

Audio
ID : 1
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 20s 755ms
Source duration : 20s 715ms
Bit rate mode : Constant
Nominal bit rate : 192 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Compression mode : Lossy
Source stream size : 267 KiB (0%)
Language : English
Encoded date : UTC 2014-05-04 15:42:23
Tagged date : UTC 2014-05-04 15:42:23
 

Attachments

  • upload_2014-5-4_19-8-35.png
    upload_2014-5-4_19-8-35.png
    56.6 KB · Views: 68

jackun

Developer
View attachment 2285
I think I found an issue related to the green line in 1080p captures. Notice it shows for height "1 080 pixels" but under Original height it says "1 088 pixels"...? Where are the other 8 pixels coming from? Is something being written into the header incorrectly? I get this green line regardless of the player I use.

VCE adds the 8 pixels as width/height needs to be multiple of 16 pixels. Player should probably crop it to "Height" value. My monitor is (still) 1680x1050 so it adds 6px to height but no green lines.

Note that it is currently just a test version so for serious streaming use x264. Trying to figure out what's the deal with the encoder slowness.
 

vbdkv

Member
CPU drops by around 20-25% usage on an FX-8320 so that's pretty awesome. It is kinda stuttery though but I'm assuming it's because its an early version and 32bit on top of that. Stuttering aside, it captures BF3 absolutely perfectly at 1080p/60fps without any noticeable performance loss, something I couldn't do with software alone. Definitely looking forward to this with bugs squished :D I also see no difference in quality at 3000kbps so that's another huge plus.
 

jackun

Developer
CPU drops by around 20-25% usage on an FX-8320 so that's pretty awesome. It is kinda stuttery though but I'm assuming it's because its an early version and 32bit on top of that. Stuttering aside, it captures BF3 absolutely perfectly at 1080p/60fps without any noticeable performance loss, something I couldn't do with software alone. Definitely looking forward to this with bugs squished :D I also see no difference in quality at 3000kbps so that's another huge plus.

Cool then. VFW codec with Dxtory and fixed QP i can do 1050p@60 but currently if there is even a little motion OBS starts to stutter, but CBR is smoother heh. I think Dxtory just handles buffers a bit differently and it looks like NVEnc plugin does some output buffering itself too (or is that just because of slices instead of full frames?)
 

PoznanskaPyra

New Member
1.) Now with bottom cropping. No green line?

2.) Yeah, CBR doesn't want to hardlimit. But if "Enable CBR padding" is enabled it stays at/above bitrate now atleast?

1.This file helped, green line disappeared.
2.CBR padding disable/enable no difference

ps. High bitrate is only in battlefield 4.
In Euro Truck Simulator 2 bitrate is 3200-3300. 3300kbit/s stream and playing online games is maximum for my internet connection.

ps2.
FPS droped to 30 and video quality is low.
 
Last edited:

XeiZ

Member
Found a option https://dl.dropboxusercontent.com/u/235773/ObsVCE-filler.7z
Should generate filler pictures. Seemed to keep more to CBR bitrate when no motion.

Nope, didnt work. It started of with 2000kbps (which i set) and "excellent" flag but after a while it started dropping the bitrate down to 900kbps during no motion and thus made twitch believe its not CBR again.

edit: http://www.twitch.tv/xeiz/b/526131459 also it doesnt seem to be 30fps, seems kinda choppy but that could be flash player in this case as it was fine with the other test yesterday.
 
Last edited:
Something is wrong when I record 1080p 60 FPS. It drops to 45, even 30 FPS and says it's dropping frames. When I record with x264 it sticks about 50+ FPS. I remember that I could record 720p 60 FPS with VCE and it was stable 60 FPS, no drops, but now I can only get to 57 FPS.

I think that you can somehow control bitrate by disabling CBR and setting quality level (this thing under CBR, I don't know how to name that in English) to desired level. When it's 0 quality is terrible and bitrate is about 200 Kb/s but only when not much movement on the screen, when I just change scene from small to fullscreen bitrate jumps to 2000 Kb/s +
When it's set to 10 quality is nice and bitrate is about 1200 Kb/s but the same thing happens when there's some fast movement on the screen.

EDIT:
Another thing that I discovered - video seems to get laggy when bitrate is high, when it's max 10 000 Kb/s it's OK, but when it's about 20 000 Kb/s it stutters and it's not like 30 FPS at all. I think that if you will fix bitrate problem it will be good enough to stream using VCE. Like I said - only disabling CBR and setting quality seems to control bitrate.
 
Last edited:
Top