OBS 30.0 can't start QSV recording anymore

obs_windows

New Member
I've been using QSV recording with OBS for many prior versions on Windows 10, but when I tried installing OBS 30.0 today my recordings will not start. I noticed in the recording settings screen there are now 2 different QSV options, one of them says "deprecated" which was what mine was initially set to. I tried changing it to the other QSV option but that one fails with the same log error:

08:46:49.121: >>> new qsv encoder
08:46:49.121: [qsv encoder: 'advanced_video_recording'] settings:
08:46:49.121: codec: H.264
08:46:49.121: rate_control: CQP
08:46:49.121: qpi: 23
08:46:49.121: qpb: 23
08:46:49.121: qpp: 23
08:46:49.121: target_usage: TU4
08:46:49.121: profile: high
08:46:49.121: keyint: 0
08:46:49.121: latency: normal
08:46:49.121: b-frames: 0
08:46:49.121: enhancements: on
08:46:49.121: fps_num: 30
08:46:49.121: fps_den: 1
08:46:49.121: width: 1920
08:46:49.121: height: 1080
08:46:49.121: [qsv encoder: 'advanced_video_recording'] debug info:
08:46:49.166: [qsv encoder: 'msdk_impl'] Specified object/item/sync point not found. (MFX_ERR_NOT_FOUND)
08:46:49.166: [qsv encoder: 'advanced_video_recording'] qsv failed to load

How can I fix this? For now I rolled back to 29.1.3 which works ok. Entire log file attached.
 

Attachments

  • obs-log.txt
    8.9 KB · Views: 80

Nanditous

New Member
I got the same problem but i use it for streaming. But fail for streaming and recording. Hope there's a workaroung...
 

FluffiBuni

New Member
I've just updated this evening, and hit exactly the same recording issue ...
[qsv encoder: 'msdk_impl'] Specified object/item/sync point not found. (MFX_ERR_NOT_FOUND).

I've tried a few settings changes and resetting my recording options through the wizard and running in Safe Mode but no joy.
 

Attachments

  • 2023-11-15 19-48-28.txt
    8.8 KB · Views: 56

Suslik V

Active Member
According to messages from community in Discord and next changes:
your CPU ("Ivy Bridge" architecture code name) no longer supported in OBS. Too old hardware for new OBS.

Downgrade to previous version (v29.1.3) of OBS can help.

All OBS releases (files under the "Assets" spoilers):
 

haramo

New Member
Same issue here, for first install OBS today on a completely reinstalled laptop (HP probook 4520s).

ON a newer laptop (lenovo) , upated OBS to 30 and works great.

Would be great if old laptops can keep working on newer updates of OBS.. in stead of using an old version of OBS , maybe security risks... .
 

rockbottom

Active Member
I believe leaving the Gen 6 & older iGPU's in play was messing up the Gen 7 & newer iGPU's from working correctly as I can now use HEVC with QSV & I could not before v30. Out with the old & in with the new.....
 

Suslik V

Active Member
I just installed version v29.1.3 but same error: MFX_ERR_UNSUPPORTED
The message is slightly different from what people have in OBS v30, look:

MFX_ERR_UNSUPPORTED - likely encoder not capable of doing something (b-frames, colorspace, high efficiency coding etc). It's my own guess.
MFX_ERR_NOT_FOUND - hardware encoding not supported at all (too old CPU for new OBS).
 

kamild_

Member
Just had this issue. Good to know i7-5500U is now no longer supported for HW encoding.
It is for situations like this where I think OBS should have an improved updater system which can check the user's current hardware and warn them about an important feature no longer being supported. A vague note in the notes about this is, in my opinion, not enough.
 
Top