OBS 0.52.08 aquaman build - quicksync & capture improvements

Status
Not open for further replies.

tokala

New Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Okay.. ive got a problem and this happens since .07.. I am aware of my bad english since im german but maybe you understand me and can help me out.. x3

The thing is, that when im streaming, opencl works fine for me.. without a problem.. i can stream for like 4 hours and obs dont crash.. My problem is that the longer i stream, to more stuttering i got in my microphone.. My viewers tell me that sometimes not even the half of my sentences get to them , i randomly just stop talking for them.. Im using push to talk and im going to post my specs and the last log file here, but i can say that i dont get this problem with the 0.522 Beta D:

Even when i disable opencl and stream normaly this is still happening.. and as i say, the longer my stream runs, the worse it gets.. so maybe you can help me D:

Pc is:

i7 2600k OC'ed to 4.6
8GB of RAM
GTX 680
1 monitor
(Headset is Logitech G35 if that helps)

Logfile of the last stream:

Code:
19:55:10: Open Broadcaster Software v0.52.08b aquaman build - 32bit (´・ω・`)
19:55:10: -------------------------------
19:55:10: CPU Name: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
19:55:10: CPU Speed: 3400MHz
19:55:10: Physical Memory:  4095MB Total, 4095MB Free
19:55:10: stepping id: 7, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 8, total cores 4
19:55:10: monitor 1: pos={0, 0}, size={1920, 1080}
19:55:10: Windows Version: 6.1 Build 7601 S
19:55:10: Aero is Enabled
19:55:10: -------------------------------
19:55:10: OBS Modules:
19:55:10: Base Address     Module
19:55:10: 011A0000         OBS.exe
19:55:10: 6B020000         OBSApi.dll
19:55:10: 6C570000         DShowPlugin.dll
19:55:10: 6F800000         GraphicsCapture.dll
19:55:10: 6BED0000         NoiseGate.dll
19:55:10: 6BEF0000         PSVPlugin.dll
19:55:10: ------------------------------------------
19:55:10: Adapter 1
19:55:10:   Video Adapter: NVIDIA GeForce GTX 680
19:55:10:   Video Adapter Dedicated Video Memory: 2091581440
19:55:10:   Video Adapter Shared System Memory: 2147807232
19:55:10: =====Stream Start: 2013-07-09, 19:55:10===============================================
19:55:10:   Multithreaded optimizations: On
19:55:10:   Base resolution: 1920x1080
19:55:10:   Output resolution: 1280x720
19:55:10: ------------------------------------------
19:55:10: Loading up D3D10...
19:55:10: Playback device Default
19:55:10: ------------------------------------------
19:55:10: Using desktop audio input: Lautsprecher (Logitech G35 Headset)
19:55:10: ------------------------------------------
19:55:10: Using auxilary audio input: Mikrofon (Logitech G35 Headset)
19:55:10: ------------------------------------------
19:55:10: Audio Encoding: AAC
19:55:10:     bitrate: 128
19:55:10: Using Monitor Capture
19:55:10: Using text output
19:55:10: Using text output
19:55:10: Using bitmap image
19:55:10: Using bitmap image
19:55:10: Using custom x264 settings: "opencl=true opencl_device=0"
19:55:10: ------------------------------------------
19:55:10: Video Encoding: x264
19:55:10:     fps: 30
19:55:10:     width: 1280, height: 720
19:55:10:     preset: veryfast
19:55:10:     CBR: no
19:55:10:     CFR: no
19:55:10:     max bitrate: 3500
19:55:10:     buffer size: 3500
19:55:10:     quality: 10
19:55:10: ------------------------------------------
19:55:12: Using RTMP service: Twitch / Justin.tv
19:55:12:   Server selection: rtmp://live-ams.justin.tv/app
19:55:14: SO_SNDBUF was at 8192
19:55:14: SO_SNDBUF is now 65536
19:57:43: ++++++++++++++++++++++++++++++++++++++++++++++++++++++
19:57:43:   New Scene
19:57:43: Using graphics capture
19:57:43: SharedTexCapture hooked
21:17:58: ++++++++++++++++++++++++++++++++++++++++++++++++++++++
21:17:58:   New Scene
21:17:58: Using Monitor Capture
21:17:58: Using text output
21:17:58: Using text output
21:17:58: Using bitmap image
21:17:58: Using bitmap image
21:26:46: ++++++++++++++++++++++++++++++++++++++++++++++++++++++
21:26:46:   New Scene
21:26:46: Using graphics capture
21:26:46: SharedTexCapture hooked
22:51:19: ++++++++++++++++++++++++++++++++++++++++++++++++++++++
22:51:19:   New Scene
22:51:19: Using Monitor Capture
22:51:19: Using text output
22:51:19: Using text output
22:51:19: Using bitmap image
22:51:19: Using bitmap image
23:02:13: ++++++++++++++++++++++++++++++++++++++++++++++++++++++
23:02:13:   New Scene
23:02:13: Using graphics capture
23:02:14: SharedTexCapture hooked
23:03:15: GraphicsCaptureSource::NewCapture:  eliminating old capture
23:03:15: SharedTexCapture hooked
23:22:32: ++++++++++++++++++++++++++++++++++++++++++++++++++++++
23:22:32:   New Scene
23:22:32: Using Monitor Capture
23:22:32: Using text output
23:22:32: Using text output
23:22:32: Using bitmap image
23:22:32: Using bitmap image
23:23:12: Total frames rendered: 374441, number of frames that lagged: 9 (0.00%) (it's okay for some frames to lag)
23:23:12: RTMPPublisher::SocketLoop: Aborting due to bStopping
23:23:12: Number of times waited to send: 8, Waited for a total of 29104 bytes
23:23:12: Number of b-frames dropped: 8 (0.0021%), Number of p-frames dropped: 17 (0.0045%), Total 25 (0.0067%)
23:23:12: =====Stream End: 2013-07-09, 23:23:12=================================================
23:23:16: 
23:23:16: Profiler results:
23:23:16: 
23:23:16: ==============================================================
23:23:16: frame - [100%] [avg time: 2.603 ms (cpu time: avg 1.352 ms, total 506395 ms)] [avg calls per frame: 1] [children: 98.3%] [unaccounted: 1.69%]
23:23:16: | scene->Preprocess - [58.9%] [avg time: 1.533 ms (cpu time: avg 0.343 ms, total 128779 ms)] [avg calls per frame: 1]
23:23:16: | video encoding and uploading - [39.4%] [avg time: 1.026 ms (cpu time: avg 0.967 ms, total 362406 ms)] [avg calls per frame: 1] [children: 38.1%] [unaccounted: 1.34%]
23:23:16: | | CopyResource - [0.269%] [avg time: 0.007 ms (cpu time: avg 0.006 ms, total 2386.82 ms)] [avg calls per frame: 0]
23:23:16: | | conversion to 4:2:0 - [0.538%] [avg time: 0.014 ms (cpu time: avg 0.003 ms, total 1326.01 ms)] [avg calls per frame: 0]
23:23:16: | | call to encoder - [36.6%] [avg time: 0.952 ms (cpu time: avg 0.922 ms, total 345511 ms)] [avg calls per frame: 0]
23:23:16: | | sending stuff out - [0.692%] [avg time: 0.018 ms (cpu time: avg 0.019 ms, total 7160.43 ms)] [avg calls per frame: 0]
23:23:16: | Convert444Threads - [2.56e+003%] [avg time: 66.664 ms (cpu time: avg 0.993 ms, total 371860 ms)] [avg calls per frame: 1]
23:23:16: ==============================================================
23:23:16:
 

Kharay

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Does this happen in voice communication software as well? Such as Skype, TeamSpeak, etc? Or just when you are streaming with OBS?
 

tokala

New Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

This only happens while im streaming.. I can use teamspeak or skype the whole day without any problems.. and while im streaming i shut down teamspeak and skype so that cannot be the problem D:

And like i write above.. this only happens with the 0.52.07 and 0.52.08 version.. no problems with 0.522 beta.
 

Momentum

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

also, does that mic stutter happens when u dont use push to talk?
 

tokala

New Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Momentum said:
also, does that mic stutter happens when u dont use push to talk?
I dont know. I have to use it since im not living alone and you would always hear them talking, laughing or other stuff.. :x Push to talk is my only option : /
 

ExitSign

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

The latest included x264 lib is not compiled with opencl support... oops?

x264-136 that is (from git). (133 in public test build is fine)

16:24:42: Using custom x264 settings: "opencl=true threads=6 ratetol=5 me=hex partitions=all 8x8dct=1 aq-mode=2 direct=auto"
16:24:42: x264: OpenCL: not compiled with OpenCL support, disabling
 

tokala

New Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Ok.. ive found something out.. The problem happens EVERYWHERE, not just in games, even while im streaming my desktop..

And as surreal it sounds.. my push to talk stops working when i push the button shift, strg or alt while i am talking.. and if thats not strange enought, nether my brother got this problen, or my friend.. then can press shift, alt or strg like they want and nothing happens..

This happens EVERY time i do this and push to talk only works again if i push the button for it again.. if i would just hold down to button nothing happens and no one can hear what i say..

The strangest thing is, that this only happens in this new version.. in the old version i dont got this problem -.-

Ive tryed out everything i can.. download other drivers for my keyboard, even change the keyboard, headset, mouse.. but nothing helps.. i cant figure out whats the problem and why it only happens in the new version D:
 

ExitSign

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

tokala said:
Ok.. ive found something out.. The problem happens EVERYWHERE, not just in games, even while im streaming my desktop..

And as surreal it sounds.. my push to talk stops working when i push the button shift, strg or alt while i am talking.. and if thats not strange enought, nether my brother got this problen, or my friend.. then can press shift, alt or strg like they want and nothing happens..

This happens EVERY time i do this and push to talk only works again if i push the button for it again.. if i would just hold down to button nothing happens and no one can hear what i say..

The strangest thing is, that this only happens in this new version.. in the old version i dont got this problem -.-

Ive tryed out everything i can.. download other drivers for my keyboard, even change the keyboard, headset, mouse.. but nothing helps.. i cant figure out whats the problem and why it only happens in the new version D:
Enable 'allow other modifiers on hotkeys' in advanced settings.
 

tokala

New Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

ExitSign said:
tokala said:
Ok.. ive found something out.. The problem happens EVERYWHERE, not just in games, even while im streaming my desktop..

And as surreal it sounds.. my push to talk stops working when i push the button shift, strg or alt while i am talking.. and if thats not strange enought, nether my brother got this problen, or my friend.. then can press shift, alt or strg like they want and nothing happens..

This happens EVERY time i do this and push to talk only works again if i push the button for it again.. if i would just hold down to button nothing happens and no one can hear what i say..

The strangest thing is, that this only happens in this new version.. in the old version i dont got this problem -.-

Ive tryed out everything i can.. download other drivers for my keyboard, even change the keyboard, headset, mouse.. but nothing helps.. i cant figure out whats the problem and why it only happens in the new version D:
Enable 'allow other modifiers on hotkeys' in advanced settings.
that realy helped.. omg.. 3 hours of testing and anger.. for nothing.. >,< thanks.. problem solved.. -.-

for some reasons i could not enable that.. obs always disabled it until i delete all of my settings.. then it was on automaticly D:
 

Jim

Jim
Developer
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Thank you everyone for all the patience, testing, and general awesomeness that you guys just exude omnidirectionally. 0.54b has been released, OpenGL bugs have hopefully been fixed (where it wasn't capturing and it was crashing on some occasions).

I'll leave the thread open for a few more days if they have anything further to add
 

Momentum

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Well thank you for continuous development Jim. Will try out the new build
 

skylarblu

New Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Tried out the new build but quicksync is greyed out, in the previous build I could at least enable it.
HD4000 + GTX 460 and all the latest drivers, I've tried with 2 physical displays attached in extend mode, and even having the HD4000 as my main display.
 

ExitSign

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

tokala said:
ExitSign said:
tokala said:
Ok.. ive found something out.. The problem happens EVERYWHERE, not just in games, even while im streaming my desktop..

And as surreal it sounds.. my push to talk stops working when i push the button shift, strg or alt while i am talking.. and if thats not strange enought, nether my brother got this problen, or my friend.. then can press shift, alt or strg like they want and nothing happens..

This happens EVERY time i do this and push to talk only works again if i push the button for it again.. if i would just hold down to button nothing happens and no one can hear what i say..

The strangest thing is, that this only happens in this new version.. in the old version i dont got this problem -.-

Ive tryed out everything i can.. download other drivers for my keyboard, even change the keyboard, headset, mouse.. but nothing helps.. i cant figure out whats the problem and why it only happens in the new version D:
Enable 'allow other modifiers on hotkeys' in advanced settings.
that realy helped.. omg.. 3 hours of testing and anger.. for nothing.. >,< thanks.. problem solved.. -.-

for some reasons i could not enable that.. obs always disabled it until i delete all of my settings.. then it was on automaticly D:
that was a bug in test build .07 I think.
 

Luk

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Running 0.541b here, now QSV works when the fake-monitor is enabled.

However, I can still enable QSV when having the fake-monitor disabled. When I start the encoding process (preview/stream) OBS will not output anything. When trying to end the preview/stream OBS freezes. This only happens with QSV enabled + fake-monitor disabled.

Log:
Code:
00:45:40: Open Broadcaster Software v0.541b - 64bit ( ^ω^)
00:45:40: -------------------------------
00:45:40: CPU Name: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
00:45:40: CPU Speed: 3400MHz
00:45:40: Physical Memory:  16263MB Total, 10282MB Free
00:45:40: stepping id: 9, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 4, total cores 4
00:45:40: monitor 1: pos={0, 0}, size={1680, 1050}
00:45:40: Windows Version: 6.1 Build 7601 S
00:45:40: Aero is Disabled
00:45:40: -------------------------------
00:45:40: OBS Modules:
00:45:40: Base Address     Module
00:45:40: 000000003FAD0000 OBS.exe
00:45:40: 00000000E67D0000 OBSApi.dll
00:45:40: 00000000F18F0000 DShowPlugin.dll
00:45:40: 00000000F2B80000 GraphicsCapture.dll
00:45:40: 00000000F3100000 NoiseGate.dll
00:45:40: 00000000F2710000 PSVPlugin.dll
00:45:40: ------------------------------------------
00:45:40: Adapter 1
00:45:40:   Video Adapter: NVIDIA GeForce GTX 580
00:45:40:   Video Adapter Dedicated Video Memory: 1560739840
00:45:40:   Video Adapter Shared System Memory: 2684235776
00:45:40: ------------------------------------------
00:45:40: Adapter 2
00:45:40:   Video Adapter: Intel(R) HD Graphics 4000
00:45:40:   Video Adapter Dedicated Video Memory: 67108864
00:45:40:   Video Adapter Shared System Memory: 1711276032
00:45:40: =====Stream Start: 2013-07-12, 00:45:40===============================================
00:45:40:   Multithreaded optimizations: On
00:45:40:   Base resolution: 1680x1050
00:45:40:   Output resolution: 1680x1050
00:45:40: ------------------------------------------
00:45:40: Loading up D3D10...
00:45:40: Playback device Default
00:45:40: ------------------------------------------
00:45:40: Using desktop audio input: Lautsprecher (Creative SB X-Fi)
00:45:40: ------------------------------------------
00:45:40: Using auxilary audio input: Mikrofon (Creative SB X-Fi)
00:45:40: ------------------------------------------
00:45:40: Audio Encoding: AAC
00:45:40:     bitrate: 128
00:45:40: Using Monitor Capture
00:45:40: Found QSV hardware support
00:45:40: ------------------------------------------
00:45:40: QSV version 1.6 using MFX_IMPL_HARDWARE_ANY | MFX_IMPL_VIA_D3D11 (actual: MFX_IMPL_HARDWARE2 | MFX_IMPL_VIA_D3D11)
00:45:40: 
00:45:40: ===================================================================================
00:45:40: Error: QSV hardware acceleration unavailable due to a driver bug. Reduce the number
00:45:40:        of monitors connected to you graphics card or configure your Intel graphics
00:45:40:        card to be the primary device.
00:45:40:        Refer to http://software.intel.com/en-us/forums/topic/359368#comment-1722674
00:45:40:        for more information.
00:45:40: ===================================================================================
00:45:40: 
00:45:40: Continuing with decreased performance
00:45:40: Using 8 encode tasks
00:45:40: ------------------------------------------
00:45:40: Video Encoding: QSV
00:45:40:     fps: 50
00:45:40:     width: 1680, height: 1050
00:45:40:     target-usage: MFX_TARGETUSAGE_BEST_QUALITY
00:45:40:     CBR: no
00:45:40:     CFR: no
00:45:40:     max bitrate: 3500
00:45:40:     buffer size: 3496
00:45:40: ------------------------------------------
00:45:41: Error: all encode tasks in use, stalling pipeline
00:45:41: Error: all encode tasks in use, stalling pipeline
00:45:41: Error: encoder is taking too long, consider decreasing your FPS/increasing your bitrate
00:45:41: Error: all encode tasks in use, stalling pipeline
00:45:41: Error: encoder is taking too long, consider decreasing your FPS/increasing your bitrate
 

swent

New Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

I'm having a really hard time finding anything about custom quicksync x254 settings. I see an option for that in latest OBS build but I'm wondering on the parameters that can be tweaked.
 

paibox

heros in an halfshel
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

If you mouseover the checkbox for it, you'll see that it only supports two settings at the moment. keyint and bframes.
 

skylarblu

New Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Luk said:
Running 0.541b here, now QSV works when the fake-monitor is enabled.

However, I can still enable QSV when having the fake-monitor disabled. When I start the encoding process (preview/stream) OBS will not output anything. When trying to end the preview/stream OBS freezes. This only happens with QSV enabled + fake-monitor disabled.

Log:
Code:
00:45:40: Open Broadcaster Software v0.541b - 64bit ( ^ω^)
00:45:40: -------------------------------
00:45:40: CPU Name: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
00:45:40: CPU Speed: 3400MHz
00:45:40: Physical Memory:  16263MB Total, 10282MB Free
00:45:40: stepping id: 9, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 4, total cores 4
00:45:40: monitor 1: pos={0, 0}, size={1680, 1050}
00:45:40: Windows Version: 6.1 Build 7601 S
00:45:40: Aero is Disabled
00:45:40: -------------------------------
00:45:40: OBS Modules:
00:45:40: Base Address     Module
00:45:40: 000000003FAD0000 OBS.exe
00:45:40: 00000000E67D0000 OBSApi.dll
00:45:40: 00000000F18F0000 DShowPlugin.dll
00:45:40: 00000000F2B80000 GraphicsCapture.dll
00:45:40: 00000000F3100000 NoiseGate.dll
00:45:40: 00000000F2710000 PSVPlugin.dll
00:45:40: ------------------------------------------
00:45:40: Adapter 1
00:45:40:   Video Adapter: NVIDIA GeForce GTX 580
00:45:40:   Video Adapter Dedicated Video Memory: 1560739840
00:45:40:   Video Adapter Shared System Memory: 2684235776
00:45:40: ------------------------------------------
00:45:40: Adapter 2
00:45:40:   Video Adapter: Intel(R) HD Graphics 4000
00:45:40:   Video Adapter Dedicated Video Memory: 67108864
00:45:40:   Video Adapter Shared System Memory: 1711276032
00:45:40: =====Stream Start: 2013-07-12, 00:45:40===============================================
00:45:40:   Multithreaded optimizations: On
00:45:40:   Base resolution: 1680x1050
00:45:40:   Output resolution: 1680x1050
00:45:40: ------------------------------------------
00:45:40: Loading up D3D10...
00:45:40: Playback device Default
00:45:40: ------------------------------------------
00:45:40: Using desktop audio input: Lautsprecher (Creative SB X-Fi)
00:45:40: ------------------------------------------
00:45:40: Using auxilary audio input: Mikrofon (Creative SB X-Fi)
00:45:40: ------------------------------------------
00:45:40: Audio Encoding: AAC
00:45:40:     bitrate: 128
00:45:40: Using Monitor Capture
00:45:40: Found QSV hardware support
00:45:40: ------------------------------------------
00:45:40: QSV version 1.6 using MFX_IMPL_HARDWARE_ANY | MFX_IMPL_VIA_D3D11 (actual: MFX_IMPL_HARDWARE2 | MFX_IMPL_VIA_D3D11)
00:45:40: 
00:45:40: ===================================================================================
00:45:40: Error: QSV hardware acceleration unavailable due to a driver bug. Reduce the number
00:45:40:        of monitors connected to you graphics card or configure your Intel graphics
00:45:40:        card to be the primary device.
00:45:40:        Refer to http://software.intel.com/en-us/forums/topic/359368#comment-1722674
00:45:40:        for more information.
00:45:40: ===================================================================================
00:45:40: 
00:45:40: Continuing with decreased performance
00:45:40: Using 8 encode tasks
00:45:40: ------------------------------------------
00:45:40: Video Encoding: QSV
00:45:40:     fps: 50
00:45:40:     width: 1680, height: 1050
00:45:40:     target-usage: MFX_TARGETUSAGE_BEST_QUALITY
00:45:40:     CBR: no
00:45:40:     CFR: no
00:45:40:     max bitrate: 3500
00:45:40:     buffer size: 3496
00:45:40: ------------------------------------------
00:45:41: Error: all encode tasks in use, stalling pipeline
00:45:41: Error: all encode tasks in use, stalling pipeline
00:45:41: Error: encoder is taking too long, consider decreasing your FPS/increasing your bitrate
00:45:41: Error: all encode tasks in use, stalling pipeline
00:45:41: Error: encoder is taking too long, consider decreasing your FPS/increasing your bitrate
How do you have and enable a fake monitor? it's the only thing I haven't tried yet, I thought an actual physical second monitor would make it work lol.
 

DAOWAce

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

DOTA2 running like absolute shyte when game capture is used.

Don't know if this is a new problem, have never tried to stream it before.

XSplit works just fine.. aside from having the stream running at 40FPS when I have it at 60 (which is why I tested it with OBS).

Tried searching the forums but don't see anyone else having this particular issue. Quickly posting here before maybe making my own thread on it.

Using the latest version, .541b.
 

Kharay

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

You may want to make your own thread about that one, actually. I have no issue whatsoever streaming DOTA2 without even dropping a single frame in DOTA2 itself.

And when you do make your own thread about it, please start by posting a log of a session where this issue occurred.
 
Status
Not open for further replies.
Top