OBS 0.52.08 aquaman build - quicksync & capture improvements

Status
Not open for further replies.

Bensam123

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Is there any chance we can see further openCL enhancements in OBS? Perhaps through capture or other tasks not related directly to encoding (since you guys don't have a lot of influence over encoding)?

Only reason I ask is because pretty much anyone can use it and it doesn't really have a downside (quality doesn't really suffer, customizeable), you can even assign it to a secondary adapter.
 

vaesauce

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Bensam123 said:
Is there any chance we can see further openCL enhancements in OBS? Perhaps through capture or other tasks not related directly to encoding (since you guys don't have a lot of influence over encoding)?

Only reason I ask is because pretty much anyone can use it and it doesn't really have a downside (quality doesn't really suffer, customizeable), you can even assign it to a secondary adapter.
I want stability from openCL. But obviously that could just be on my end since others are using it with no issues. I still haven't found a way to stop the openCL crashes.

On a side note, I don't know about you guys but the Quality increases A LOT when using openCL o_O.
 

z0rz

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Damn, consistent crashes with OpenCL on 32bit and 64bit (7870 with 13.4 drivers). Was really hoping to see if it made it possible to stream 4v4 SC2 @60fps haha

Decided to tinker with QSV. I noticed everyone saying that quality balance and custom x264 parameters are ignored by QSV encoding, but what does the "Use custom x264 settings for QSV" checkbox do then?
 

fredkruge

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

I see, thanks for the information about quicksync, but.
Momentum said:
While it might not be suitable for high motion capture and encoding, it should work just fine for streaming LoL (given that u have 5000 bitrate).
Im not really interested in streaming league of blarghhhhhhhh. So it requires a pretty high bitrate to sustain good quality, eh? What kind of bit rate do you think it would take for high motion stuff (60fps @ 720p) using quicksync? Im sort of interested in getting good quality with low CPU usage, which is why im looking into quicksync or a capture card... and if you say quicksync is comprable to the superfast preset, could anybody recommend a decent capture card that gets good quality with a lower bitrate? Canadian ISP's restrict bandwidth -_-' (im going to test quicksync once my ISP increases my upload speed... im going from 2megabits to 10 megabits :) )

EDIT: at this rate with the number of questions should I create a separate thread instead of hijacking this OBS thread o.O? I think I am going to. going to link the thread.
http://obsproject.com/forum/viewtopic.php?f=5&t=5504
 

Krazy

Town drunk
Forum Moderator
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

vaesauce said:
Bensam123 said:
Is there any chance we can see further openCL enhancements in OBS? Perhaps through capture or other tasks not related directly to encoding (since you guys don't have a lot of influence over encoding)?

Only reason I ask is because pretty much anyone can use it and it doesn't really have a downside (quality doesn't really suffer, customizeable), you can even assign it to a secondary adapter.
I want stability from openCL. But obviously that could just be on my end since others are using it with no issues. I still haven't found a way to stop the openCL crashes.

On a side note, I don't know about you guys but the Quality increases A LOT when using openCL o_O.
Quality should be ever so slightly worse because of how the hardware OpenCL does its thing. There definitely should not be any noticeable quality increases, as long as all other settings remain the same.

z0rz said:
Damn, consistent crashes with OpenCL on 32bit and 64bit (7870 with 13.4 drivers). Was really hoping to see if it made it possible to stream 4v4 SC2 @60fps haha

Decided to tinker with QSV. I noticed everyone saying that quality balance and custom x264 parameters are ignored by QSV encoding, but what does the "Use custom x264 settings for QSV" checkbox do then?
Pffft, I can't even play late game 4v4 without my machine slowing to a crawl without streaming. And I'm playing on a heavily overclocked 2600k with a GTX 670 :P

fredkruge said:
I see, thanks for the information about quicksync, but.
Momentum said:
While it might not be suitable for high motion capture and encoding, it should work just fine for streaming LoL (given that u have 5000 bitrate).
Im not really interested in streaming league of blarghhhhhhhh. So it requires a pretty high bitrate to sustain good quality, eh? What kind of bit rate do you think it would take for high motion stuff (60fps @ 720p) using quicksync? Im sort of interested in getting good quality with low CPU usage, which is why im looking into quicksync or a capture card... and if you say quicksync is comprable to the superfast preset, could anybody recommend a decent capture card that gets good quality with a lower bitrate? Canadian ISP's restrict bandwidth -_-' (im going to test quicksync once my ISP increases my upload speed... im going from 2megabits to 10 megabits :) )

EDIT: at this rate with the number of questions should I create a separate thread instead of hijacking this OBS thread o.O? I think I am going to. going to link the thread.
http://obsproject.com/forum/viewtopic.php?f=5&t=5504
Capture cards will provide even worse quality for the same bitrate, and are largely useless on a single PC setup, especially since OBS can't make use of the hardware encoders on them (nor would you ever want to). The only way a capture card helps for PC gaming is if you are using a 2PC setup, and then lower the encoding preset and/or tweak the encoder with lots of custom settings.
 

Geoning

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Game Capture doesn't work with Minecraft (OpenGL)

Log:

Error: Out of memory while trying to allocate 10712 bytes at 000007FACDC4AF75

17:01:30: Open Broadcaster Software v0.52.08b aquaman build - 64bit ( ^ω^)
17:01:30: -------------------------------
17:01:30: CPU Name: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
17:01:30: CPU Speed: 2494MHz
17:01:30: Physical Memory: 8081MB Total, 5886MB Free
17:01:30: stepping id: 9, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 4, total cores 2
17:01:30: monitor 1: pos={0, 0}, size={1600, 900}
17:01:30: Windows Version: 6.2 Build 9200
17:01:30: Aero is Enabled
 

Xphome

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Does x264 see the devices in the same order as OBS? I want to know if I should use opencl_device=1 or 2 since I want it to run on my GTX 680.

Code:
17:03:10: Adapter 1
17:03:10:   Video Adapter: NVIDIA GeForce GTX 680
17:03:10:   Video Adapter Dedicated Video Memory: 2083188736
17:03:10:   Video Adapter Shared System Memory: 2147807232
17:03:10: ------------------------------------------
17:03:10: Adapter 2
17:03:10:   Video Adapter: Intel(R) HD Graphics 4000
17:03:10:   Video Adapter Dedicated Video Memory: 503316480
17:03:10:   Video Adapter Shared System Memory: 1375731712
 

xD4rkFire

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

To find your display adapter device number, first open up device manager. Under display adapters, right click on your display adapter (in your case the GTX 680) and click properties. Under the general tab, you'll see "Location" and you'll see your device number there.
 

Geoning

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Xphome said:
Does x264 see the devices in the same order as OBS? I want to know if I should use opencl_device=1 or 2 since I want it to run on my GTX 680.

Code:
17:03:10: Adapter 1
17:03:10:   Video Adapter: NVIDIA GeForce GTX 680
17:03:10:   Video Adapter Dedicated Video Memory: 2083188736
17:03:10:   Video Adapter Shared System Memory: 2147807232
17:03:10: ------------------------------------------
17:03:10: Adapter 2
17:03:10:   Video Adapter: Intel(R) HD Graphics 4000
17:03:10:   Video Adapter Dedicated Video Memory: 503316480
17:03:10:   Video Adapter Shared System Memory: 1375731712
Open file "x264_lookahead.clbin" with notepad++

For me:
opencl_device=0 - Intel 4000

opencl_device=1 - GTX 660M

Code:
GeForce GTX 660M
NVIDIA Corporation
320.49
c8ef3d10dedcd2579b7ae8c9f0d18028
//
// Generated by NVIDIA NVVM Compiler
// Compiler built on Fri Jun 21 11:11:06 2013 (1371805866)
// Driver 
//
...
 

Xphome

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

xD4rkFire said:
To find your display adapter device number, first open up device manager. Under display adapters, right click on your display adapter (in your case the GTX 680) and click properties. Under the general tab, you'll see "Location" and you'll see your device number there.
GTX 680: PCI bus 1, device 0, function 0
HD 4000: PCI bus 0, device 2, function 0

Which doesn't help since opencl_device=0 doesn't work and by the order above the HD 4000 should be first but it isn't in OBS (Since PCI bus 0 is before 1).

EDIT:

Geoning said:
Xphome said:
Does x264 see the devices in the same order as OBS? I want to know if I should use opencl_device=1 or 2 since I want it to run on my GTX 680.

Code:
17:03:10: Adapter 1
17:03:10:   Video Adapter: NVIDIA GeForce GTX 680
17:03:10:   Video Adapter Dedicated Video Memory: 2083188736
17:03:10:   Video Adapter Shared System Memory: 2147807232
17:03:10: ------------------------------------------
17:03:10: Adapter 2
17:03:10:   Video Adapter: Intel(R) HD Graphics 4000
17:03:10:   Video Adapter Dedicated Video Memory: 503316480
17:03:10:   Video Adapter Shared System Memory: 1375731712
Open file "x264_lookahead.clbin" with notepad++

For me:
opencl_device=0 - Intel 4000

opencl_device=1 - GTX 660M

Code:
GeForce GTX 660M
NVIDIA Corporation
320.49
c8ef3d10dedcd2579b7ae8c9f0d18028
//
// Generated by NVIDIA NVVM Compiler
// Compiler built on Fri Jun 21 11:11:06 2013 (1371805866)
// Driver 
//
...
Ah, thanks.

EDIT2: opencl_device=1 it was.

Code:
GeForce GTX 680
NVIDIA Corporation
326.01
c8ef3d10dedcd2579b7ae8c9f0d18028
//
// Generated by NVIDIA NVVM Compiler
// Compiler built on Sat Jun 22 20:52:16 2013 (1371927136)
// Driver 
//
 

jesyjames

New Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

xD4rkFire said:
To find your display adapter device number, first open up device manager. Under display adapters, right click on your display adapter (in your case the GTX 680) and click properties. Under the general tab, you'll see "Location" and you'll see your device number there.
I have two GTX 670's. Currently, I have SLI disabled. Anyway to use just the second card for opencl?

Here is what it says:

Card 1: PCI bus 3, device 0, function 0
Card 2: PCI bus 4, device 0, function 0
 

xD4rkFire

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Hmm I guess I've been doing it wrong this whole time. When I try to open up x264_lookahead.clbin with Notepad++, I can't make any sense of what it says

Tahiti
Advanced Micro Devices, Inc.
1214.3 (VM)
c8ef3d10dedcd2579b7ae8c9f0d18028
ELF

^ that's what it looks like when I try and copy and paste the whole thing but this is what it looks like on my screen

http://i.imgur.com/RWKTcUb.png
 

Xphome

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

xD4rkFire said:
Hmm I guess I've been doing it wrong this whole time. When I try to open up x264_lookahead.clbin with Notepad++, I can't make any sense of what it says

Tahiti
Advanced Micro Devices, Inc.
1214.3 (VM)
c8ef3d10dedcd2579b7ae8c9f0d18028
ELF

^ that's what it looks like when I try and copy and paste the whole thing but this is what it looks like on my screen

http://i.imgur.com/RWKTcUb.png
Advanced Micro Devices = AMD
Radeon HD 7900 series is codenamed Tahiti
 

xD4rkFire

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Yes, but how do I find which device number to use for OpenCL?
 

Xphome

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

xD4rkFire said:
Yes, but how do I find which device number to use for OpenCL?
Delete the file then try a device number and see what it says in the file that it creates. (I guess this is how you do it since I don't see why it would make it for a device that isn't used.)
 

xD4rkFire

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

But if the file already says my GPU, doesn't that mean I already have the correct setting?
 

Xphome

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

xD4rkFire said:
But if the file already says my GPU, doesn't that mean I already have the correct setting?
Probably, if it doesn't say the same if you change the device number. You could change it and see if it changes anything in the file. I'm going to try it.

EDIT: Yep, if I change it to 0 the file changes.

Intel(R) HD Graphics 4000
Intel(R) Corporation
9.18.10.3071
c8ef3d10dedcd2579b7ae8c9f0d18028
ELF
 

xD4rkFire

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Going from opencl_device=0 to ...=1, it still says my HD7950 (Tahiti).
opencl_device= 2 is also the same result.

edit: However, in the log files, when I set it to opencl_device= 1 it shows

17:22:01: Using custom x264 settings: "opencl=true opencl_device=1"
17:22:01: x264: OpenCL: Unable to find a compatible device

but with =0

it's just

17:24:16: Using custom x264 settings: "opencl=true opencl_device=0
 

Luk

Member
Re: OBS 0.52.08 aquaman build - quicksync & capture improvem

Also QSV seems to be broken since 08. I was using 07 and QSV was working perfectly once I extended my desktop with a second fake-monitor using the iGPU.

Since 08 I can still activate QSV with and without the need to activate the second fake-monitor, but once I hit preview or stream, OBS stops working (program freezes).

Here are my two logfiles.

Code:
14:47:49: Open Broadcaster Software v0.52.08b aquaman build - 64bit ( ^ω^)
14:47:49: -------------------------------
14:47:49: CPU Name: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
14:47:49: CPU Speed: 3400MHz
14:47:49: Physical Memory:  16263MB Total, 12960MB Free
14:47:49: stepping id: 9, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 4, total cores 4
14:47:49: monitor 1: pos={0, 0}, size={1680, 1050}
14:47:49: Windows Version: 6.1 Build 7601 S
14:47:49: Aero is Disabled
14:47:49: -------------------------------
14:47:49: OBS Modules:
14:47:49: Base Address     Module
14:47:49: 000000003FE10000 OBS.exe
14:47:49: 00000000EF960000 OBSApi.dll
14:47:49: 00000000F4A70000 DShowPlugin.dll
14:47:49: 00000000F4AA0000 GraphicsCapture.dll
14:47:49: 00000000FC1A0000 NoiseGate.dll
14:47:49: 00000000F2430000 PSVPlugin.dll
14:47:49: ------------------------------------------
14:47:49: Adapter 1
14:47:49:   Video Adapter: NVIDIA GeForce GTX 580
14:47:49:   Video Adapter Dedicated Video Memory: 1560739840
14:47:49:   Video Adapter Shared System Memory: 2684235776
14:47:49: ------------------------------------------
14:47:49: Adapter 2
14:47:49:   Video Adapter: Intel(R) HD Graphics 4000
14:47:49:   Video Adapter Dedicated Video Memory: 67108864
14:47:49:   Video Adapter Shared System Memory: 1711276032
14:47:49: =====Stream Start: 2013-07-09, 14:47:49===============================================
14:47:49:   Multithreaded optimizations: On
14:47:49:   Base resolution: 1680x1050
14:47:49:   Output resolution: 1680x1050
14:47:49: ------------------------------------------
14:47:49: Loading up D3D10...
14:47:49: Playback device Default
14:47:49: ------------------------------------------
14:47:49: Using desktop audio input: Lautsprecher (Creative SB X-Fi)
14:47:49: ------------------------------------------
14:47:49: Using auxilary audio input: Mikrofon (Creative SB X-Fi)
14:47:49: ------------------------------------------
14:47:49: Audio Encoding: AAC
14:47:49:     bitrate: 128
14:47:49: Using graphics capture
14:47:49: Found QSV hardware support
14:47:49: ------------------------------------------
14:47:49: QSV version 1.6 using MFX_IMPL_HARDWARE_ANY (actual: MFX_IMPL_HARDWARE2 | MFX_IMPL_VIA_D3D11)
14:47:49: 
14:47:49: ===================================================================================
14:47:49: Error: QSV hardware acceleration unavailable due to a driver bug. Reduce the number
14:47:49:        of monitors connected to you graphics card or configure your Intel graphics
14:47:49:        card to be the primary device.
14:47:49:        Refer to http://software.intel.com/en-us/forums/topic/359368#comment-1722674
14:47:49:        for more information.
14:47:49: ===================================================================================
14:47:49: 
14:47:49: Continuing with decreased performance
14:47:49: Using 8 encode tasks
14:47:49: ------------------------------------------
14:47:49: Video Encoding: QSV
14:47:49:     fps: 50
14:47:49:     width: 1680, height: 1050
14:47:49:     target-usage: MFX_TARGETUSAGE_BEST_QUALITY
14:47:49:     CBR: no
14:47:49:     CFR: no
14:47:49:     max bitrate: 3500
14:47:49:     buffer size: 3496
14:47:49: ------------------------------------------
14:47:49: Error: all encode tasks in use, stalling pipeline
14:47:49: Error: encoder is taking too long, consider decreasing your FPS/increasing your bitrate
14:47:50: Error: all encode tasks in use, stalling pipeline
14:47:50: Error: encoder is taking too long, consider decreasing your FPS/increasing your bitrate

Code:
14:48:56: Open Broadcaster Software v0.52.08b aquaman build - 64bit ( ^ω^)
14:48:56: -------------------------------
14:48:56: CPU Name: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
14:48:56: CPU Speed: 3400MHz
14:48:56: Physical Memory:  16263MB Total, 12835MB Free
14:48:56: stepping id: 9, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 4, total cores 4
14:48:56: monitor 1: pos={0, 0}, size={1680, 1050}
14:48:56: monitor 2: pos={1680, 0}, size={1280, 720}
14:48:56: Windows Version: 6.1 Build 7601 S
14:48:56: Aero is Disabled
14:48:56: -------------------------------
14:48:56: OBS Modules:
14:48:56: Base Address     Module
14:48:56: 000000003F3E0000 OBS.exe
14:48:56: 00000000EF740000 OBSApi.dll
14:48:56: 00000000F6550000 DShowPlugin.dll
14:48:56: 00000000F4A70000 GraphicsCapture.dll
14:48:56: 00000000F2430000 NoiseGate.dll
14:48:56: 00000000FC1A0000 PSVPlugin.dll
14:48:56: ------------------------------------------
14:48:56: Adapter 1
14:48:56:   Video Adapter: NVIDIA GeForce GTX 580
14:48:56:   Video Adapter Dedicated Video Memory: 1560739840
14:48:56:   Video Adapter Shared System Memory: 2684235776
14:48:56: ------------------------------------------
14:48:56: Adapter 2
14:48:56:   Video Adapter: Intel(R) HD Graphics 4000
14:48:56:   Video Adapter Dedicated Video Memory: 67108864
14:48:56:   Video Adapter Shared System Memory: 1711276032
14:48:56: =====Stream Start: 2013-07-09, 14:48:56===============================================
14:48:56:   Multithreaded optimizations: On
14:48:56:   Base resolution: 1680x1050
14:48:56:   Output resolution: 1680x1050
14:48:56: ------------------------------------------
14:48:56: Loading up D3D10...
14:48:56: Playback device Default
14:48:56: ------------------------------------------
14:48:56: Using desktop audio input: Lautsprecher (Creative SB X-Fi)
14:48:56: ------------------------------------------
14:48:56: Using auxilary audio input: Mikrofon (Creative SB X-Fi)
14:48:56: ------------------------------------------
14:48:56: Audio Encoding: AAC
14:48:56:     bitrate: 128
14:48:56: Using graphics capture
14:48:56: Found QSV hardware support
14:48:56: ------------------------------------------
14:48:56: QSV version 1.6 using MFX_IMPL_HARDWARE_ANY (actual: MFX_IMPL_HARDWARE2 | MFX_IMPL_VIA_D3D11)
14:48:56: 
14:48:56: ===================================================================================
14:48:56: Error: QSV hardware acceleration unavailable due to a driver bug. Reduce the number
14:48:56:        of monitors connected to you graphics card or configure your Intel graphics
14:48:56:        card to be the primary device.
14:48:56:        Refer to http://software.intel.com/en-us/forums/topic/359368#comment-1722674
14:48:56:        for more information.
14:48:56: ===================================================================================
14:48:56: 
14:48:56: Continuing with decreased performance
14:48:56: Using 8 encode tasks
14:48:56: ------------------------------------------
14:48:56: Video Encoding: QSV
14:48:56:     fps: 50
14:48:56:     width: 1680, height: 1050
14:48:56:     target-usage: MFX_TARGETUSAGE_BEST_QUALITY
14:48:56:     CBR: no
14:48:56:     CFR: no
14:48:56:     max bitrate: 3500
14:48:56:     buffer size: 3496
14:48:56: ------------------------------------------
14:48:57: Error: all encode tasks in use, stalling pipeline
14:48:57: Error: encoder is taking too long, consider decreasing your FPS/increasing your bitrate
14:48:57: Error: all encode tasks in use, stalling pipeline
14:48:57: Error: encoder is taking too long, consider decreasing your FPS/increasing your bitrate
 
Status
Not open for further replies.
Top