OBS 0.51.01 game capture bugfixes test build

Status
Not open for further replies.

sickest

New Member
Same problem with Arma 2 now. Even having a problem when I went back to Xsplit. Almost like nothing will pick up the arma2oa.exe process.
 

Kyosji

New Member
Update on my issue with TF2 and other source engine games not working.

Ok, completely cleared the appdata. I re did my settings and tried TF2 again, same issue. I pulled up the CORRECT hook log and it showed a massive amount of failure.

Code:
2013-05-03, 19:15:03: we're booting up: 
19:15:03: (half life scientist) everything..  seems to be in order
19:15:03: D3D9 Present
19:15:03: GL Present
19:15:03: D3D9EndScene called
19:15:03: found d3d9 present params for window: Team Fortress 2 
19:15:03: D3DPRESENT_PARAMETERS {
19:15:03: 	BackBufferWidth: 1920
19:15:03: 	BackBufferHeight: 1080
19:15:03: 	BackBufferFormat: D3DFMT_A8R8G8B8
19:15:03: 	BackBufferCount: 1
19:15:03: 	MultiSampleType: D3DMULTISAMPLE_NONE
19:15:03: 	MultiSampleQuality: 0
19:15:03: 	SwapEffect: D3DSWAPEFFECT_DISCARD
19:15:03: 	hDeviceWindow: 1313974
19:15:03: 	Windowed: false
19:15:03: 	EnableAutoDepthStencil: true
19:15:03: 	AutoDepthStencilFormat: D3DFMT_D24S8
19:15:03: 	Flags: None
19:15:03: 	FullScreen_RefreshRateInHz: 60
19:15:03: 	PresentationInterval: 2147483648
19:15:03: };
19:15:03: successfully set up d3d9 hooks
19:15:03: D3D9Present called
19:15:03: DXGI Present
19:15:04: DoD3D9GPUHook: opening intermediary texture failed, result = 2147942487
19:15:04: ---------------------- Cleared D3D9 Capture ----------------------
19:15:04: D3D9EndScene called
19:15:11: D3D9Present called
19:15:11: DoD3D9GPUHook: opening intermediary texture failed, result = 2147942487
19:15:11: ---------------------- Cleared D3D9 Capture ----------------------
19:15:11: D3D9EndScene called
19:15:11: D3D9Present called
19:15:11: DoD3D9GPUHook: opening intermediary texture failed, result = 2147942487
19:15:11: ---------------------- Cleared D3D9 Capture ----------------------
19:15:11: D3D9EndScene called
19:15:11: D3D9Present called
19:15:11: DoD3D9GPUHook: opening intermediary texture failed, result = 2147942487
19:15:11: ---------------------- Cleared D3D9 Capture ----------------------
19:15:11: D3D9EndScene called
19:15:11: D3D9Present called
19:15:11: DoD3D9GPUHook: opening intermediary texture failed, result = 2147942487
19:15:11: ---------------------- Cleared D3D9 Capture ----------------------
19:15:11: D3D9EndScene called
19:15:11: D3D9Present called
19:15:11: DoD3D9GPUHook: opening intermediary texture failed, result = 2147942487
19:15:11: ---------------------- Cleared D3D9 Capture ----------------------
19:15:11: D3D9EndScene called
19:15:12: D3D9Present called
19:15:12: DoD3D9GPUHook: opening intermediary texture failed, result = 2147942487
19:15:12: ---------------------- Cleared D3D9 Capture ----------------------
19:15:12: D3D9EndScene called

It kept going on with the same error, I didn't see a reason to post the whole thing.

Latest log:

Code:
19:13:53: Open Broadcaster Software v0.51.01b (kamehameha test build) - 64bit ( ^ω^)
19:13:53: -------------------------------
19:13:53: CPU Name: AMD Phenom(tm) II X6 1055T Processor
19:13:53: CPU Speed: 2809MHz
19:13:53: Physical Memory:  16381MB Total, 11454MB Free
19:13:53: stepping id: 0, model 10, family 15, type 0, extmodel 8, extfamily 0, HTT 1, logical cores 6, total cores 6
19:13:53: monitor 1: pos={0, 0}, size={1920, 1080}
19:13:53: Windows Version: 6.0 Build 6002 S
19:13:53: Aero is Disabled
19:13:53: ------------------------------------------
19:13:53: Adapter 1
19:13:53:   Video Adapter: AMD Radeon HD 7800 Series
19:13:53:   Video Adapter Dedicated Video Memory: 1046683648
19:13:53:   Video Adapter Shared System Memory: 4025577472
19:13:53: =====Stream Start: 2013-05-03, 19:13:53===============================================
19:13:53:   Multithreaded optimizations: On
19:13:53:   Base resolution: 1920x1080
19:13:53:   Output resolution: 1280x720
19:13:53: ------------------------------------------
19:13:53: Loading up D3D10...
19:13:53: Playback device {0.0.0.00000000}.{dc0a0d31-d255-4f68-bd80-8bfca4225406}
19:13:53: ------------------------------------------
19:13:53: Using desktop audio input: Speakers (VIA High Definition Audio)
19:13:53: ------------------------------------------
19:13:53: Using auxilary audio input: Microphone (VIA High Definition Audio)
19:13:53: ------------------------------------------
19:13:53: Audio Encoding: MP3
19:13:53:     bitrate: 128
19:13:53: ------------------------------------------
19:13:53: Video Encoding: x264
19:13:53:     fps: 30
19:13:53:     width: 1280, height: 720
19:13:53:     preset: veryfast
19:13:53:     CBR: no
19:13:53:     CFR: no
19:13:53:     max bitrate: 2000
19:13:53:     buffer size: 2000
19:13:53:     quality: 9
19:13:53: ------------------------------------------
19:13:55: Using RTMP service: Twitch / Justin.tv
19:13:55:   Server selection: rtmp://live-mia.justin.tv/app
19:14:01: Total frames rendered: 226, number of frames that lagged: 0 (0.00%) (it's okay for some frames to lag)
19:14:04: librtmp error: RTMP_ReadPacket, failed to read RTMP packet header
19:14:04: Connection to rtmp://live-mia.justin.tv/app failed: Could not access the specified channel or stream key.  This could be because the key/channel is invalid, or because the server still thinks you are logged in.
19:14:04: Number of times waited to send: 0, Waited for a total of 0 bytes
19:14:04: Number of b-frames dropped: 0 (-1.$%), Number of p-frames dropped: 0 (-1.$%), Total 0 (-1.$%)
19:14:04: =====Stream End: 2013-05-03, 19:14:04=================================================
19:14:17: =====Stream Start: 2013-05-03, 19:14:17===============================================
19:14:17:   Multithreaded optimizations: On
19:14:17:   Base resolution: 1920x1080
19:14:17:   Output resolution: 1280x720
19:14:17: ------------------------------------------
19:14:17: Loading up D3D10...
19:14:17: Playback device {0.0.0.00000000}.{dc0a0d31-d255-4f68-bd80-8bfca4225406}
19:14:17: ------------------------------------------
19:14:17: Using desktop audio input: Speakers (VIA High Definition Audio)
19:14:17: ------------------------------------------
19:14:17: Using auxilary audio input: Microphone (VIA High Definition Audio)
19:14:17: ------------------------------------------
19:14:17: Audio Encoding: MP3
19:14:17:     bitrate: 128
19:14:17: Using graphics capture
19:14:17: ------------------------------------------
19:14:17: Video Encoding: x264
19:14:17:     fps: 30
19:14:17:     width: 1280, height: 720
19:14:17:     preset: veryfast
19:14:17:     CBR: no
19:14:17:     CFR: no
19:14:17:     max bitrate: 2000
19:14:17:     buffer size: 2000
19:14:17:     quality: 9
19:14:17: ------------------------------------------
19:14:19: Using RTMP service: Twitch / Justin.tv
19:14:19:   Server selection: rtmp://live-mia.justin.tv/app
19:14:21: SO_SNDBUF was at 8192
19:14:21: SO_SNDBUF is now 65536
19:14:43: Total frames rendered: 761, number of frames that lagged: 3 (0.39%) (it's okay for some frames to lag)
19:14:43: RTMPPublisher::SocketLoop: Aborting due to bStopping
19:14:43: Number of times waited to send: 0, Waited for a total of 0 bytes
19:14:43: Number of b-frames dropped: 0 (0%), Number of p-frames dropped: 0 (0%), Total 0 (0%)
19:14:43: =====Stream End: 2013-05-03, 19:14:43=================================================
19:14:56: =====Stream Start: 2013-05-03, 19:14:56===============================================
19:14:56:   Multithreaded optimizations: On
19:14:56:   Base resolution: 1920x1080
19:14:56:   Output resolution: 1280x720
19:14:56: ------------------------------------------
19:14:56: Loading up D3D10...
19:14:57: Playback device {0.0.0.00000000}.{dc0a0d31-d255-4f68-bd80-8bfca4225406}
19:14:57: ------------------------------------------
19:14:57: Using desktop audio input: Speakers (VIA High Definition Audio)
19:14:57: ------------------------------------------
19:14:57: Using auxilary audio input: Microphone (VIA High Definition Audio)
19:14:57: ------------------------------------------
19:14:57: Audio Encoding: MP3
19:14:57:     bitrate: 128
19:14:57: Using graphics capture
19:14:57: ------------------------------------------
19:14:57: Video Encoding: x264
19:14:57:     fps: 30
19:14:57:     width: 1280, height: 720
19:14:57:     preset: veryfast
19:14:57:     CBR: no
19:14:57:     CFR: no
19:14:57:     max bitrate: 2000
19:14:57:     buffer size: 2000
19:14:57:     quality: 9
19:14:57: ------------------------------------------
19:14:58: Using RTMP service: Twitch / Justin.tv
19:14:58:   Server selection: rtmp://live-mia.justin.tv/app
19:15:00: SO_SNDBUF was at 8192
19:15:00: SO_SNDBUF is now 65536
19:19:53: Total frames rendered: 8860, number of frames that lagged: 20 (0.23%) (it's okay for some frames to lag)
19:19:53: RTMPPublisher::SocketLoop: Aborting due to bStopping
19:19:53: Number of times waited to send: 0, Waited for a total of 0 bytes
19:19:53: Number of b-frames dropped: 0 (0%), Number of p-frames dropped: 0 (0%), Total 0 (0%)
19:19:53: =====Stream End: 2013-05-03, 19:19:53=================================================
19:24:56: 
19:24:56: Profiler results:
19:24:56: 
19:24:56: ==============================================================
19:24:56: frame - [100%] [avg time: 2.951 ms] [avg calls per frame: 1] [children: 73.1%] [unaccounted: 26.9%]
19:24:56: | scene->Preprocess - [0.0678%] [avg time: 0.002 ms] [avg calls per frame: 1]
19:24:56: | video encoding and uploading - [73%] [avg time: 2.155 ms] [avg calls per frame: 1] [children: 71.3%] [unaccounted: 1.73%]
19:24:56: | | CopyResource - [0.474%] [avg time: 0.014 ms] [avg calls per frame: 0]
19:24:56: | | conversion to 4:2:0 - [0.576%] [avg time: 0.017 ms] [avg calls per frame: 0]
19:24:56: | | call to encoder - [69.7%] [avg time: 2.058 ms] [avg calls per frame: 0]
19:24:56: | | sending stuff out - [0.508%] [avg time: 0.015 ms] [avg calls per frame: 0]
19:24:56: ==============================================================
19:24:56:
 

mrradicaled

New Member
Okay I actually managed to get ArmA 2 to work for a minute before OBS kicked that admin rights message out again...

I try doing game capture via hotkey, and it works on a lot of games but in arma I get this:

Code:
DXGI Present
DXGI: Found D3D 10
DoD3D10Hook: success
Keepalive no longer found on d3d910.0, freeing capture data
 

dehixem

Member
Um, I don't know if this is related to my own pc, but every time I try to use Window Capture it won't work unless I use "compatibility mode".
It never happened to me before :s

I don't know if this is a bad thing or not though
 

Jim

Jim
Developer
Actually I failed to put important code into the inject helper to make it elevated, so if you were trying to capture with the 64bit version it would fail. I'll fix it and re-upload

kyosji - I'm actually really frustrated that you are getting this problem, because I myself don't get any problems. You're not using any overlays or any third party graphics apps or anything of that nature are you? They will interfere with game capture often in these ways
 

fragga

New Member
Hi everybody!

I've come from another thread with black screen

Here are my logs:
0.51b
Open Broadcaster Software v0.51b - 64bit ( ^ω^)
-------------------------------
CPU Name: Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
CPU Speed: 2394MHz
Physical Memory: 6091MB Total, 2591MB Free
stepping id: 7, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 4, total cores 2
monitor 1: pos={0, 0}, size={1366, 768}
Windows Version: 6.1 Build 7601 S
Aero is Disabled
------------------------------------------
Adapter 1
Video Adapter: Intel(R) HD Graphics Family
Video Adapter Dedicated Video Memory: 2194472960
Video Adapter Shared System Memory: 2925453312
=====Stream Start: 2013-05-04, 22:48:34===============================================
Multithreaded optimizations: On
Base resolution: 1366x768
Output resolution: 1364x768
------------------------------------------
Loading up D3D10...
Playback device Default
------------------------------------------
Using desktop audio input: Громкоговорители и головные телефоны (IDT High Definition Audio CODEC)
------------------------------------------
Using auxilary audio input: Массив встр. микрофона (IDT High Definition Audio CODEC)
------------------------------------------
Audio Encoding: AAC
bitrate: 160
Using bitmap image
------------------------------------------
Video Encoding: x264
fps: 30
width: 1364, height: 768
preset: veryfast
CBR: no
CFR: no
max bitrate: 2500
buffer size: 2500
quality: 8
------------------------------------------
++++++++++++++++++++++++++++++++++++++++++++++++++++++
New Scene
Using bitmap image
Using graphics capture
SharedTexCapture hooked
SharedTexCapture hooked
SharedTexCapture hooked
SharedTexCapture hooked
SharedTexCapture hooked
Total frames rendered: 5233, number of frames that lagged: 3 (0.06%) (it's okay for some frames to lag)
=====Stream End: 2013-05-04, 22:51:29=================================================
=====Stream Start: 2013-05-04, 22:51:30===============================================
Multithreaded optimizations: On
Base resolution: 1366x768
Output resolution: 1364x768
------------------------------------------
Loading up D3D10...
Playback device Default
------------------------------------------
Using desktop audio input: Громкоговорители и головные телефоны (IDT High Definition Audio CODEC)
------------------------------------------
Using auxilary audio input: Массив встр. микрофона (IDT High Definition Audio CODEC)
------------------------------------------
Audio Encoding: AAC
bitrate: 160
Using bitmap image
Using graphics capture
------------------------------------------
Video Encoding: x264
fps: 30
width: 1364, height: 768
preset: veryfast
CBR: no
CFR: no
max bitrate: 3000
buffer size: 3000
quality: 8
------------------------------------------
Total frames rendered: 1, number of frames that lagged: 0 (0.00%) (it's okay for some frames to lag)
=====Stream End: 2013-05-04, 22:51:31=================================================
=====Stream Start: 2013-05-04, 22:51:31===============================================
Multithreaded optimizations: On
Base resolution: 1366x768
Output resolution: 1364x768
------------------------------------------
Loading up D3D10...
Playback device Default
------------------------------------------
Using desktop audio input: Громкоговорители и головные телефоны (IDT High Definition Audio CODEC)
------------------------------------------
Using auxilary audio input: Массив встр. микрофона (IDT High Definition Audio CODEC)
------------------------------------------
Audio Encoding: AAC
bitrate: 160
Using bitmap image
Using graphics capture
------------------------------------------
Video Encoding: x264
fps: 30
width: 1364, height: 768
preset: veryfast
CBR: no
CFR: no
max bitrate: 3000
buffer size: 3000
quality: 8
------------------------------------------
Total frames rendered: 138, number of frames that lagged: 0 (0.00%) (it's okay for some frames to lag)
=====Stream End: 2013-05-04, 22:51:37=================================================
------------------------------------------

Profiler results:

==============================================================
frame - [100%] [avg time: 2.538 ms] [avg calls per frame: 1] [children: 82.2%] [unaccounted: 17.8%]
| scene->Preprocess - [0.0394%] [avg time: 0.001 ms] [avg calls per frame: 1]
| video encoding and uploading - [82.2%] [avg time: 2.086 ms] [avg calls per frame: 1] [children: 81.1%] [unaccounted: 1.06%]
| | CopyResource - [1.18%] [avg time: 0.03 ms] [avg calls per frame: 0]
| | conversion to 4:2:0 - [2.09%] [avg time: 0.053 ms] [avg calls per frame: 0]
| | call to encoder - [77.8%] [avg time: 1.974 ms] [avg calls per frame: 0]
| | sending stuff out - [0.0788%] [avg time: 0.002 ms] [avg calls per frame: 0]
==============================================================
51.01
00:56:59: Open Broadcaster Software v0.51.01b (kamehameha test build) - 32bit (´・ω・`)
00:56:59: -------------------------------
00:56:59: CPU Name: Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
00:56:59: CPU Speed: 2394MHz
00:56:59: Physical Memory: 4095MB Total, 4072MB Free
00:56:59: stepping id: 7, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 4, total cores 2
00:56:59: monitor 1: pos={0, 0}, size={1366, 768}
00:56:59: Windows Version: 6.1 Build 7601 S
00:56:59: Aero is Disabled
00:56:59: ------------------------------------------
00:56:59: Adapter 1
00:56:59: Video Adapter: Intel(R) HD Graphics Family
00:56:59: Video Adapter Dedicated Video Memory: 2194472960
00:56:59: Video Adapter Shared System Memory: 2100428800
00:56:59: =====Stream Start: 2013-05-05, 00:56:59===============================================
00:56:59: Multithreaded optimizations: On
00:56:59: Base resolution: 1366x768
00:56:59: Output resolution: 1364x768
00:56:59: ------------------------------------------
00:57:01: Loading up D3D10...
00:57:02: Playback device Default
00:57:02: ------------------------------------------
00:57:02: Using desktop audio input: Громкоговорители и головные телефоны (IDT High Definition Audio CODEC)
00:57:02: ------------------------------------------
00:57:02: Using auxilary audio input: Массив встр. микрофона (IDT High Definition Audio CODEC)
00:57:03: ------------------------------------------
00:57:03: Audio Encoding: AAC
00:57:03: bitrate: 160
00:57:03: Using bitmap image
00:57:03: ------------------------------------------
00:57:03: Video Encoding: x264
00:57:03: fps: 30
00:57:03: width: 1364, height: 768
00:57:03: preset: veryfast
00:57:03: CBR: no
00:57:03: CFR: no
00:57:03: max bitrate: 3000
00:57:03: buffer size: 3000
00:57:03: quality: 8
00:57:03: ------------------------------------------
00:57:04: ++++++++++++++++++++++++++++++++++++++++++++++++++++++
00:57:04: New Scene
00:57:04: Using bitmap image
00:57:04: Using graphics capture
00:57:13: ++++++++++++++++++++++++++++++++++++++++++++++++++++++
00:57:13: New Scene
00:57:54: Using graphics capture
00:57:54: SharedTexCapture hooked
00:58:07: Total frames rendered: 1900, number of frames that lagged: 3 (0.16%) (it's okay for some frames to lag)
00:58:07: =====Stream End: 2013-05-05, 00:58:07=================================================
00:58:08:
00:58:08: Profiler results:
00:58:08:
00:58:08: ==============================================================
00:58:08: frame - [100%] [avg time: 3.014 ms] [avg calls per frame: 1] [children: 72.6%] [unaccounted: 27.4%]
00:58:08: | scene->Preprocess - [0%] [avg time: 0 ms] [avg calls per frame: 1]
00:58:08: | video encoding and uploading - [72.6%] [avg time: 2.189 ms] [avg calls per frame: 1] [children: 70.9%] [unaccounted: 1.73%]
00:58:08: | | CopyResource - [1.23%] [avg time: 0.037 ms] [avg calls per frame: 0]
00:58:08: | | conversion to 4:2:0 - [1.69%] [avg time: 0.051 ms] [avg calls per frame: 0]
00:58:08: | | call to encoder - [67.9%] [avg time: 2.048 ms] [avg calls per frame: 0]
00:58:08: | | sending stuff out - [0.0332%] [avg time: 0.001 ms] [avg calls per frame: 0]
00:58:08: ==============================================================
00:58:08:
and caprute hook I had last time
2013-05-05, 00:57:54: we're booting up:
00:57:54: (half life scientist) everything.. seems to be in order
00:57:54: D3D9 Present
00:57:54: D3D9EndScene called
00:57:54: found d3d9 present params for window: Diablo III
00:57:54: D3DPRESENT_PARAMETERS {
00:57:54: BackBufferWidth: 1366
00:57:54: BackBufferHeight: 768
00:57:54: BackBufferFormat: D3DFMT_A8R8G8B8
00:57:54: BackBufferCount: 1
00:57:54: MultiSampleType: D3DMULTISAMPLE_NONE
00:57:54: MultiSampleQuality: 0
00:57:54: SwapEffect: D3DSWAPEFFECT_DISCARD
00:57:54: hDeviceWindow: 721870
00:57:54: Windowed: true
00:57:54: EnableAutoDepthStencil: false
00:57:54: AutoDepthStencilFormat: D3DFMT_UNKNOWN
00:57:54: Flags: None
00:57:54: FullScreen_RefreshRateInHz: 0
00:57:54: PresentationInterval: 2147483648
00:57:54: };
00:57:54: successfully set up d3d9 hooks
00:57:54: D3D9Present called
00:57:54: DXGI Present
00:57:54: DoD3D9GPUHook: success00:57:54:
00:57:54: D3DSURFACE_DESC {
00:57:54: Format: D3DFMT_A8R8G8B8
00:57:54: Type: D3DRTYPE_SURFACE
00:57:54: Usage: D3DUSAGE_RENDERTARGET
00:57:54: Pool: D3DPOOL_DEFAULT
00:57:54: MultiSampleType: D3DMULTISAMPLE_NONE
00:57:54: MultiSampleQuality: 0
00:57:54: Width: 1366
00:57:54: Height: 768
00:57:54: };
00:57:54: successfully capturing d3d9 frames via GPU
00:58:07: ---------------------- Cleared D3D9 Capture ----------------------
00:58:07: D3D9EndScene called
00:58:07: D3D9Present called
Game I want to stream is World of Warcraft. Last time I also tried D3 as you can see in capture hook.
The rest of my story here viewtopic.php?f=5&t=3718
 

Kyosji

New Member
The only overlay I have running is Rainmeter. I just disabled it and my antivirus and tried again with teh same results. Black screen but I have all audio.

It;s very odd because I can use those other software that shall not be named and it shows fine.
 

VinnyJ

New Member
Game is captured upside-down.
Ds4Gr8E.png

captureHookLog.txt
Code:
2013-05-05, 01:03:33: we're booting up: 
01:03:33: (half life scientist) everything..  seems to be in order
01:03:33: GL Present
01:03:33: setting up gl data
01:03:33: DoGLCPUHook: success
01:03:33: successfully capturing gl frames via RAM
01:04:23: stop requested, terminating gl capture
01:04:24: ---------------------- Cleared OpenGL Capture ----------------------
01:04:30: ---------------------- Cleared OpenGL Capture ----------------------

2013-05-05-0103-11.log
Code:
01:03:32: Open Broadcaster Software v0.51.01b (kamehameha test build) - 64bit ( ^ω^)
01:03:32: -------------------------------
01:03:32: CPU Name: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
01:03:32: CPU Speed: 3392MHz
01:03:32: Physical Memory:  32716MB Total, 28624MB Free
01:03:32: stepping id: 9, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 8, total cores 4
01:03:32: monitor 1: pos={0, 0}, size={1920, 1080}
01:03:32: monitor 2: pos={1920, 156}, size={1280, 1024}
01:03:32: Windows Version: 6.2 Build 9200 
01:03:32: Aero is Enabled
01:03:32: ------------------------------------------
01:03:32: Adapter 1
01:03:32:   Video Adapter: NVIDIA GeForce GTX 650
01:03:32:   Video Adapter Dedicated Video Memory: 1014824960
01:03:32:   Video Adapter Shared System Memory: 3221221376
01:03:32: =====Stream Start: 2013-05-05, 01:03:32===============================================
01:03:32:   Multithreaded optimizations: On
01:03:32:   Base resolution: 1920x1080
01:03:32:   Output resolution: 1920x1080
01:03:32: ------------------------------------------
01:03:32: Loading up D3D10...
01:03:33: Playback device {0.0.0.00000000}.{cb737c6a-7e09-481c-8c03-7c7b6384695c}
01:03:33: ------------------------------------------
01:03:33: Using desktop audio input: Speakers (Yeti Stereo Microphone)
01:03:33: ------------------------------------------
01:03:33: Using auxilary audio input: Microphone (Yeti Stereo Microphone)
01:03:33: ------------------------------------------
01:03:33: Audio Encoding: AAC
01:03:33:     bitrate: 96
01:03:33: ------------------------------------------
01:03:33:     device: Logitech HD Pro Webcam C920,
01:03:33:     device id \\?\usb#vid_046d&pid_082d&mi_00#6&1d878d77&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{bbefb6c7-2fc4-4139-bb8b-a58bba724083},
01:03:33:     chosen type: I420, usingFourCC: false, res: 1920x1080 - 1920x1080, frameIntervals: 333333-2000000, fourCC: 'I420'
01:03:33:     audio device: Disable,
01:03:33:     audio device id Disabled,
01:03:33: 
01:03:33: Using directshow input
01:03:33: Using graphics capture
01:03:33: ------------------------------------------
01:03:33: Video Encoding: x264
01:03:33:     fps: 45
01:03:33:     width: 1920, height: 1080
01:03:33:     preset: veryfast
01:03:33:     CBR: no
01:03:33:     CFR: no
01:03:33:     max bitrate: 2000
01:03:33:     buffer size: 2000
01:03:33:     quality: 8
01:03:33: ------------------------------------------
01:03:33: using memory capture
01:04:23: Total frames rendered: 2248, number of frames that lagged: 1 (0.04%) (it's okay for some frames to lag)
01:04:24: =====Stream End: 2013-05-05, 01:04:24=================================================
01:04:27: 
01:04:27: Profiler results:
01:04:27: 
01:04:27: ==============================================================
01:04:27: frame - [100%] [avg time: 6.642 ms] [avg calls per frame: 1] [children: 54.6%] [unaccounted: 45.4%]
01:04:27: | scene->Preprocess - [12.4%] [avg time: 0.822 ms] [avg calls per frame: 1]
01:04:27: | video encoding and uploading - [42.2%] [avg time: 2.804 ms] [avg calls per frame: 1] [children: 41.8%] [unaccounted: 0.422%]
01:04:27: | | CopyResource - [0.301%] [avg time: 0.02 ms] [avg calls per frame: 0]
01:04:27: | | conversion to 4:2:0 - [0.0602%] [avg time: 0.004 ms] [avg calls per frame: 0]
01:04:27: | | call to encoder - [41.4%] [avg time: 2.751 ms] [avg calls per frame: 0]
01:04:27: | | sending stuff out - [0.0151%] [avg time: 0.001 ms] [avg calls per frame: 0]
01:04:27: ==============================================================
01:04:27:
 

azthec

New Member
I can't get any games to stream at fullscreen with game capture (the only way I have found is using dxtory, and thats crazy unstable).

Normal Log:
Code:
19:53:15: Open Broadcaster Software v0.51.01b (kamehameha test build) - 64bit ( ^ω^)
19:53:15: -------------------------------
19:53:15: CPU Name: Intel(R) Core(TM) i7-3720QM CPU @ 2.60GHz
19:53:15: CPU Speed: 2594MHz
19:53:15: Physical Memory:  8088MB Total, 4383MB Free
19:53:15: stepping id: 9, model 10, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 8, total cores 4
19:53:15: monitor 1: pos={0, 0}, size={1920, 1080}
19:53:15: Windows Version: 6.1 Build 7601 S
19:53:15: Aero is Enabled
19:53:15: ------------------------------------------
19:53:15: Adapter 1
19:53:15:   Video Adapter: Intel(R) HD Graphics 4000
19:53:15:   Video Adapter Dedicated Video Memory: 2194874368
19:53:15:   Video Adapter Shared System Memory: 3972253696
19:53:15: =====Stream Start: 2013-05-04, 19:53:15===============================================
19:53:15:   Multithreaded optimizations: On
19:53:15:   Base resolution: 1920x1080
19:53:15:   Output resolution: 1920x1080
19:53:15: ------------------------------------------
19:53:15: Loading up D3D10...
19:53:15: Playback device Default
19:53:15: ------------------------------------------
19:53:15: Using desktop audio input: Altifalantes (Realtek High Definition Audio)
19:53:15: ------------------------------------------
19:53:15: Using auxilary audio input: Microfone (Realtek High Definition Audio)
19:53:15: ------------------------------------------
19:53:15: Audio Encoding: AAC
19:53:15:     bitrate: 128
19:53:15: Using Monitor Capture
19:53:15: ------------------------------------------
19:53:15: Video Encoding: x264
19:53:15:     fps: 30
19:53:15:     width: 1920, height: 1080
19:53:15:     preset: veryfast
19:53:15:     CBR: no
19:53:15:     CFR: no
19:53:15:     max bitrate: 850
19:53:15:     buffer size: 510
19:53:15:     quality: 6
19:53:15: ------------------------------------------
19:53:18: Using RTMP service: Twitch / Justin.tv
19:53:18:   Server selection: rtmp://live-lhr.justin.tv/app
19:53:19: SO_SNDBUF was at 8192
19:53:19: SO_SNDBUF is now 65536
19:53:25: ++++++++++++++++++++++++++++++++++++++++++++++++++++++
19:53:25:   New Scene
19:53:25: ------------------------------------------
19:53:25:     device: Dxtory Video 1,
19:53:25:     device id (null),
19:53:25:     chosen type: RGB32, usingFourCC: false, res: 1920x1080 - 1920x1080, frameIntervals: 333333-333333, fourCC: 00000000
19:53:25:     audio device: Disable,
19:53:25:     audio device id Disabled,
19:53:25: 
19:53:25: Using directshow input

Hook Log:
Code:
2013-05-04, 19:36:23: we're booting up: 
19:36:23: (half life scientist) everything..  seems to be in order
19:36:23: D3D9 Present
19:36:23: DXGI Present
19:36:23: DXGI: Found D3D 11
19:36:23: setting up d3d11 data
19:36:23: ---------------------- Cleared D3D11 Capture ----------------------
19:36:23: found dxgi format (dx11) of: 28, size: {1920, 1080}, multisampled: true
19:36:23: DoD3D11Hook: success
19:36:23: successfully capturing d3d11 frames via GPU
19:36:26: ---------------------- Cleared D3D11 Capture ----------------------
19:36:26: DXGI: Found D3D 11
19:36:26: setting up d3d11 data
19:36:26: ---------------------- Cleared D3D11 Capture ----------------------
19:36:26: DoD3D11Hook: success
19:36:26: ---------------------- Cleared D3D11 Capture ----------------------
19:36:28: DXGI: Found D3D 11
19:36:28: setting up d3d11 data
19:36:28: ---------------------- Cleared D3D11 Capture ----------------------
19:36:28: DoD3D11Hook: success
19:36:28: successfully capturing d3d11 frames via GPU
19:36:59: ---------------------- Cleared D3D11 Capture ----------------------
19:36:59: DXGI: Found D3D 11
19:36:59: setting up d3d11 data
19:36:59: ---------------------- Cleared D3D11 Capture ----------------------
19:36:59: DoD3D11Hook: success
19:36:59: successfully capturing d3d11 frames via GPU
19:37:04: stop requested, terminating d3d11 capture
19:37:04: ---------------------- Cleared D3D11 Capture ----------------------
19:37:18: DoD3D11Hook: success
19:37:18: successfully capturing d3d11 frames via GPU
19:37:22: ---------------------- Cleared D3D11 Capture ----------------------
19:37:22: DXGI: Found D3D 11
19:37:22: setting up d3d11 data
19:37:22: ---------------------- Cleared D3D11 Capture ----------------------
19:37:22: DoD3D11Hook: success
19:37:23: ---------------------- Cleared D3D11 Capture ----------------------
19:37:24: DXGI: Found D3D 11
19:37:24: setting up d3d11 data
19:37:24: ---------------------- Cleared D3D11 Capture ----------------------
19:37:24: DoD3D11Hook: success
19:37:24: successfully capturing d3d11 frames via GPU
19:37:35: stop requested, terminating d3d11 capture
19:37:35: ---------------------- Cleared D3D11 Capture ----------------------
19:40:06: ---------------------- Cleared D3D11 Capture ----------------------
19:40:06: DXGI: Found D3D 11
19:40:06: setting up d3d11 data
19:40:06: ---------------------- Cleared D3D11 Capture ----------------------
19:40:06: ---------------------- Cleared D3D11 Capture ----------------------
19:40:08: DXGI: Found D3D 11
19:40:08: setting up d3d11 data
19:40:08: ---------------------- Cleared D3D11 Capture ----------------------
19:44:14: DoD3D11Hook: success
19:44:14: successfully capturing d3d11 frames via GPU
19:44:23: stop requested, terminating d3d11 capture
19:44:23: ---------------------- Cleared D3D11 Capture ----------------------
19:44:25: ---------------------- Cleared D3D11 Capture ----------------------
19:44:25: DXGI: Found D3D 11
19:44:25: setting up d3d11 data
19:44:25: ---------------------- Cleared D3D11 Capture ----------------------
19:44:25: ---------------------- Cleared D3D11 Capture ----------------------
19:44:27: DXGI: Found D3D 11
19:44:27: setting up d3d11 data
19:44:27: ---------------------- Cleared D3D11 Capture ----------------------
19:44:28: DoD3D11Hook: success
19:44:28: successfully capturing d3d11 frames via GPU
19:44:50: stop requested, terminating d3d11 capture
19:44:50: ---------------------- Cleared D3D11 Capture ----------------------
19:45:04: ---------------------- Cleared D3D11 Capture ----------------------
19:45:04: DXGI: Found D3D 11
19:45:04: setting up d3d11 data
19:45:04: ---------------------- Cleared D3D11 Capture ----------------------
19:45:04: ---------------------- Cleared D3D11 Capture ----------------------
19:45:06: DXGI: Found D3D 11
19:45:06: setting up d3d11 data
19:45:06: ---------------------- Cleared D3D11 Capture ----------------------
19:50:02: ---------------------- Cleared D3D11 Capture ----------------------
19:50:03: DXGI: Found D3D 11
19:50:03: setting up d3d11 data
19:50:03: ---------------------- Cleared D3D11 Capture ----------------------
19:50:03: found dxgi format (dx11) of: 28, size: {1920, 1080}, multisampled: true

EDIT: Just looked at the log and I now believe its trying to use my integrated intel card as oposed to my ATI Radeon 7970m, therefore I assume the program still has issues running on switchable graphics system (enduro).
 

dehixem

Member
Other possible issue i've encountered : I just tried the 0.51.01 and after streaming a bit Twitch did not save it in my video list. Am I the only one having this new issue ?
 

Hajimoto

New Member
I am not sure when this change happened but I have noticed that I am no longer able to add select the option "Capture Layered Windows". There are some onscreen elements that I utilize like timers and such that are no longer able to be captured.

I have checked previous scenes that have an element that was created utilizing the "Capture Layered Windows" option and when i go to properties the option is shown. As a primitive work around I have copied the entire scene and then pruned it down to the elements I wish to use and then rename it accordingly.

Is there something I am over looking that would accomplish the same result as "Capture Layered Windows"?
 

dodgepong

Administrator
Forum Admin
Hajimoto said:
I am not sure when this change happened but I have noticed that I am no longer able to add select the option "Capture Layered Windows". There are some onscreen elements that I utilize like timers and such that are no longer able to be captured.

I have checked previous scenes that have an element that was created utilizing the "Capture Layered Windows" option and when i go to properties the option is shown. As a primitive work around I have copied the entire scene and then pruned it down to the elements I wish to use and then rename it accordingly.

Is there something I am over looking that would accomplish the same result as "Capture Layered Windows"?
There's no Capture Layered Windows on a Window Capture source, but there is on Monitor Capture...is that the issue? In versions previous to 0.50, Monitor Capture and Window Capture were part of the source capture source type.
 

dodgepong

Administrator
Forum Admin
KeenKTron the hook file should have timestamps too, if it was generated by the test version of OBS. Can you run the test version and attempt a capture of your game again to make sure you get a capture with the latest version? (or better yet, delete the capture hook log and let the test version re-create it so you know it is updated)

EDIT: Having looked at your log again, it looks like you are getting error code 5, which is indicative of a hack shield, so it looks like the test build still isn't working for that game. I'm surprised that that error was not logged to the capture hook log though.
 

Hajimoto

New Member
dodgepong said:
There's no Capture Layered Windows on a Window Capture source, but there is on Monitor Capture...is that the issue? In versions previous to 0.50, Monitor Capture and Window Capture were part of the source capture source type.

I have made a quick YOUTUBE VIDEO that does a better job asking the question than my anemic writing skills :) The Monitor Capture does not have the program hook and the Window Capture no longer has the Capture Layered Windows option so I am not able to duplicate previously created scene elements.

Thank you

Hajimoto
 
Status
Not open for further replies.
Top