Resource icon

All Versions NVIDIA NvEnc Guide

#1
findal submitted a new resource:

NVIDIA NvEnc Guide - Guide on how to use NvEnc with OBS for the best possible image quality

ABOUT THIS GUIDE
The objective of this guide is to help you understand how to use the NVIDIA encoder, NvEnc, in OBS. We have tried to simplify some of the concepts to make this accessible to a wider audience. If you think we can improve any part of this guide or find any issues or mistakes, please post below and we will be happy to update it.

INDEX

  1. NvEnc in OBS
    1. About NvEnc
    2. Recommended Settings
    3. Recording
  2. Additional Info on...
Read more about this resource...
 
#2
Sorry about my English. Good afternoon. I want to use two graphics cards in OBS. One video card handles the game. The second processes the stream. Both Nvidia video cards. Can I specify OBS which video card to use for streams? Nvence encoders are on both video cards and if it is simple to choose it in settings + to specify GPU of the second video card that the first all the same is loaded by 10 percent. The second video card is loaded by 35 percent, which means that the GPU of the video card processes the stream. I really have to transfer the entire load from the stream to the second video card. To the first during the stream did not experience the load. Help please.
 

Baz

New Member
#4
The paragraph on codecs is duplicated, and also contains a typo in the second sentence ("There one used for streaming is H.264", supposed to be "The" I guess)
 
#6
Amazing Guide.... Thank you.. Just a little Oopsy though. You said
"RECOMMENDED SETTINGS
These are our recommended settings for OBS Studio 23.0 and up"

We are only currently on 22.0.2
 
#8
So, I tried these settings and I get the "overload" message. I wonder how is that possible. RTX 2060 6GB, i5 8600K OC to 4.1GHz, 8GB RAM, Upload Speed 15Mbps, Bitrate set on 6000. In-game resolution 1080p, output 1080p 60fps, FTL enabled, is it too much? I have the settings exactly like in the picture under Advanced Settings. I tried to uncheck "look-ahead" and "pshyco visual tuning" and changed the Preset to Quality, also changed from Lancoz to Bilinear. Still get the same results. I did the auto-config wizard setup to see if something changes, and it gave me 10k bitrate with base and output set to 1080p @ 60fps with encoder nvenc but i didn't tried go live with those since with the first set up failed me. I did the auto-config again with the game running in the background and it changed again to base 1080p and output 720p with software x264 encoder and bitrate around 4500 and streamed with that and i noticed the message disappeared but the gameplay was a bit "choppy". Again, how is that possible on an 8600K CPU? I also tried to lower the graphics settings to low on everything, still the same. The game in question is Vampyr. Could it be that the game is really bad optimized? I noticed another thing on the in-game fps, no matter what i had changed in the graphics settings and vsync, the fps remained locked at 60. Another thing i noticed in the task manager the gpu was loaded around 40-50%. How can it be? Don't tell me the gfx card sucks lol.
PS: Sorry for the long comment :D. Great Guide btw!
 
#9
Hi Brinion,

If you are streaming with NvEnc, the overload problem can only happen if your settings are too high and you try to do 4K streaming, or if you are maxing out the GPU. I would use the guide settings and do 2 things:
1) Turn Game Mode off in windows.
2) Put a frame cap on the game.

After that, make sure the GPU load is below 90% when the game is running (not when you are alt tabbed; some games reduce FPS when the game is in the background so it may seem as if your GPU load is OK, but the moment you go back it spikes up again). If the issue persists, I would recommend posting it in the support section of the forum with a copy of your log.
 
#10
the overload problem can only happen if your settings are too high and you try to do 4K streaming
By "settings too high" you mean what, exactly?

Did you read what I wrote previously or ...?
I said I followed the guide exactly as shown in here. I streamed @1080p not 4K, and it showed the overload problem. Turned Game Mode off in Win, tried with VSync ON/OFF, low settings, etc. still get the message.

Nevermind all this. Moving on. Thanks anyway.
 
#11
Wanted to share my results with the NVENC H.264 (New) codec, when did some tests to Twitch and Youtube.

PC specs:

OS: Win 10 x64
CPU: Ryzen 5 1600 @ 3.8 GHz
RAM: 16 Gb (4 x 4) DDR4 @ 2933 MHz
GPU: GTX 1070 (slightly overclocked)
Hard Drives: 2x Samsung SSD's (250 Gb & 1 Tb) + 1 Tb external HDD (Samsung)


OBS Version: 23.1.0

Stream settings:

Encoder: NVidia NVENC H.264 (New)
Enforce Streaming Service Encoder Settings: Enabled
Rate Control: CBR
Bitrate: 8500
Keyframe Interval: 0
Preset: Max Quality
Profile: High
Look Ahead: Enabled
Psycho Visual Tuning: Enabled
GPU: 0
Max B-frames: 2






Twitch test:
https://www.twitch.tv/videos/410402448


Youtube test:
https://www.youtube.com/watch?v=9DDyqw3LWBw







It's easy to see that Twitch has superior smoothness and image quality compard to Youtube, but there's still some work to do with the new codec. So far, my impression is that the new codec tries to hide some of pixelation with blurring the pixels, which then results image getting blurred a bit. It looks much better than the old codec for sure, and needs less resources/bandwith to run butter smooth stream (at least on Twitch), but the blurring isn't going to help to hide the fact, that there is still some of that pixelation going on. Not as much as it used to be thou, I'm very impressed by this sort of progress on this.
 
Top